Have a question? Want to report an issue? Contact JFrog support

Versions Compared

Key

  • This line was added.
  • This line was removed.
  • Formatting was changed.
Section
Column
width75%

 

Overview

Artifactory provides tight integration with Bamboo through the Bamboo Artifactory Plug-in. Beyond managing efficient deployment of your artifacts to Artifactory, the plug-in lets you capture information about artifacts deployed, dependencies resolved, environment data associated with the Bamboo build runs and more, that effectively facilitates fully traceable builds.

Build Runner Support

The Bamboo Artifactory Plug-in currently provides full support for Maven 3, Gradle and Ivy builds.  Generic Deployment Tasks are available for all builder types.

Tip
titleBefore you begin

Please refer to the general information about Artifactory's Build Integration before using the Bamboo Artifactory Plug-in.

Info
titleSource Code Available!

The Bamboo Artifactory Plugin is an open-source project on GitHub which you can freely browse and fork.

Download

Latest:

Download version 2.0.2 which is compatible with Bamboo 5.15.x.

Upgrading to version 2.x from version 1.x of the plugin requires new installation steps. Please refer to Installing the Plugin for more details.


Older:

VersionDownload linkCompatibility
2.1.0.1Download Bamboo 5.14.x
1.13.0Download Bamboo 5.14.x
1.11.2Download Bamboo 5.13.x
1.11.1Download Bamboo 5.12.x
1.10.3Download Bamboo 5.11.x
1.10.1 Download Bamboo 5.10.x
1.9.2 Download Bamboo 5.9.x
1.7.7 Download Bamboo 5.8.x

 


Installing the Plugin

Requirements

  • Artifactory 2.2.5 or later. For best results and optimized communication, we recommend using the latest version of Artifactory.
  • Artifactory Pro is required for advanced features, such as License Control and enhanced Build Integration.
  • Maven 3.
  • Gradle 0.9 or later.
  • Ant and Ivy 2.1.0 or later.

Upgrading to Versions 2.x from Versions 1.x

If you are currently using a version of the plugin below 2.0.0 and would like to upgrade to version 2.0.0 or above, you need to migrate your Artifactory configuration data to the format expected by the type 2 plugin as described in the following steps:

1. If you are not already on version 1.13.0 of the plugin, upgrade to that version first.

2. From Bamboo Administration | Artifactory Plugin, click on the "Migrate data to v2" button.

3. Remove plugin version 1.13.0 and restart Bamboo.

4. You're now ready to install version 2.x according to the below instructions.

Installing Versions 2.x

From version 2.0.0, the Bamboo Artifactory Plugin is released as a type 2 plugin. You can read about installing type 2 plugins in the Bamboo documentation for Installing add-ons.

Installing Versions 1.x

Note
titleRemove older versions

If you have an older version of the plug-in, be sure to remove it before upgrading to a newer one

For versions below 2.0.0, the plugin was released as a type 1 plugin and is deployed to Bamboo by placing the packaged plugin jar file into the $BAMBOO_INSTALLATION_HOME/atlassian-bamboo/WEB-INF/lib folder and restarting Bamboo.

For more details please refer to the Bamboo documentation for Installing Plugins type 1 add-ons.

Column
Info
iconfalse
titlePage Contents

Table of Contents
maxLevel4
minLevel2

...