Uploaded image for project: 'Gradle Artifactory Plug-in'
  1. Gradle Artifactory Plug-in
  2. GAP-257

Cannot notify listeners of type ProjectEvaluationListener as these listeners are already being notified.

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: High
    • Resolution: Fixed
    • Affects Version/s: 4.4.0
    • Fix Version/s: 4.4.4
    • Labels:
    • Regression:
      Yes

      Description

      Projects that build correctly are now throwing this error: "Cannot notify listeners of type ProjectEvaluationListener as these listeners are already being notified." - see full stack trace below. I verified that they are fine building against version 4.3.0 - so a change in 4.4.0 has introduced this defect. I am using Gradle 2.14 to build the project (and JDK 1.8)

      Our config is similar to: https://dzone.com/articles/publish-jar-artifact-using

      The error in the stack trace below is happening on the "from components.java" line from the config snippet below.

      configure(subprojects - project(':api')) {
          //    tasks.withType(Compile) {
          //        options.compilerArgs << "-Xlint:unchecked"
          //        options.compilerArgs << "-Xlint:deprecation"
          //    }
          apply from: file("${System.getProperty("user.home")}/.gradle/settings.gradle")
          apply from: "${gradleHome}/artifactory.gradle"
          //Publishing task for deploying standalone JAR file
          publishing {
              publications {
                  mavenJava(MavenPublication) {
                      from components.java
                  }
              }
          }
          artifactoryPublish{
              dependsOn jar
          }
      }
      

      Line 25 is the "from components.java" from above.

      14:15:05.131 [ERROR] [org.gradle.BuildExceptionReporter]        at build_9rgzpyop00576dho8qwsabaql$_run_closure2$_closure5$_closure7$_closure8.doCall(<PATH TO BUILD.GRADLE HERE>/build.gradle:25)
      

      Here is the stack trace snippet:

      14:15:04.617 [DEBUG] [org.gradle.model.internal.registry.DefaultModelRegistry] Project :data-load - Registering model element 'tasks.distZip' (hidden = false)
      14:15:04.627 [DEBUG] [org.gradle.model.internal.registry.DefaultModelRegistry] Project :data-load - Registering model element 'tasks.distTar' (hidden = false)
      14:15:04.627 [DEBUG] [org.gradle.model.internal.registry.DefaultModelRegistry] Project :data-load - Registering model element 'tasks.assembleDist' (hidden = false)
      14:15:04.633 [DEBUG] [org.gradle.model.internal.registry.DefaultModelRegistry] Project :data-load - Registering model element 'tasks.installDist' (hidden = false)
      14:15:04.650 [DEBUG] [org.gradle.model.internal.registry.DefaultModelRegistry] Project :data-load - Registering model element 'tasks.run' (hidden = false)
      14:15:04.683 [DEBUG] [org.gradle.model.internal.registry.DefaultModelRegistry] Project :data-load - Registering model element 'tasks.startScripts' (hidden = false)
      14:15:04.687 [DEBUG] [org.gradle.model.internal.registry.DefaultModelRegistry] Project :data-load - Registering model element 'tasks.installApp' (hidden = false)
      14:15:04.695 [DEBUG] [org.gradle.api.internal.artifacts.mvnsettings.DefaultLocalMavenRepositoryLocator] No local repository in Settings file defined. Using default path: <HOME DIRECTORY HERE>/.m2/repository
      14:15:04.941 [DEBUG] [org.gradle.configuration.project.BuildScriptProcessor] Timing: Running the build script took 0.446 secs
      14:15:04.945 [DEBUG] [org.jfrog.gradle.plugin.artifactory.extractor.listener.ProjectsEvaluatedBuildListener] Artifactory URL: <HTTP URL TO OUR ARTIFACTORY HERE>
      14:15:05.085 [DEBUG] [org.jfrog.gradle.plugin.artifactory.extractor.listener.ProjectsEvaluatedBuildListener] Artifactory URL: <HTTP URL TO OUR ARTIFACTORY HERE>
      14:15:05.090 [DEBUG] [org.jfrog.gradle.plugin.artifactory.extractor.listener.ProjectsEvaluatedBuildListener] Artifactory URL: <HTTP URL TO OUR ARTIFACTORY HERE>
      14:15:05.093 [DEBUG] [org.jfrog.gradle.plugin.artifactory.extractor.listener.ProjectsEvaluatedBuildListener] Artifactory URL: <HTTP URL TO OUR ARTIFACTORY HERE>
      14:15:05.096 [DEBUG] [org.jfrog.gradle.plugin.artifactory.extractor.listener.ProjectsEvaluatedBuildListener] Artifactory URL: <HTTP URL TO OUR ARTIFACTORY HERE>
      14:15:05.114 [ERROR] [org.gradle.BuildExceptionReporter]
      14:15:05.121 [ERROR] [org.gradle.BuildExceptionReporter] FAILURE: Build failed with an exception.
      14:15:05.121 [ERROR] [org.gradle.BuildExceptionReporter]
      14:15:05.121 [ERROR] [org.gradle.BuildExceptionReporter] * Where:
      14:15:05.121 [ERROR] [org.gradle.BuildExceptionReporter] Build file '<PATH TO BUILD.GRADLE HERE>/build.gradle' line: 25
      14:15:05.121 [ERROR] [org.gradle.BuildExceptionReporter]
      14:15:05.121 [ERROR] [org.gradle.BuildExceptionReporter] * What went wrong:
      14:15:05.121 [ERROR] [org.gradle.BuildExceptionReporter] A problem occurred configuring project ':data-load'.
      14:15:05.122 [ERROR] [org.gradle.BuildExceptionReporter] > Failed to notify project evaluation listener.
      14:15:05.122 [ERROR] [org.gradle.BuildExceptionReporter]    > A problem occurred configuring project ':<PROJECT NAME HERE>-core'.
      14:15:05.122 [ERROR] [org.gradle.BuildExceptionReporter]       > Cannot notify listeners of type ProjectEvaluationListener as these listeners are already being notified.
      14:15:05.122 [ERROR] [org.gradle.BuildExceptionReporter]    > A problem occurred configuring project ':<PROJECT NAME HERE>-core'.
      14:15:05.122 [ERROR] [org.gradle.BuildExceptionReporter]       > Cannot notify listeners of type ProjectEvaluationListener as these listeners are already being notified.
      14:15:05.122 [ERROR] [org.gradle.BuildExceptionReporter]    > A problem occurred configuring project ':<PROJECT NAME HERE>-core'.
      14:15:05.122 [ERROR] [org.gradle.BuildExceptionReporter]       > Cannot notify listeners of type ProjectEvaluationListener as these listeners are already being notified.
      14:15:05.122 [ERROR] [org.gradle.BuildExceptionReporter]    > A problem occurred configuring project ':<PROJECT NAME HERE>-core'.
      14:15:05.122 [ERROR] [org.gradle.BuildExceptionReporter]       > Cannot notify listeners of type ProjectEvaluationListener as these listeners are already being notified.
      14:15:05.123 [ERROR] [org.gradle.BuildExceptionReporter]    > A problem occurred configuring project ':<PROJECT NAME HERE>-core'.
      14:15:05.123 [ERROR] [org.gradle.BuildExceptionReporter]       > Cannot notify listeners of type ProjectEvaluationListener as these listeners are already being notified.
      14:15:05.123 [ERROR] [org.gradle.BuildExceptionReporter]
      14:15:05.123 [ERROR] [org.gradle.BuildExceptionReporter] * Exception is:
      14:15:05.125 [ERROR] [org.gradle.BuildExceptionReporter] org.gradle.api.ProjectConfigurationException: A problem occurred configuring project ':data-load'.
      14:15:05.125 [ERROR] [org.gradle.BuildExceptionReporter]        at org.gradle.configuration.project.LifecycleProjectEvaluator.addConfigurationFailure(LifecycleProjectEvaluator.java:79)
      14:15:05.125 [ERROR] [org.gradle.BuildExceptionReporter]        at org.gradle.configuration.project.LifecycleProjectEvaluator.notifyAfterEvaluate(LifecycleProjectEvaluator.java:74)
      14:15:05.126 [ERROR] [org.gradle.BuildExceptionReporter]        at org.gradle.configuration.project.LifecycleProjectEvaluator.evaluate(LifecycleProjectEvaluator.java:61)
      14:15:05.126 [ERROR] [org.gradle.BuildExceptionReporter]        at org.gradle.api.internal.project.AbstractProject.evaluate(AbstractProject.java:540)
      14:15:05.126 [ERROR] [org.gradle.BuildExceptionReporter]        at org.gradle.api.internal.project.AbstractProject.evaluate(AbstractProject.java:93)
      14:15:05.126 [ERROR] [org.gradle.BuildExceptionReporter]        at org.gradle.execution.TaskPathProjectEvaluator.configureHierarchy(TaskPathProjectEvaluator.java:47)
      14:15:05.126 [ERROR] [org.gradle.BuildExceptionReporter]        at org.gradle.configuration.DefaultBuildConfigurer.configure(DefaultBuildConfigurer.java:35)
      14:15:05.126 [ERROR] [org.gradle.BuildExceptionReporter]        at org.gradle.initialization.DefaultGradleLauncher$2.run(DefaultGradleLauncher.java:124)
      14:15:05.126 [ERROR] [org.gradle.BuildExceptionReporter]        at org.gradle.internal.Factories$1.create(Factories.java:22)
      14:15:05.126 [ERROR] [org.gradle.BuildExceptionReporter]        at org.gradle.internal.progress.DefaultBuildOperationExecutor.run(DefaultBuildOperationExecutor.java:91)
      14:15:05.126 [ERROR] [org.gradle.BuildExceptionReporter]        at org.gradle.internal.progress.DefaultBuildOperationExecutor.run(DefaultBuildOperationExecutor.java:53)
      14:15:05.126 [ERROR] [org.gradle.BuildExceptionReporter]        at org.gradle.initialization.DefaultGradleLauncher.doBuildStages(DefaultGradleLauncher.java:121)
      14:15:05.126 [ERROR] [org.gradle.BuildExceptionReporter]        at org.gradle.initialization.DefaultGradleLauncher.access$200(DefaultGradleLauncher.java:32)
      14:15:05.126 [ERROR] [org.gradle.BuildExceptionReporter]        at org.gradle.initialization.DefaultGradleLauncher$1.create(DefaultGradleLauncher.java:98)
      14:15:05.127 [ERROR] [org.gradle.BuildExceptionReporter]        at org.gradle.initialization.DefaultGradleLauncher$1.create(DefaultGradleLauncher.java:92)
      14:15:05.127 [ERROR] [org.gradle.BuildExceptionReporter]        at org.gradle.internal.progress.DefaultBuildOperationExecutor.run(DefaultBuildOperationExecutor.java:91)
      14:15:05.127 [ERROR] [org.gradle.BuildExceptionReporter]        at org.gradle.internal.progress.DefaultBuildOperationExecutor.run(DefaultBuildOperationExecutor.java:63)
      14:15:05.127 [ERROR] [org.gradle.BuildExceptionReporter]        at org.gradle.initialization.DefaultGradleLauncher.doBuild(DefaultGradleLauncher.java:92)
      14:15:05.127 [ERROR] [org.gradle.BuildExceptionReporter]        at org.gradle.initialization.DefaultGradleLauncher.run(DefaultGradleLauncher.java:83)
      14:15:05.127 [ERROR] [org.gradle.BuildExceptionReporter]        at org.gradle.launcher.exec.InProcessBuildActionExecuter$DefaultBuildController.run(InProcessBuildActionExecuter.java:99)
      14:15:05.127 [ERROR] [org.gradle.BuildExceptionReporter]        at org.gradle.tooling.internal.provider.ExecuteBuildActionRunner.run(ExecuteBuildActionRunner.java:28)
      14:15:05.127 [ERROR] [org.gradle.BuildExceptionReporter]        at org.gradle.launcher.exec.ChainingBuildActionRunner.run(ChainingBuildActionRunner.java:35)
      14:15:05.127 [ERROR] [org.gradle.BuildExceptionReporter]        at org.gradle.launcher.exec.InProcessBuildActionExecuter.execute(InProcessBuildActionExecuter.java:48)
      14:15:05.127 [ERROR] [org.gradle.BuildExceptionReporter]        at org.gradle.launcher.exec.InProcessBuildActionExecuter.execute(InProcessBuildActionExecuter.java:30)
      14:15:05.127 [ERROR] [org.gradle.BuildExceptionReporter]        at org.gradle.launcher.exec.ContinuousBuildActionExecuter.execute(ContinuousBuildActionExecuter.java:81)
      14:15:05.127 [ERROR] [org.gradle.BuildExceptionReporter]        at org.gradle.launcher.exec.ContinuousBuildActionExecuter.execute(ContinuousBuildActionExecuter.java:46)
      14:15:05.128 [ERROR] [org.gradle.BuildExceptionReporter]        at org.gradle.launcher.exec.DaemonUsageSuggestingBuildActionExecuter.execute(DaemonUsageSuggestingBuildActionExecuter.java:51)
      14:15:05.128 [ERROR] [org.gradle.BuildExceptionReporter]        at org.gradle.launcher.exec.DaemonUsageSuggestingBuildActionExecuter.execute(DaemonUsageSuggestingBuildActionExecuter.java:28)
      14:15:05.128 [ERROR] [org.gradle.BuildExceptionReporter]        at org.gradle.launcher.cli.RunBuildAction.run(RunBuildAction.java:43)
      14:15:05.128 [ERROR] [org.gradle.BuildExceptionReporter]        at org.gradle.internal.Actions$RunnableActionAdapter.execute(Actions.java:173)
      14:15:05.128 [ERROR] [org.gradle.BuildExceptionReporter]        at org.gradle.launcher.cli.CommandLineActionFactory$ParseAndBuildAction.execute(CommandLineActionFactory.java:239)
      14:15:05.128 [ERROR] [org.gradle.BuildExceptionReporter]        at org.gradle.launcher.cli.CommandLineActionFactory$ParseAndBuildAction.execute(CommandLineActionFactory.java:212)
      14:15:05.128 [ERROR] [org.gradle.BuildExceptionReporter]        at org.gradle.launcher.cli.JavaRuntimeValidationAction.execute(JavaRuntimeValidationAction.java:35)
      14:15:05.128 [ERROR] [org.gradle.BuildExceptionReporter]        at org.gradle.launcher.cli.JavaRuntimeValidationAction.execute(JavaRuntimeValidationAction.java:24)
      14:15:05.128 [ERROR] [org.gradle.BuildExceptionReporter]        at org.gradle.launcher.cli.ExceptionReportingAction.execute(ExceptionReportingAction.java:33)
      14:15:05.128 [ERROR] [org.gradle.BuildExceptionReporter]        at org.gradle.launcher.cli.ExceptionReportingAction.execute(ExceptionReportingAction.java:22)
      14:15:05.128 [ERROR] [org.gradle.BuildExceptionReporter]        at org.gradle.launcher.cli.CommandLineActionFactory$WithLogging.execute(CommandLineActionFactory.java:205)
      14:15:05.128 [ERROR] [org.gradle.BuildExceptionReporter]        at org.gradle.launcher.cli.CommandLineActionFactory$WithLogging.execute(CommandLineActionFactory.java:169)
      14:15:05.128 [ERROR] [org.gradle.BuildExceptionReporter]        at org.gradle.launcher.Main.doAction(Main.java:33)
      14:15:05.129 [ERROR] [org.gradle.BuildExceptionReporter]        at org.gradle.launcher.bootstrap.EntryPoint.run(EntryPoint.java:45)
      14:15:05.129 [ERROR] [org.gradle.BuildExceptionReporter]        at org.gradle.launcher.bootstrap.ProcessBootstrap.runNoExit(ProcessBootstrap.java:55)
      14:15:05.129 [ERROR] [org.gradle.BuildExceptionReporter]        at org.gradle.launcher.bootstrap.ProcessBootstrap.run(ProcessBootstrap.java:36)
      14:15:05.129 [ERROR] [org.gradle.BuildExceptionReporter]        at org.gradle.launcher.GradleMain.main(GradleMain.java:23)
      14:15:05.129 [ERROR] [org.gradle.BuildExceptionReporter] Caused by: org.gradle.internal.event.ListenerNotificationException: Failed to notify project evaluation listener.
      14:15:05.129 [ERROR] [org.gradle.BuildExceptionReporter]        at org.gradle.internal.event.AbstractBroadcastDispatch.dispatch(AbstractBroadcastDispatch.java:55)
      14:15:05.129 [ERROR] [org.gradle.BuildExceptionReporter]        at org.gradle.internal.event.DefaultListenerManager$EventBroadcast$ListenerDispatch.dispatch(DefaultListenerManager.java:221)
      14:15:05.129 [ERROR] [org.gradle.BuildExceptionReporter]        at org.gradle.internal.event.DefaultListenerManager$EventBroadcast$ListenerDispatch.dispatch(DefaultListenerManager.java:209)
      14:15:05.129 [ERROR] [org.gradle.BuildExceptionReporter]        at org.gradle.internal.event.AbstractBroadcastDispatch.dispatch(AbstractBroadcastDispatch.java:44)
      14:15:05.129 [ERROR] [org.gradle.BuildExceptionReporter]        at org.gradle.internal.event.BroadcastDispatch.dispatch(BroadcastDispatch.java:79)
      14:15:05.129 [ERROR] [org.gradle.BuildExceptionReporter]        at org.gradle.internal.event.BroadcastDispatch.dispatch(BroadcastDispatch.java:30)
      14:15:05.129 [ERROR] [org.gradle.BuildExceptionReporter]        at org.gradle.internal.dispatch.ProxyDispatchAdapter$DispatchingInvocationHandler.invoke(ProxyDispatchAdapter.java:93)
      14:15:05.130 [ERROR] [org.gradle.BuildExceptionReporter]        at com.sun.proxy.$Proxy11.afterEvaluate(Unknown Source)
      14:15:05.130 [ERROR] [org.gradle.BuildExceptionReporter]        at org.gradle.internal.dispatch.ReflectionDispatch.dispatch(ReflectionDispatch.java:35)
      14:15:05.130 [ERROR] [org.gradle.BuildExceptionReporter]        at org.gradle.internal.dispatch.ReflectionDispatch.dispatch(ReflectionDispatch.java:24)
      14:15:05.130 [ERROR] [org.gradle.BuildExceptionReporter]        at org.gradle.internal.event.AbstractBroadcastDispatch.dispatch(AbstractBroadcastDispatch.java:44)
      14:15:05.130 [ERROR] [org.gradle.BuildExceptionReporter]        at org.gradle.internal.event.BroadcastDispatch.dispatch(BroadcastDispatch.java:79)
      14:15:05.130 [ERROR] [org.gradle.BuildExceptionReporter]        at org.gradle.internal.event.BroadcastDispatch.dispatch(BroadcastDispatch.java:30)
      14:15:05.130 [ERROR] [org.gradle.BuildExceptionReporter]        at org.gradle.internal.dispatch.ProxyDispatchAdapter$DispatchingInvocationHandler.invoke(ProxyDispatchAdapter.java:93)
      14:15:05.130 [ERROR] [org.gradle.BuildExceptionReporter]        at com.sun.proxy.$Proxy11.afterEvaluate(Unknown Source)
      14:15:05.130 [ERROR] [org.gradle.BuildExceptionReporter]        at org.gradle.configuration.project.LifecycleProjectEvaluator.notifyAfterEvaluate(LifecycleProjectEvaluator.java:67)
      14:15:05.130 [ERROR] [org.gradle.BuildExceptionReporter]        ... 41 more
      14:15:05.130 [ERROR] [org.gradle.BuildExceptionReporter] Caused by: org.gradle.api.ProjectConfigurationException: A problem occurred configuring project ':<PROJECT NAME HERE>-core'.
      14:15:05.130 [ERROR] [org.gradle.BuildExceptionReporter]        at org.gradle.configuration.project.LifecycleProjectEvaluator.addConfigurationFailure(LifecycleProjectEvaluator.java:79)
      14:15:05.130 [ERROR] [org.gradle.BuildExceptionReporter]        at org.gradle.configuration.project.LifecycleProjectEvaluator.evaluate(LifecycleProjectEvaluator.java:49)
      14:15:05.131 [ERROR] [org.gradle.BuildExceptionReporter]        at org.gradle.api.internal.project.AbstractProject.evaluate(AbstractProject.java:540)
      14:15:05.131 [ERROR] [org.gradle.BuildExceptionReporter]        at org.gradle.api.internal.project.AbstractProject.evaluate(AbstractProject.java:93)
      14:15:05.131 [ERROR] [org.gradle.BuildExceptionReporter]        at org.gradle.api.publish.internal.ProjectDependencyPublicationResolver.resolve(ProjectDependencyPublicationResolver.java:35)
      14:15:05.131 [ERROR] [org.gradle.BuildExceptionReporter]        at org.gradle.api.publish.maven.internal.publication.DefaultMavenPublication.addProjectDependency(DefaultMavenPublication.java:120)
      14:15:05.131 [ERROR] [org.gradle.BuildExceptionReporter]        at org.gradle.api.publish.maven.internal.publication.DefaultMavenPublication.from(DefaultMavenPublication.java:111)
      14:15:05.131 [ERROR] [org.gradle.BuildExceptionReporter]        at build_9rgzpyop00576dho8qwsabaql$_run_closure2$_closure5$_closure7$_closure8.doCall(<PATH TO BUILD.GRADLE HERE>/build.gradle:25)
      14:15:05.131 [ERROR] [org.gradle.BuildExceptionReporter]        at org.gradle.api.internal.ClosureBackedAction.execute(ClosureBackedAction.java:67)
      14:15:05.131 [ERROR] [org.gradle.BuildExceptionReporter]        at org.gradle.api.internal.AbstractPolymorphicDomainObjectContainer.create(AbstractPolymorphicDomainObjectContainer.java:65)
      14:15:05.131 [ERROR] [org.gradle.BuildExceptionReporter]        at org.gradle.api.internal.PolymorphicDomainObjectContainerConfigureDelegate._configure(PolymorphicDomainObjectContainerConfigureDelegate.java:44)
      14:15:05.131 [ERROR] [org.gradle.BuildExceptionReporter]        at org.gradle.internal.metaobject.ConfigureDelegate.invokeMethod(ConfigureDelegate.java:68)
      14:15:05.131 [ERROR] [org.gradle.BuildExceptionReporter]        at build_9rgzpyop00576dho8qwsabaql$_run_closure2$_closure5$_closure7.doCall(<PATH TO BUILD.GRADLE HERE>/build.gradle:24)
      14:15:05.132 [ERROR] [org.gradle.BuildExceptionReporter]        at org.gradle.api.internal.ClosureBackedAction.execute(ClosureBackedAction.java:67)
      14:15:05.132 [ERROR] [org.gradle.BuildExceptionReporter]        at org.gradle.util.ConfigureUtil.configureSelf(ConfigureUtil.java:149)
      14:15:05.132 [ERROR] [org.gradle.BuildExceptionReporter]        at org.gradle.api.internal.AbstractNamedDomainObjectContainer.configure(AbstractNamedDomainObjectContainer.java:70)
      14:15:05.132 [ERROR] [org.gradle.BuildExceptionReporter]        at org.gradle.api.internal.AbstractNamedDomainObjectContainer.configure(AbstractNamedDomainObjectContainer.java:25)
      14:15:05.132 [ERROR] [org.gradle.BuildExceptionReporter]        at org.gradle.api.internal.ClosureBackedAction.execute(ClosureBackedAction.java:59)
      14:15:05.132 [ERROR] [org.gradle.BuildExceptionReporter]        at org.gradle.api.publish.internal.DefaultPublishingExtension.publications(DefaultPublishingExtension.java:48)
      14:15:05.132 [ERROR] [org.gradle.BuildExceptionReporter]        at org.gradle.api.publish.internal.DefaultPublishingExtension_Decorated.publications(Unknown Source)
      14:15:05.132 [ERROR] [org.gradle.BuildExceptionReporter]        at build_9rgzpyop00576dho8qwsabaql$_run_closure2$_closure5.doCall(<PATH TO BUILD.GRADLE HERE>/build.gradle:23)
      14:15:05.132 [ERROR] [org.gradle.BuildExceptionReporter]        at org.gradle.api.internal.ClosureBackedAction.execute(ClosureBackedAction.java:67)
      14:15:05.132 [ERROR] [org.gradle.BuildExceptionReporter]        at org.gradle.listener.ActionBroadcast.execute(ActionBroadcast.java:39)
      14:15:05.132 [ERROR] [org.gradle.BuildExceptionReporter]        at org.gradle.api.internal.plugins.ExtensionsStorage$DeferredConfigurableExtensionHolder.configureNow(ExtensionsStorage.java:183)
      14:15:05.132 [ERROR] [org.gradle.BuildExceptionReporter]        at org.gradle.api.internal.plugins.ExtensionsStorage$DeferredConfigurableExtensionHolder.get(ExtensionsStorage.java:162)
      14:15:05.133 [ERROR] [org.gradle.BuildExceptionReporter]        at org.gradle.api.internal.plugins.ExtensionsStorage.getByType(ExtensionsStorage.java:77)
      14:15:05.133 [ERROR] [org.gradle.BuildExceptionReporter]        at org.gradle.api.internal.plugins.DefaultConvention.getByType(DefaultConvention.java:113)
      14:15:05.133 [ERROR] [org.gradle.BuildExceptionReporter]        at org.jfrog.gradle.plugin.artifactory.task.helper.TaskHelperPublications.publications(TaskHelperPublications.java:79)
      14:15:05.133 [ERROR] [org.gradle.BuildExceptionReporter]        at org.jfrog.gradle.plugin.artifactory.task.ArtifactoryTask.publications(ArtifactoryTask.java:89)
      14:15:05.133 [ERROR] [org.gradle.BuildExceptionReporter]        at org.gradle.internal.metaobject.BeanDynamicObject$MetaClassAdapter.invokeMethod(BeanDynamicObject.java:374)
      14:15:05.133 [ERROR] [org.gradle.BuildExceptionReporter]        at org.gradle.internal.metaobject.BeanDynamicObject.invokeMethod(BeanDynamicObject.java:169)
      14:15:05.133 [ERROR] [org.gradle.BuildExceptionReporter]        at org.gradle.internal.metaobject.CompositeDynamicObject.invokeMethod(CompositeDynamicObject.java:96)
      14:15:05.133 [ERROR] [org.gradle.BuildExceptionReporter]        at org.gradle.internal.metaobject.MixInClosurePropertiesAsMethodsDynamicObject.invokeMethod(MixInClosurePropertiesAsMethodsDynamicObject.java:30)
      14:15:05.133 [ERROR] [org.gradle.BuildExceptionReporter]        at org.gradle.internal.metaobject.ConfigureDelegate.invokeMethod(ConfigureDelegate.java:59)
      14:15:05.133 [ERROR] [org.gradle.BuildExceptionReporter]        at artifactory_3e3101l7h95p0lo4vicnlu10c$_run_closure2$_closure7$_closure10.doCall(<HOME DIRECTORY HERE>/shared/artifactory.gradle:81)
      14:15:05.133 [ERROR] [org.gradle.BuildExceptionReporter]        at org.gradle.api.internal.ClosureBackedAction.execute(ClosureBackedAction.java:67)
      14:15:05.133 [ERROR] [org.gradle.BuildExceptionReporter]        at org.gradle.util.ConfigureUtil.configureSelf(ConfigureUtil.java:137)
      14:15:05.134 [ERROR] [org.gradle.BuildExceptionReporter]        at org.gradle.api.internal.AbstractTask.configure(AbstractTask.java:522)
      14:15:05.134 [ERROR] [org.gradle.BuildExceptionReporter]        at org.gradle.api.internal.AbstractTask.configure(AbstractTask.java:76)
      14:15:05.134 [ERROR] [org.gradle.BuildExceptionReporter]        at org.gradle.util.ConfigureUtil.configure(ConfigureUtil.java:104)
      14:15:05.134 [ERROR] [org.gradle.BuildExceptionReporter]        at org.jfrog.gradle.plugin.artifactory.task.BuildInfoBaseTask.projectsEvaluated(BuildInfoBaseTask.java:178)
      14:15:05.134 [ERROR] [org.gradle.BuildExceptionReporter]        at org.jfrog.gradle.plugin.artifactory.task.BuildInfoBaseTask$projectsEvaluated.call(Unknown Source)
      14:15:05.134 [ERROR] [org.gradle.BuildExceptionReporter]        at org.jfrog.gradle.plugin.artifactory.extractor.listener.ProjectsEvaluatedBuildListener$_afterEvaluate_closure1.doCall(ProjectsEvaluatedBuildListener.groovy:43)
      14:15:05.134 [ERROR] [org.gradle.BuildExceptionReporter]        at org.jfrog.gradle.plugin.artifactory.extractor.listener.ProjectsEvaluatedBuildListener.afterEvaluate(ProjectsEvaluatedBuildListener.groovy:42)
      14:15:05.134 [ERROR] [org.gradle.BuildExceptionReporter]        at org.gradle.internal.dispatch.ReflectionDispatch.dispatch(ReflectionDispatch.java:35)
      14:15:05.134 [ERROR] [org.gradle.BuildExceptionReporter]        at org.gradle.internal.dispatch.ReflectionDispatch.dispatch(ReflectionDispatch.java:24)
      14:15:05.134 [ERROR] [org.gradle.BuildExceptionReporter]        at org.gradle.internal.event.DefaultListenerManager$ListenerDetails.dispatch(DefaultListenerManager.java:249)
      14:15:05.135 [ERROR] [org.gradle.BuildExceptionReporter]        at org.gradle.internal.event.DefaultListenerManager$ListenerDetails.dispatch(DefaultListenerManager.java:229)
      14:15:05.135 [ERROR] [org.gradle.BuildExceptionReporter]        at org.gradle.internal.event.AbstractBroadcastDispatch.dispatch(AbstractBroadcastDispatch.java:44)
      14:15:05.135 [ERROR] [org.gradle.BuildExceptionReporter]        ... 56 more
      14:15:05.135 [ERROR] [org.gradle.BuildExceptionReporter] Caused by: java.lang.IllegalStateException: Cannot notify listeners of type ProjectEvaluationListener as these listeners are already being notified.
      14:15:05.135 [ERROR] [org.gradle.BuildExceptionReporter]        at org.gradle.internal.event.DefaultListenerManager$EventBroadcast.startNotification(DefaultListenerManager.java:170)
      14:15:05.135 [ERROR] [org.gradle.BuildExceptionReporter]        at org.gradle.internal.event.DefaultListenerManager$EventBroadcast.access$300(DefaultListenerManager.java:112)
      14:15:05.135 [ERROR] [org.gradle.BuildExceptionReporter]        at org.gradle.internal.event.DefaultListenerManager$EventBroadcast$ListenerDispatch.dispatch(DefaultListenerManager.java:219)
      14:15:05.135 [ERROR] [org.gradle.BuildExceptionReporter]        at org.gradle.internal.event.DefaultListenerManager$EventBroadcast$ListenerDispatch.dispatch(DefaultListenerManager.java:209)
      14:15:05.135 [ERROR] [org.gradle.BuildExceptionReporter]        at org.gradle.internal.event.AbstractBroadcastDispatch.dispatch(AbstractBroadcastDispatch.java:44)
      14:15:05.135 [ERROR] [org.gradle.BuildExceptionReporter]        at org.gradle.internal.event.BroadcastDispatch.dispatch(BroadcastDispatch.java:79)
      14:15:05.135 [ERROR] [org.gradle.BuildExceptionReporter]        at org.gradle.internal.event.BroadcastDispatch.dispatch(BroadcastDispatch.java:30)
      14:15:05.135 [ERROR] [org.gradle.BuildExceptionReporter]        at org.gradle.internal.dispatch.ProxyDispatchAdapter$DispatchingInvocationHandler.invoke(ProxyDispatchAdapter.java:93)
      14:15:05.154 [ERROR] [org.gradle.BuildExceptionReporter]        at com.sun.proxy.$Proxy11.beforeEvaluate(Unknown Source)
      14:15:05.154 [ERROR] [org.gradle.BuildExceptionReporter]        at org.gradle.internal.dispatch.ReflectionDispatch.dispatch(ReflectionDispatch.java:35)
      14:15:05.154 [ERROR] [org.gradle.BuildExceptionReporter]        at org.gradle.internal.dispatch.ReflectionDispatch.dispatch(ReflectionDispatch.java:24)
      14:15:05.154 [ERROR] [org.gradle.BuildExceptionReporter]        at org.gradle.internal.event.AbstractBroadcastDispatch.dispatch(AbstractBroadcastDispatch.java:44)
      14:15:05.154 [ERROR] [org.gradle.BuildExceptionReporter]        at org.gradle.internal.event.BroadcastDispatch.dispatch(BroadcastDispatch.java:79)
      14:15:05.155 [ERROR] [org.gradle.BuildExceptionReporter]        at org.gradle.internal.event.BroadcastDispatch.dispatch(BroadcastDispatch.java:30)
      14:15:05.155 [ERROR] [org.gradle.BuildExceptionReporter]        at org.gradle.internal.dispatch.ProxyDispatchAdapter$DispatchingInvocationHandler.invoke(ProxyDispatchAdapter.java:93)
      14:15:05.155 [ERROR] [org.gradle.BuildExceptionReporter]        at com.sun.proxy.$Proxy11.beforeEvaluate(Unknown Source)
      14:15:05.155 [ERROR] [org.gradle.BuildExceptionReporter]        at org.gradle.configuration.project.LifecycleProjectEvaluator.evaluate(LifecycleProjectEvaluator.java:47)
      14:15:05.155 [ERROR] [org.gradle.BuildExceptionReporter]        ... 103 more
      14:15:05.155 [ERROR] [org.gradle.BuildExceptionReporter]
      14:15:05.155 [LIFECYCLE] [org.gradle.BuildResultLogger]
      14:15:05.155 [LIFECYCLE] [org.gradle.BuildResultLogger] BUILD FAILED
      14:15:05.155 [LIFECYCLE] [org.gradle.BuildResultLogger]
      14:15:05.155 [LIFECYCLE] [org.gradle.BuildResultLogger] Total time: 10.809 secs
      

        Attachments

          Activity

          allen.servedio@weather.com Allen Servedio added a comment -

          Okay, that will take me some time to do (as you can imagine, this is embedded in an internal project that I can't easily extract). I will try to reproduce it on my side with a simple project.

          romang Roman Gurevitch added a comment -

          Thanks, we appreciate your efforts.
          You can try and use our examples to reproduce the issue,
          https://github.com/JFrogDev/project-examples/tree/master/gradle-examples/4

          romang Roman Gurevitch added a comment -

          Hi Allen, we have released a new version of Gradle Artifactory plugin (4.4.1).
          You are welcome to try it out and see if your example works with it.

          allen.servedio@weather.com Allen Servedio added a comment -

          Okay, I will try it in a week when I get back and will update with results. Thanks!

          allen.servedio@weather.com Allen Servedio added a comment -

          Thanks for fixing the original defect. I have moved to 4.4.1 and after altering the config a bit, I found I had a lifecycle issue with how artifactoryPublish was being defined. It was defined within the sub project itself and the failure basically said that it could not see the task on the pre-evaluation step. I moved it to a top level build.gradle file within a configure block scoped to the subproject and the second failure I was getting has gone away. This defect can be closed.

          So, I moved:

              apply plugin: 'war'
              artifactoryPublish {
                  dependsOn war
              }
          

          Out of the subproject and placed it in the root's build.gradle like this:

          configure(project(':my-sub-project')) {
              apply plugin: 'war'
              artifactoryPublish {
                  dependsOn war
              }
          }
          

            People

            • Assignee:
              romang Roman Gurevitch
              Reporter:
              allen.servedio@weather.com Allen Servedio
            • Votes:
              1 Vote for this issue
              Watchers:
              3 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: