Uploaded image for project: 'Jenkins Artifactory Plug-in'
  1. Jenkins Artifactory Plug-in
  2. HAP-1093

Declarative syntax for Jenkins Artifactory Plugin

    Details

    • Type: Improvement
    • Status: Resolved
    • Priority: Normal
    • Resolution: Fixed
    • Affects Version/s: 2.15.0
    • Fix Version/s: 3.0.0
    • Component/s: Gradle
    • Labels:

      Description

      This feature improvement was requested by one customer as far as I know. Most use cases we will hear would be customers not wanting to use groovy in Jenkins that could potentially trigger all kinds of warnings related to security in Jenkins. So by having declarative out of the box, it can eliminate the use of Java/Groovy libraries that causes the warnings, thus no more warnings. Attached the sample screenshot from Jenkins. 

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                yahavi Yahav Itzhak
                Reporter:
                joonl Joon Lee (Inactive)
              • Votes:
                0 Vote for this issue
                Watchers:
                3 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: