Uploaded image for project: 'Jenkins Artifactory Plug-in'
  1. Jenkins Artifactory Plug-in
  2. HAP-1167

Can't get credentialsId from the Artifactory server object

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: 3 - High
    • Resolution: Done
    • Affects Version/s: 3.2.1
    • Fix Version/s: 3.2.4
    • Component/s: None
    • Labels:
      None
    • Environment:

      Jenkins 2.164.1

      Jenkins Artifactory plugin 3.1.2

      Description

      When using the Artifactory Jenkins plugin, I configure the Artifactory server in the global Jenkins configuration with the credentials plugin:

       

      But when I try to see which credential ID is used for Artifactory, as described in the documentation:

      I get a null value.

       

      Looking at all the properties of the server object, I see:

       

      The server object has the credentialsId property set to null and the username and password values are expanded from the username and password defined in the credential. Also, the 
      usesCredentialsId propery is set to false.

      This is not the desired behaviour, I would expect to see the credential ID here, so that I can use it to access Artifactory for running REST API requests.

       

       

        Attachments

          Activity

            People

            Assignee:
            alexeiv Alexei Vainshtein
            Reporter:
            daniele Daniel Ezer (Inactive)
            Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved: