Uploaded image for project: 'Jenkins Artifactory Plug-in'
  1. Jenkins Artifactory Plug-in
  2. HAP-1485

Jenkins Artifactory Plugin does not upload pom files when using rtMavenRun

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Open
    • Resolution: Unresolved
    • Affects Version/s: None
    • Fix Version/s: None
    • Component/s: Maven3
    • Labels:
    • Environment:

      Maven version: 3.8.6

      OS: Amazon Linux 2

      JDK: Amazon Corretto OpenJDK 17

      Description

      Hi! 

      We are using the Artifactory plugin for Jenkins in our declarative pipeline for a long time with the rtMavenRun step. After upgrading to version 3.16.3 no pom files are uploaded for modules of type "jar" from our multimodule maven projects. For "pom" type modules the pom-files are still uploaded.   

      Example:

      rtMavenRun(pom: 'pom.xml',                            
       goals: 'clean install', 
       deployerId: 'MAVEN_DEPLOYER', 
       resolverId: 'MAVEN_RESOLVER')
      

      This used to work fine before we upgraded the plugin to version 3.16.3, but also exists in the latest version (3.17.0). 

        Attachments

          Activity

            People

            Assignee:
            eyalb Eyal Ben Moshe
            Reporter:
            zapodot Sondre Kvalø
            Votes:
            2 Vote for this issue
            Watchers:
            4 Start watching this issue

              Dates

              Created:
              Updated: