Uploaded image for project: 'Jenkins Artifactory Plug-in'
  1. Jenkins Artifactory Plug-in
  2. HAP-299

The dependency to Hudson subversion plugin failed tests when depending on Artifactory plugin

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: 4 - Normal
    • Resolution: Done
    • Affects Version/s: 2.0.7
    • Fix Version/s: 2.0.8
    • Component/s: Maven2
    • Labels:
      None
    • Environment:

      maven 2 and Jenkins 1.447

      Description

      Hi,
      I'm depending on the Artifactory plugin and Subversion plugin and tests are failing since I migrated my plugin to use Jenkins 1.447.
      To solve the issue I needed to exclude the Hudson subversion plugin:

      <dependency>
          <groupId>org.jenkins-ci.plugins</groupId>
          <artifactId>artifactory</artifactId>
          <version>2.0.7</version>
          <exclusions>
      	<exclusion>
                  <groupId>org.jvnet.hudson.plugins</groupId>
      	    <artifactId>subversion</artifactId>
      	</exclusion>
          </exclusions>
      </dependency>
      

      and add to depends on the Jenkins Subversion plugin:

      <dependency>
          <groupId>org.jenkins-ci.plugins</groupId>
          <artifactId>subversion</artifactId>
          <version>1.39</version>
      </dependency>
      

      Is it possible to depends on at least Jenkins Subversion, plugin?
      thanks

        Attachments

          Activity

            People

            Assignee:
            yossis Yossi Shaul
            Reporter:
            drautureau David Rautureau (Inactive)
            Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved: