Uploaded image for project: 'Jenkins Artifactory Plug-in'
  1. Jenkins Artifactory Plug-in
  2. HAP-316

NPE in BuildUniqueIdentifierHelper when building downstream job

    XMLWordPrintable

    Details

      Description

      After updating to the latest Artifactory plugin we were met with an NPE on next build.

      Deploying artifacts of module: .....
      ERROR: null
      java.lang.NullPointerException
      at org.jfrog.hudson.util.BuildUniqueIdentifierHelper.getUpstreamIdentifier(BuildUniqueIdentifierHelper.java:106)
      at org.jfrog.hudson.maven2.ArtifactsDeployer.deployArtifact(ArtifactsDeployer.java:170)
      at org.jfrog.hudson.maven2.ArtifactsDeployer.deploy(ArtifactsDeployer.java:127)
      at org.jfrog.hudson.ArtifactoryRedeployPublisher.perform(ArtifactoryRedeployPublisher.java:300)
      at hudson.tasks.BuildStepMonitor$1.perform(BuildStepMonitor.java:19)
      at hudson.model.AbstractBuild$AbstractRunner.perform(AbstractBuild.java:710)
      at hudson.model.AbstractBuild$AbstractRunner.performAllBuildSteps(AbstractBuild.java:685)
      at hudson.maven.MavenModuleSetBuild$RunnerImpl.post2(MavenModuleSetBuild.java:994)
      at hudson.model.AbstractBuild$AbstractRunner.post(AbstractBuild.java:632)
      at hudson.model.Run.run(Run.java:1459)
      at hudson.maven.MavenModuleSetBuild.run(MavenModuleSetBuild.java:477)
      at hudson.model.ResourceController.execute(ResourceController.java:88)
      at hudson.model.Executor.run(Executor.java:239)
      Build step 'Deploy artifacts to Artifactory' changed build result to FAILURE

        Attachments

          Activity

            People

            Assignee:
            shayy Shay Yaakov (Inactive)
            Reporter:
            johno Johno Crawford (Inactive)
            Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved: