Uploaded image for project: 'Jenkins Artifactory Plug-in'
  1. Jenkins Artifactory Plug-in
  2. HAP-390

Resolve Artifacts from Artifactory works only if Deploy Artifacts to Artifactory is selected in Post-Build Steps

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: Critical
    • Resolution: Duplicate
    • Affects Version/s: 2.1.4
    • Fix Version/s: 2.1.5
    • Component/s: None
    • Labels:
      None
    • Environment:

      Jenkins 1.480.3
      Artifactory Plugin 2.1.4
      Artifactory Pro 2.6.6

      Description

      I have a scenario where I want to build a product from artifacts stored in Artifactory but I don't want to deploy the resulting products back to Artifactory (for example, test jobs).

      In essence I just want Jenkins to resolve the artifacts from Artifactory and push nothing back.

      Not selected Deploy Artifacts to Artifactory in the Post-Build Steps results in deactivating the resolution through Artifactory althogether. I can see it from the command executed by Jenkins that the -Dm3plugin.lib=<path>/artifactory-plugin/2.1.4 is missing when the said Post-Build Step is not specified.

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                yossis Yossi Shaul
                Reporter:
                prenaud76 Patrick Renaud
              • Votes:
                0 Vote for this issue
                Watchers:
                1 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: