Uploaded image for project: 'Jenkins Artifactory Plug-in'
  1. Jenkins Artifactory Plug-in
  2. HAP-929

Special characters in property value behave differently than when adding via REST api

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: High
    • Resolution: Fixed
    • Affects Version/s: 2.11.0
    • Fix Version/s: 2.12.0
    • Component/s: None
    • Labels:
      None

      Description

      The observed inconsistencies are:
      1. '$' (dollar) = '$' and after become null/empty
      2. '=' (equal) = property not created
      3. '/' (slash) = artifact not published

      These characters are deployable via REST (with escaping) and in the UI without escaping:
      1. curl -X PUT -uadmin:password "http://localhost:8081/artifactory/api/storage/dummy3/test.txt?properties=RESTapi=1\$1"
      2. curl -X PUT -uadmin:password "http://localhost:8081/artifactory/api/storage/dummy3/test.txt?properties=RESTapi=1\=1"
      3. curl -X PUT -uadmin:password "http://localhost:8081/artifactory/api/storage/dummy3/test.txt?properties=RESTapi=1/1"

      ';' (semi-colon) = ';' and after become null/empty (from Jenkins), this cannot be added via REST or UI since the ';' is considered a multi value separator

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                yahavi Yahav Itzhak
                Reporter:
                itamarb Itamar Berman-Eshel
              • Votes:
                0 Vote for this issue
                Watchers:
                3 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: