Uploaded image for project: 'Artifactory Binary Repository'
  1. Artifactory Binary Repository
  2. RTFACT-10403

Enabling debug logging causes Docker pushes to fail with an HTTP 500

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: Normal
    • Resolution: Duplicate
    • Affects Version/s: 4.7.0, 4.8.0
    • Fix Version/s: None
    • Component/s: Docker, Logging
    • Labels:
      None

      Description

      Enabling debug logging causes Docker pushes to fail.

      To reproduce (Performed with Art 4.8.0 and Docker 1.9):

      1. Setup a new Artifactory instance with a Docker repository and a reverse proxy
      2. Edit the logback.xml to add debug logging to org.artifactory:

          <logger name="org.artifactory">
              <level value="debug"/>
          </logger>
      

      3. Attempt to push an image (that does not exist)
      4. Observe the failure

      Docker error

      Arturos-MBP:sample arturoaparicio$ docker push localhost:5002/busybox
      The push refers to a repository [localhost:5002/busybox] (len: 2)
      65e4158d9625: Image push failed 
      Received unexpected HTTP status: 500 Internal Server Error
      

      Exception seen in the logs

      2016-06-01 19:49:22,315 [http-nio-8081-exec-8] [DEBUG] (o.a.w.s.a.PropsAuthenticationFilter:73) - re-authentication failed
      java.util.MissingFormatArgumentException: Format specifier '%s'
      

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                Unassigned
                Reporter:
                arturoa Arturo Aparicio
              • Votes:
                2 Vote for this issue
                Watchers:
                2 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: