Uploaded image for project: 'Artifactory Binary Repository'
  1. Artifactory Binary Repository
  2. RTFACT-10490

Handling leading zeros in SemVer on NuGet

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed
    • Resolution: Deferred
    • Affects Version/s: 4.8.0
    • Fix Version/s: None
    • Component/s: NuGet
    • Labels:
    • Severity:
      High

      Description

      Upload this package https://www.nuget.org/packages/Moq/4.1.1311.615 to artifactory.
      Try to retrieve it by request https://artifactory.server/api/v2/Packages(Id='Moq',Version='4.1.1311.615')
      Negative response - 404, while on nuget.org it works https://www.nuget.org/api/v2/Packages(Id='Moq',Version='4.1.1311.615')

      I've discovered that in nuspec file it has version with leading zero, so this request works https://artifactory.server/api/v2/Packages(Id='Moq',Version='4.1.1311.0615')
      While it's prohibited to have leading zeros in SemVer it's important to be compatible with reference NuGet server (nuget.org).

        Attachments

          Activity

              People

              Assignee:
              Unassigned
              Reporter:
              derigel Viacheslav Trenogin (Inactive)
              Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved:

                  Sync Status

                  Connection: RTFACT Sync
                  RTMID-10490 -
                  SYNCHRONIZED
                  • Last Sync Date: