Uploaded image for project: 'Artifactory Binary Repository'
  1. Artifactory Binary Repository
  2. RTFACT-10598

Remember me corrupts cookies with Crowd/LDAP

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed
    • Resolution: Deferred
    • Affects Version/s: 4.8.2
    • Fix Version/s: None
    • Component/s: Crowd, LDAP, Web UI
    • Labels:
    • Environment:

      Crowd 2.8.3, Artifactory Professional 4.8.2 rev 40222 Licensed to Our Team, macOS 10.11.5, Google Chrome Version 51.0.2704.103 (64-bit), Firefox 47.0, Safari latest version

    • Severity:
      High

      Description

      Using macOS 10.11.5, and Google Chrome or Safari or Firefox, I can log into Artifactory 4.8.2. If I don't check "Remember me" on the login screen, Artifactory appears to work correctly.
      If I log in with Remember me checked, I get wacky results. Random characters on the page, the log out link doesn't work. Artifacts don't load in the list. If I refresh the page, I get a 500 error

      HTTP Status 500 - more then one filter accept this request

      type Exception report

      message more then one filter accept this request

      description The server encountered an internal error that prevented it from fulfilling this request.

      exception

      java.lang.RuntimeException: more then one filter accept this request
      org.artifactory.webapp.servlet.authentication.ArtifactoryAuthenticationFilterChain.acceptFilter(ArtifactoryAuthenticationFilterChain.java:105)
      org.artifactory.webapp.servlet.AccessFilter.doFilterInternal(AccessFilter.java:179)
      org.artifactory.webapp.servlet.AccessFilter.doFilter(AccessFilter.java:157)
      org.artifactory.webapp.servlet.RequestFilter.doFilter(RequestFilter.java:61)
      org.artifactory.webapp.servlet.ArtifactoryFilter.doFilter(ArtifactoryFilter.java:111)

      note The full stack trace of the root cause is available in the Apache Tomcat/8.0.32 logs.
      Apache Tomcat/8.0.32

      At this point, I cannot log in.

      Deleting the cookies generated during the above attempts allows me to log in again.
      Obviously, this is a pain in the butt. It is 100% repeatable on my machine. I have restarted the browsers, the entire machine and even went into Recovery mode and ran Disk First Aid on the disk. The disk was fine.

      I've tried to reproduce this on other Macs in the office and they don't get the 500 error, BUT Remember me does not work. They must enter their user/password every time.

        Attachments

          Activity

              People

              Assignee:
              Unassigned
              Reporter:
              thebroz Richard Brosnahan (Inactive)
              Votes:
              5 Vote for this issue
              Watchers:
              5 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved:

                  Sync Status

                  Connection: RTFACT Sync
                  RTMID-10598 -
                  SYNCHRONIZED
                  • Last Sync Date: