Uploaded image for project: 'Artifactory Binary Repository'
  1. Artifactory Binary Repository
  2. RTFACT-12832

Missing language information (NuGet packages)

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed
    • Resolution: Deferred
    • Affects Version/s: 4.7.1, 4.7.4, 4.13.2
    • Fix Version/s: None
    • Component/s: NuGet
    • Environment:

      RHEL 7, Artifactory Enterprise in HA configuration with Oracle DB and NetApp file share

    • Severity:
      Critical

      Description

      As my colleague already described in RTFACT-10596, we still have an issue with NuGet package information provided using the REST API: the language information is missing, however its value is visible in nuspec, nupkg properties (nuget.language) and in NuPkg Info in the Artifactory WebUI.
      It's observed, that the xml contains <d:Language m:null="true"/>, but the Package Info shows "Languages: de".
      This behavior exists on several versions of Artifactory and also on our Enterprise licensed HA system.

        Attachments

          Issue Links

            Activity

                People

                Assignee:
                Unassigned
                Reporter:
                Kalman Kalman Bogdan
                Votes:
                1 Vote for this issue
                Watchers:
                1 Start watching this issue

                  Dates

                  Created:
                  Updated:
                  Resolved:

                    Sync Status

                    Connection: RTFACT Sync
                    RTMID-12832 -
                    SYNCHRONIZED
                    • Last Sync Date: