Uploaded image for project: 'Artifactory Binary Repository'
  1. Artifactory Binary Repository
  2. RTFACT-14509

Upgrade from Artifactory 5.3.0 to higher version is failing in Linux distributions using systemd

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: High
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 5.4.3
    • Component/s: None
    • Labels:
      None

      Description

      Upgrade from Artifactory 5.3.0 to higher version failing in Debian 8 OS (and on other Linux distributions using systemd), with the following error:
      "The currently installed Artifactory version does not have the same layout as this DEB!"

      Reproduction steps:
      Upgrade Artifactory using the below dpkg command to version 5.3.0 or above while the OS is using systemd:
      dpkg -i <package name.deb>

        Attachments

          Activity

            People

            • Assignee:
              anastasiag Anastasia Grinman
              Reporter:
              yehudah Yehuda Hadad
            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: