Uploaded image for project: 'Artifactory Binary Repository'
  1. Artifactory Binary Repository
  2. RTFACT-14604

UI deployments are failing on HA on authentication on the event's propagation

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: Normal
    • Resolution: Fixed
    • Affects Version/s: 5.2.1, 5.3.4, 5.4.3, 5.4.4
    • Fix Version/s: 5.6.0
    • Component/s: Deploy UI
    • Labels:
      None

      Description

      In order to reproduce, any version 5.x will do.

      • HA setup with two nodes.
      • UI deployment (as via rest it is working).
        Following the removal of sticky session, there is a propagation of the event during UI deployments.

      Steps:
      The user which deploy via the UI should be either external user (not created in Artifactory) or a user which his permissions are inherited by a group.

      So if there is a permission target for this repository, the permissions for the repository are granted by the group and not directly to the user. Meaning the user is only associated to the group (on the permission target, the user is not added, only the group).

      The deployment will fail with 403, no permissions for the user to deploy.
      The reason is that during the propagation event, the permissions for the user are lost

      Adding the user to the permission target will solve this.

        Attachments

          Activity

            People

            • Assignee:
              noams Noam Shemesh
              Reporter:
              aviz Avi Zaig (Inactive)
              Assigned QA:
              Gilad Kalchheim (Inactive)
            • Votes:
              2 Vote for this issue
              Watchers:
              4 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: