Uploaded image for project: 'Artifactory Binary Repository'
  1. Artifactory Binary Repository
  2. RTFACT-14766

Upgrade ivy dependency to 2.4

    XMLWordPrintable

    Details

    • Type: Improvement
    • Status: Open
    • Priority: 4 - Normal
    • Resolution: Unresolved
    • Affects Version/s: 5.4.6
    • Fix Version/s: None
    • Component/s: Dependencies
    • Labels:
      None

      Description

      Current latest artifactory version (5.4.6) still depends on ivy-2.2.0.jar

      When using user plugins such as ivy2pom (https://github.com/JFrogDev/artifactory-user-plugins/tree/master/descriptors/ivy2pom), this means that the parsing of Ivy descriptors is limited to versions up to 2.2.
      (More details at https://issues.apache.org/jira/browse/IVY-1565)

      Upgrading to ivy-2.4.0.jar would have the significant benefit that all the Ivy descriptors could be parsed, which would enhance the usefulness of the user plugins that may parse ivy descriptors.

        Attachments

          Activity

            People

            Assignee:
            Unassigned
            Reporter:
            arnaud.jeansen Arnaud Jeansen (Inactive)
            Votes:
            1 Vote for this issue
            Watchers:
            4 Start watching this issue

              Dates

              Created:
              Updated:

                Sync Status

                Connection: RTFACT Sync
                RTMID-14766 -
                ERROR
                • Last Sync Date: