Uploaded image for project: 'Artifactory Binary Repository'
  1. Artifactory Binary Repository
  2. RTFACT-15092

Exporting on 5.4.4 and importing on the same/a more recent version (i.e 5.5.1) fails with Access errors

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Open
    • Priority: High
    • Resolution: Unresolved
    • Affects Version/s: 5.5.1
    • Fix Version/s: None
    • Component/s: Access Server
    • Labels:
      None

      Description

      This appears to no longer happen when exporting using a more recent version such as 5.5.1, this bug report is for documentation purposes

      To reproduce:

      1.Export on artifactory 5.4.4
      2.Try importing on a different 5.4.4 instance via the UI, tick the Verbose output checkbox - it should fail, observe the stack traces attached to this JIRA on the log

      *The same issue happens when importing on 5.5.1, however, exporting & importing on 5.5.1 works fine.

      It appears that the import makes the existing admin token invalid, which leads to its revocation, and the Access admin user creds too are invalid. The stack traces show two different requests that fail with a 401 response, one with Bearer auth that fails, and the other with Basic auth. The verbose one includes apache wire logging enabled.

        Attachments

          Issue Links

            Activity

              People

              Assignee:
              Unassigned
              Reporter:
              uriahl Uriah Levy
              Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

                Dates

                Created:
                Updated: