Uploaded image for project: 'Artifactory Binary Repository'
  1. Artifactory Binary Repository
  2. RTFACT-15242

Access server backup fails because of HTTP error 401

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: Normal
    • Resolution: Not a Bug
    • Affects Version/s: 5.5.1
    • Fix Version/s: None
    • Component/s: Access Server
    • Labels:
      None
    • Environment:
      • Artifactory 5.5.1 RPM installed in CentOS7 docker container
      • Postgresql-DB 9.2.23 in separate CentOS7 docker container

      Description

      On our new Artifactory 5.5.1 server installed from scratch both preconfigured backup jobs (daily & weekly) are failing with following error

      Error during access server backup: HTTP response status
      401:{"errors":[

      {"code":"UNAUTHORIZED","detail":"Bad credentials","message":"HTTP 401 Unauthorized"}

      ]}

      The access server request log contains following entry created at backup time

      2017-11-08T02:00:00.340+0100|127.0.0.1|anonymous|POST|http://localhost:8081/access/api/v1/system/backup/export|401|0|120|JFrog Access Java Client/2.0.4

      On our test server (5.5.1 Pro upgraded from 5.3.* OSS) the backup jobs succeed. The corresponding request log entry is

      2017-11-08T02:00:05.748+0100|127.0.0.1|admin|POST|http://localhost:8081/access/api/v1/system/backup/export|202|0|463|JFrog Access Java Client/2.0.4

      So both servers use different credentials during the backup.

        Attachments

          Activity

            People

            • Assignee:
              Unassigned
              Reporter:
              wbosse W. Bosse
            • Votes:
              1 Vote for this issue
              Watchers:
              3 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: