Uploaded image for project: 'Artifactory Binary Repository'
  1. Artifactory Binary Repository
  2. RTFACT-15614

When downloading Artifactory generated settings.xml, it does not populate the encrypted password for ldap users

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: High
    • Resolution: Fixed
    • Affects Version/s: 5.7.2
    • Fix Version/s: 5.9.0
    • Component/s: LDAP, Maven
    • Labels:
      None
    • Regression:
      Yes
    • Sprint:
      Leap 28

      Description

      When downloading Artifactory generated settings.xml, it does not populate the encrypted password for ldap users.

      Steps to reproduce:
      1. Deploy the setting.xml snippet to libs-release-local repo
      2. Run curl -uldapuser:password http://localhost:8081/artifactory/libs-release-local/settings.xml
      3. You will see that in the snippet, it did populate the username, but not the encrypted password:

      <server>
      <username>ldapuser</username>
      <password>*** Insert encrypted password here ***</password>
      <id>central</id>
      </server>
      <server>
      <username>ldapuser</username>
      <password>*** Insert encrypted password here ***</password>
      <id>snapshots</id>
      </server>

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                lizad Liza Dashevski (Inactive)
                Reporter:
                mohammadt Mohammad Tibi
                Assigned QA:
                Gilad Kalchheim (Inactive)
              • Votes:
                0 Vote for this issue
                Watchers:
                6 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: