Uploaded image for project: 'Artifactory Binary Repository'
  1. Artifactory Binary Repository
  2. RTFACT-15646

Email field not populated when creating HTTP SSO user with Auto Associate LDAP Groups checked

    Details

    • Type: Improvement
    • Status: Resolved
    • Priority: Normal
    • Resolution: Fixed
    • Affects Version/s: 5.8.3
    • Fix Version/s: 5.10.0
    • Component/s: LDAP
    • Labels:
      None

      Description

      Customer is having an issue with newly created SSO users that are LDAP users too. Artifactory does not completely sync the email field about the specific user from LDAP. There are workarounds but require manual work for each user.

      STEPS TO REPRODUCE:
      1 - enable all HTTP SSO features in Artifactory
      2 - Sync LDAP groups with Artifactory.
      3 - login using HTTP SSO with a user that is already an LDAP user
      4 - Check Users tab in Artifactory for the user that is logged in with Realm HTTP-SSO but the email and last login fields are not updated according to the HTTP SSO bind with LDAP that was resolved in jira (RTFACT-12320)

      P.S:
      Another use case can be, if you login an LDAP user with Artifactory challenge page (login page) and log out. Then try to login with HTTP-SSO. In the Users tab we can see that the user Realm is updated to HTTP-SSO and email field is popluated with the user's email but the last login field still not populated.

        Attachments

          Activity

            People

            • Assignee:
              Dudim Dudi Morad
              Reporter:
              Nimerb Nimer Bsoul
              Assigned QA:
              Yoaz Menda (Inactive)
            • Votes:
              1 Vote for this issue
              Watchers:
              1 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: