Uploaded image for project: 'Artifactory Binary Repository'
  1. Artifactory Binary Repository
  2. RTFACT-15996

Access Token authentication will not work on RHEL6 machines

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: Normal
    • Resolution: Not a Bug
    • Affects Version/s: None
    • Fix Version/s: None
    • Component/s: Access Tokens
    • Labels:
      None

      Description

      When creating Access Token for example for existing/none existing user with deployment operations on RHEL7 everything works properly.

      However, when trying to use the same Access Token on RHEL6 machine, it will result with status 401, and "Bad credentials":
      {
      "errors" : [

      { "status" : 401, "message" : "Bad credentials" }

      ]

      Steps to reproduce are simple:
      1. Create permissions target with overwrite and deployments permissions to a certain repository(i have done it on my AOL).
      2. Create a group that will contain the permission target.
      3. Create an access token using curl on RHEL7 machine.
      4. Upload a file, using the username(can exist or none-existing user) and the generated token and the file will upload successfully.
      5. Repeat step 4 on RHEL6 machine, you will get error 401.

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                Unassigned
                Reporter:
                shaibz Shai Ben-Zvi
              • Votes:
                0 Vote for this issue
                Watchers:
                2 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: