Uploaded image for project: 'Artifactory Binary Repository'
  1. Artifactory Binary Repository
  2. RTFACT-16865

Unlock on Profile Page not working for user with special characters in password

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: Blocker
    • Resolution: Duplicate
    • Affects Version/s: None
    • Fix Version/s: 6.1.0
    • Component/s: None
    • Labels:
      None
    • Environment:

      Ubuntu 16.04.4 LTS
      jfrog-artifactory-oss 6.0.0
      Windows Server 2008R2

      Description

      With Artifactory OSS version 6.0.0 connected to Active Directory a user with a "special character" in his password (in this case it was a ":", there may be others) was not able to use the "unlock" function on his profile page to e.g. get an API key.

      The user in question did not have any problems with the password on any other system and was able to login to artifactory and access the profile page. But when entering the correct password and clicking the "unlock" button, he received an error message like this:

      You are already logged in. You can go to the home page or log out.

      Only after changing the AD password to one without a ":" it was possible to use the "unlock" button without problems.

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                tamirh Tamir Hadad
                Reporter:
                heapifyman heapifyman
                Assigned QA:
                Tamir Hadad
              • Votes:
                2 Vote for this issue
                Watchers:
                5 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: