Uploaded image for project: 'Artifactory Binary Repository'
  1. Artifactory Binary Repository
  2. RTFACT-17157

CRAN R requires quotes in setRepositories

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Done
    • Priority: 4 - Normal
    • Resolution: Done
    • Affects Version/s: None
    • Fix Version/s: 6.6.0
    • Component/s: None
    • Labels:
      None
    • Severity:
      Medium

      Description

      SENSITIVE DATA HAS BEEN REMOVED FROM THIS TICKET ACCORDING TO JFROG'S INTERNAL POLICY.

       

      The R server requires quotes in setRepositories. We are missing the quotes in the Set Me Up.

      This means the current "Set Me Up" instructions from Artifactory cannot be used.
      For example:

      > setRepositories(addURLs = c(cran-remote = "RESTRICTED_URL1"))
      Error: unexpected '=' in "setRepositories(addURLs = c(cran-remote ="
      

      After a quick investigation it looks like the client requires the repository name to be surrounded by quotes, like this:

      setRepositories(addURLs = c("cran-remote" = "RESTRICTED_URL2"))
      

        Attachments

          Issue Links

            Activity

              People

              Assignee:
              nadavy Nadav Yogev
              Reporter:
              arielk Ariel Kabov
              Votes:
              0 Vote for this issue
              Watchers:
              3 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved:

                  Sync Status

                  Connection: RTFACT Sync
                  RTMID-17157 -
                  SYNCHRONIZED
                  • Last Sync Date: