Uploaded image for project: 'Artifactory Binary Repository'
  1. Artifactory Binary Repository
  2. RTFACT-17563

Artifactory 6.4.0 fails to start up with the S3 binary provider

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: High
    • Resolution: Fixed
    • Affects Version/s: 6.4.0
    • Fix Version/s: 6.4.1
    • Component/s: S3, startup
    • Labels:
      None
    • Environment:
    • Regression:
      Yes

      Description

      Facing issue with Artifactory 6.4.0 installation using AWS CloudFormation Template. 

      Used following AWS Cloud Formation template to install Artifactory 6.4.0.
      https://github.com/jfrog/JFrog-Cloud-Installers/blob/master/CloudFormation/artifactory-enterprise.json

      Issue: Artifactory server fails to come up. Not able to access GUI.

      Setup details:
      Above AWS Cloud formation template creates VM with AMI image, prepares basic setup (like db.properties, binarystore.xml, ha-node.properties, master.key, licenses etc),
      and installs Artifactory and nginx using yum.

      Binarystore is set to AWS s3.

      DB is set to MySQL.

      [See attachment for the contents of binarystore.xml]

      Failure messages in artifactory.log:

      — log snippet —
      java.lang.RuntimeException: Failed to test connection with s3, bucket:artentchk-s3bucket-wrkc7jyu427r

      Caused by: java.lang.RuntimeException: Failed to test connection with s3, bucket:artentchk-s3bucket-wrkc7jyu427r
      at org.artifactory.addon.filestore.type.jets3t.CommonS3Methods.test(CommonS3Methods.java:79)
      at org.artifactory.addon.filestore.type.jets3t.s3.S3JetS3tBinaryProvider.testS3(S3JetS3tBinaryProvider.java:454)

      [art-init] [ERROR] (o.a.w.s.ArtifactoryContextConfigListener:92) - Application could not be initialized: null.

      — end of log snippet —

      Note: The same setup works fine with earlier versions like 6.3.3, 6.3.0.

      This failure is seen with Terraform based installation too.

      I was able to connect to s3 bucket using external client tool like 'Commander One'. (just to verify the connectivity)

      I see there were 2 bugs (RTFACT-12957 and RTFACT-17262) that got fixed in 6.4.0.

      Not sure if this failure is related.

        Attachments

          Activity

            People

            • Assignee:
              uriahl Uriah Levy
              Reporter:
              maheshg Mahesh Gopalakrishnan
            • Votes:
              0 Vote for this issue
              Watchers:
              4 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: