Uploaded image for project: 'Artifactory Binary Repository'
  1. Artifactory Binary Repository
  2. RTFACT-18195

Distribution to HA cluster for the 1st time won't work until explicitly syncing nodes

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Open
    • Priority: 2 - Critical
    • Resolution: Unresolved
    • Affects Version/s: None
    • Fix Version/s: None
    • Component/s: High Availability
    • Labels:
    • Environment:

      artifactory-pro:6.6.3 in HA configuration (2 nodes behind nignx)

    • Severity:
      Critical
    • Team:
      dev-artifactory-packages

      Description

      When distributing package, we are creating generic repository named "_intransit" on target node
      The problem is that generation of this repo does not trigger sync on HA cluster, Therefore, the transfer request fails (if the copy request comes to non-notified node)

      The workaround is to manually trigger sync between HA nodes and repeat the transaction (api/release/bundle/transaction)

        Attachments

        1. artifactory.log-node1
          140 kB
        2. artifactory.log-node2
          131 kB
        3. artifactory.log-node3
          127 kB
        4. request.log-node1
          349 kB
        5. request.log-node2
          353 kB
        6. request.log-node3
          348 kB

          Activity

            People

            Assignee:
            Unassigned
            Reporter:
            alexd Alex Dvorkin (Inactive)
            Votes:
            2 Vote for this issue
            Watchers:
            6 Start watching this issue

              Dates

              Created:
              Updated:

                Sync Status

                Connection: RTFACT Sync
                RTMID-18195 -
                SYNCHRONIZED
                • Last Sync Date: