Uploaded image for project: 'Artifactory Binary Repository'
  1. Artifactory Binary Repository
  2. RTFACT-18310

Go Repository - Couldn't find version info for project due to version zip file cannot be found but zip file in artifactory

    Details

    • Type: Bug
    • Status: Will Not Implement
    • Priority: High
    • Resolution: Not a Bug
    • Affects Version/s: 6.1.1
    • Fix Version/s: 6.7.0
    • Component/s: Go
    • Labels:
      None
    • Environment:

      gocenter.jfrog.info

      Description

      While doing "Go Get" load testing on Artifactory gocenter.jfrog.info using gocenter-virtual - see the following errors in the log. The load is 250+ simultaneous users doing "go get <modules>" using JMeter. The modules are from a list of go modules.

      2019-01-16 01:23:45,340 [http-nio-8081-exec-306] [ERROR] (o.j.r.g.r.h.GoLocalRepoHandler:127) - Couldn't find version info for project github.com/aphistic/golf, due to version v0.0.0-20180712155816-02c07f170c5a zip could not be found
      2019-01-16 01:23:47,122 [http-nio-8081-exec-303] [ERROR] (o.j.r.g.r.h.GoLocalRepoHandler:127) - Couldn't find version info for project github.com/aphistic/sweet, due to version v0.0.0-20180618201346-68e18ab55a67 zip could not be found

      The modules are present on aritfactory
      gocenter-stage/github.com/aphistic/sweet/@v/v0.0.0-20180618201346-68e18ab55a67.zip
      gocenter-stage/github.com/aphistic/golf/@v/v0.0.0-20180712155816-02c07f170c5a.zip

      The request logs shows the mod file downloaded but not the zip file.
      20190116034806|2041|REQUEST|64.71.2.36|anonymous|GET|/api/go/gocenter-virtual/github.com/aphistic/sweet/@v/v0.0.0-20180618201346-68e18ab55a67.mod|HTTP/1.1|200|312
      20190116034806|1121|REQUEST|64.71.2.36|anonymous|GET|/api/go/gocenter-virtual/github.com/aphistic/sweet/@v/v0.0.0-20180618201346-68e18ab55a67.mod|HTTP/1.1|200|312
      20190116034806|695|REQUEST|64.71.2.36|anonymous|GET|/api/go/gocenter-virtual/github.com/aphistic/sweet/@v/v0.0.0-20180618201346-68e18ab55a67.info|HTTP/1.1|200|0
      20190116034806|1036|REQUEST|64.71.2.36|anonymous|GET|/api/go/gocenter-virtual/github.com/aphistic/sweet/@v/v0.0.0-20180618201346-68e18ab55a67.mod|HTTP/1.1|200|312
      20190116034806|3653|REQUEST|64.71.2.36|anonymous|GET|/api/go/gocenter-virtual/github.com/aphistic/sweet/@v/v0.0.0-20180618201346-68e18ab55a67.mod|HTTP/1.1|200|312

      *Question is why the error is generated and the assumption is that the module is not loaded.
      Working with Nadav Yogev to troubleshoot the issue*

      Additional Information modules with same issue -
      v0.0.0-20160813154853-07dd2e8dfe18 zip could not be found
      2019-01-16 01:31:50,890 [http-nio-8081-exec-284] [ERROR] (o.j.r.g.r.h.GoLocalRepoHandler:127) - Couldn't find version info for project go.uber.org/atomic, due to version v1.3.2 zip could not be found
      2019-01-16 01:31:51,277 [http-nio-8081-exec-222] [ERROR] (o.j.r.g.r.h.GoLocalRepoHandler:127) - Couldn't find version info for project go.uber.org/atomic, due to version v1.3.2 zip could not be found
      2019-01-16 01:31:54,413 [http-nio-8081-exec-282] [ERROR] (o.j.r.g.r.h.GoLocalRepoHandler:127) - Couldn't find version info for project github.com/ugorji/go/codec, due to version v0.0.0-20181204163529-d75b2dcb6bc8 zip could not be found
      2019-01-16 01:31:54,757 [http-nio-8081-exec-281] [ERROR] (o.j.r.g.r.h.GoLocalRepoHandler:127) - Couldn't find version info for project go.uber.org/atomic, due to version v1.3.2 zip could not be found
      2019-01-16 01:31:57,250 [http-nio-8081-exec-123] [ERROR] (o.j.r.g.r.h.GoLocalRepoHandler:127) - Couldn't find version info for project go.uber.org/atomic, due to version v1.3.2 zip could not be found
      2019-01-16 01:31:58,056 [http-nio-8081-exec-257] [ERROR] (o.j.r.g.r.h.GoLocalRepoHandler:127) - Couldn't find version info for project go.uber.org/atomic, due to version v1.3.2 zip could not be found
      2019-01-16 01:32:22,301 [http-nio-8081-exec-265] [ERROR] (o.j.r.g.r.h.GoLocalRepoHandler:127) - Couldn't find version info for project go.uber.org/atomic, due to version v1.3.2 zip could not be found
      2019-01-16 01:33:23,934 [http-nio-8081-exec-310] [ERROR] (o.j.r.g.r.h.GoLocalRepoHandler:127) - Couldn't find version info for project golang.org/x/net, due to version v0.0.0-20190108225652-1e06a53dbb7e zip could not be found
      2019-01-16 01:33:24,976 [http-nio-8081-exec-308] [ERROR] (o.j.r.g.r.h.GoLocalRepoHandler:127) - Couldn't find version info for project golang.org/x/net, due to version v0.0.0-20190110200230-915654e7eabc zip could not be found
      2019-01-16 01:33:30,885 [http-nio-8081-exec-292] [ERROR] (o.j.r.g.r.h.GoLocalRepoHandler:127) - Couldn't find version info for project golang.org/x/lint, due to version v0.0.0-20181217174547-8f45f776aaf1 zip could not be found
      2019-01-16 01:33:38,487 [http-nio-8081-exec-202] [ERROR] (o.j.r.g.r.h.GoLocalRepoHandler:127) - Couldn't find version info for project golang.org/x/text, due to version v0.3.1-0.20180807135948-17ff2d5776d2 zip could not be found
      2019-01-16 01:33:41,683 [http-nio-8081-exec-285] [ERROR] (o.j.r.g.r.h.GoLocalRepoHandler:127) - Couldn't find version info for project golang.org/x/time, due to version v0.0.0-20181108054448-85acf8d2951c zip could not be found
      2019-01-16 01:33:52,292 [http-nio-8081-exec-305] [ERROR] (o.j.r.g.r.h.GoLocalRepoHandler:127) - Couldn't find version info for project google.golang.org/appengine, due to version v1.4.0 zip could not be found
      2019-01-16 01:33:52,516 [http-nio-8081-exec-209] [ERROR] (o.j.r.g.r.h.GoLocalRepoHandler:127) - Couldn't find version info for project google.golang.org/appengine, due to version v1.4.0 zip could not be found
      2019-01-16 01:33:59,343 [http-nio-8081-exec-292] [ERROR] (o.j.r.g.r.h.GoLocalRepoHandler:127) - Couldn't find version info for project golang.org/x/perf, due to version v0.0.0-20180704124530-6e6d33e29852 zip could not be found
      2019-01-16 01:34:08,351 [http-nio-8081-exec-288] [ERROR] (o.j.r.g.r.h.GoLocalRepoHandler:127) - Couldn't find version info for project gopkg.in/fsnotify.v1, due to version v1.2.1 zip could not be found
      2019-01-16 01:34:16,681 [http-nio-8081-exec-177] [ERROR] (o.j.r.g.r.h.GoLocalRepoHandler:127) - Couldn't find version info for project golang.org/x/tools, due to version v0.0.0-20180828015842-6cd1fcedba52 zip could not be found
      2019-01-16 01:34:59,602 [http-nio-8081-exec-292] [ERROR] (o.j.r.g.r.h.GoLocalRepoHandler:127) - Couldn't find version info for project gopkg.in/inf.v0, due to version v0.9.1 zip could not be found
      2019-01-16 01:35:01,488 [http-nio-8081-exec-242] [ERROR] (o.j.r.g.r.h.GoLocalRepoHandler:127) - Couldn't find version info for project gopkg.in/inf.v0, due to version v0.9.1 zip could not be found
      2019-01-16 01:35:01,655 [http-nio-8081-exec-262] [ERROR] (o.j.r.g.r.h.GoLocalRepoHandler:127) - Couldn't find version info for project gopkg.in/inf.v0, due to version v0.9.1 zip could not be found
      2019-01-16 01:35:01,884 [http-nio-8081-exec-252] [ERROR] (o.j.r.g.r.h.GoLocalRepoHandler:127) - Couldn't find version info for project gopkg.in/inf.v0, due to version v0.9.1 zip could not be found
      2019-01-16 01:35:01,886 [http-nio-8081-exec-253] [ERROR] (o.j.r.g.r.h.GoLocalRepoHandler:127) - Couldn't find version info for project gopkg.in/inf.v0, due to version v0.9.1 zip could not be found
      2019-01-16 01:35:03,380 [http-nio-8081-exec-170] [ERROR] (o.j.r.g.r.h.GoLocalRepoHandler:127) - Couldn't find version info for project gopkg.in/inf.v0, due to version v0.9.1 zip could not be found
      2019-01-16 01:35:08,056 [http-nio-8081-exec-276] [ERROR] (o.j.r.g.r.h.GoLocalRepoHandler:127) - Couldn't find version info for project gopkg.in/inf.v0, due to version v0.9.1 zip could not be found
      2019-01-16 01:35:09,655 [http-nio-8081-exec-272] [ERROR] (o.j.r.g.r.h.GoLocalRepoHandler:127) - Couldn't find version info for project gopkg.in/inf.v0, due to version v0.9.1 zip could not be found
      2019-01-16 01:35:40,892 [http-nio-8081-exec-266] [ERROR] (o.j.r.g.r.h.GoLocalRepoHandler:127) - Couldn't find version info for project gopkg.in/inf.v0, due to version v0.9.1 zip could not be found
      2019-01-16 07:28:58,376 [http-nio-8081-exec-141] [ERROR] (o.j.r.g.r.h.GoLocalRepoHandler:127) - Couldn't find version info for project github.com/BurntSushi/xgb, due to version v0.0.0-20160522181843-27f122750802 zip could not be found
      2019-01-16 19:34:27,294 [http-nio-8081-exec-1640] [ERROR] (o.j.r.g.r.h.GoLocalRepoHandler:127) - Couldn't find version info for project github.com/BurntSushi/xgb, due to version v0.0.0-20160522181843-27f122750802 zip could not be found
      2019-01-16 19:40:09,621 [http-nio-8081-exec-1534] [ERROR] (o.j.r.g.r.h.GoLocalRepoHandler:127) - Couldn't find version info for project github.com/BurntSushi/xgb, due to version v0.0.0-20160522181843-27f122750802 zip could not be found
      2019-01-16 19:40:23,093 [http-nio-8081-exec-1683] [WARN ] (o.a.r.ArtifactoryResponseBase:125) - Sending HTTP error code 500: Could not process download request: Cannot construct a module info object from a blank item path.
      2019-01-16 19:40:43,600 [http-nio-8081-exec-1676] [WARN ] (o.a.r.ArtifactoryResponseBase:125) - Sending HTTP error code 500: Could not process download request: Cannot construct a module info object from a blank item path.
      2019-01-16 19:41:55,642 [http-nio-8081-exec-1587] [ERROR] (o.j.r.g.r.h.GoLocalRepoHandler:127) - Couldn't find version info for project github.com/BurntSushi/xgb, due to version v0.0.0-20160522181843-27f122750802 zip could not be found
      2019-01-16 19:46:02,088 [http-nio-8081-exec-1672] [ERROR] (o.j.r.g.r.h.GoLocalRepoHandler:127) - Couldn't find version info for project github.com/BurntSushi/xgb, due to version v0.0.0-20160522181843-27f122750802 zip could not be found
      2019-01-16 19:48:00,550 [http-nio-8081-exec-2101] [ERROR] (o.j.r.g.r.h.GoLocalRepoHandler:127) - Couldn't find version info for project github.com/BurntSushi/xgb, due to version v0.0.0-20160522181843-27f122750802 zip could not be found
      2019-01-16 19:50:31,506 [http-nio-8081-exec-2173] [ERROR] (o.j.r.g.r.h.GoLocalRepoHandler:127) - Couldn't find version info for project github.com/BurntSushi/xgb, due to version v0.0.0-20160522181843-27f122750802 zip could not be found

        Attachments

          Activity

            People

            • Assignee:
              nadavy Nadav Yogev
              Reporter:
              stanleyf Stanley Fong
            • Votes:
              0 Vote for this issue
              Watchers:
              4 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: