Uploaded image for project: 'Artifactory Binary Repository'
  1. Artifactory Binary Repository
  2. RTFACT-18455

"Set Me Up" claims I do not have permission to deploy to virtual repo

    Details

    • Type: Bug
    • Status: Open
    • Priority: Minor
    • Resolution: Unresolved
    • Affects Version/s: None
    • Fix Version/s: None
    • Component/s: Set Me Up
    • Labels:
      None
    • Environment:

      Artifactory 6.7.2

      Centos 7.3

      Firefox 64.0.2

      Description

      A user, "artifactory.test" has "Push_to_repos" permissions to "npm__local" repository

      A virtual repo, "npm" contains "npm__local" as its Default Deployment Repository

      If the user artifactory.test authenticates to "Set Me Up" in the Artifactory GUI and looks for "npm__local", it all looks correct.

      Instead if the user goes to the "npm" repository, there is an (incorrect) warning displayed: "You do not have deploy permissions to this repository"

      I believe that is confusing behavior because I can, as user "artifactory.test" deploy to the repo "npm", which will internally store the artifact in "npm__local"

      Correct behavior would be to only warn if the target repo was undeployable by the user.

      I've seen this behavior with generic virtual/local repos as well.

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                Unassigned
                Reporter:
                eric.griswold Eric Griswold
              • Votes:
                0 Vote for this issue
                Watchers:
                2 Start watching this issue

                Dates

                • Created:
                  Updated: