Uploaded image for project: 'Artifactory Binary Repository'
  1. Artifactory Binary Repository
  2. RTFACT-20607

Downloading artifacts through search page not encoding the special characters like #, % as %23

    Details

    • Type: Bug
    • Status: Open
    • Priority: Normal
    • Resolution: Unresolved
    • Affects Version/s: 6.14.1
    • Fix Version/s: None
    • Component/s: None
    • Labels:
      None

      Description

      Downloading the artifacts with special characters like "#", "%" in path failed to escaped as %23 in search page whereas it is working fine from the tree browser.

       

      The download link on the Search page (which doesn't work - returns 404) forwards you to:

      http://localhost:8081/artifactory/generic-local/hello#/R-3.5.3.pkg

       

      The download link on the Tree browser (which does work) forwards you to:

      http://localhost:8081/artifactory/generic-local/hello%23/R-3.5.3.pkg

       

      The Tree browser is correctly encoding the special character as "%23", whereas the Search page does not and causing 404 error while trying to download the artifacts.

       

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                Unassigned
                Reporter:
                sankark Sankar Kumar
              • Votes:
                1 Vote for this issue
                Watchers:
                2 Start watching this issue

                Dates

                • Created:
                  Updated: