Uploaded image for project: 'Artifactory Binary Repository'
  1. Artifactory Binary Repository
  2. RTFACT-23005

plugin link from artifactory is not url decoded properly for '::' when selected from jenkins

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Open
    • Priority: 3 - High
    • Resolution: Unresolved
    • Affects Version/s: 7.6.3, 7.7.3
    • Fix Version/s: None
    • Component/s: Artifactory, Plugins
    • Environment:

      artifactory - centos 7.4

      jenkins - centos 7.3

    • Severity:
      High
    • Regression:
      Yes

      Description

      Artifactory version 7.6.3
      Jenkins version 2.235.2
      Artifactory plugin version: 3.7.0/3.7.3 

      1. Artifact is published and from jenkins link url shows as 'http://my_art_instance:8081/artifactory/webapp/builds/TYPE*%20%3A%3A%20*My-Test*%20%3A%3A%20*master/999'.

      2. From jenkins select the link:

      3. Artifactory link opens to http://my_art_instance:8082/ui/builds/TYPE*%2520%253A%253A%2520*My-Test*%2520%253A%253A%2520*master. 

      The result is the build path shows as 'Builds > TYPE%20%3A%3A%20My-Test%20%3A%3A%20master' and no builds are listed.  '::' is not escaped.

      4. Modify the link and remove the extra '25':
      http://my_art_instance:8082/ui/builds/TYPE%20%3A%3A%20My-Test%20%3A%3A%20master. 

      Correct build info loads in the page and shows '::' properly.

      Not sure if this is plugin side or artifacory side but using both plugin versions have same result.

        Attachments

          Activity

            People

            Assignee:
            Unassigned
            Reporter:
            ckcrowe christopher crowe
            Votes:
            1 Vote for this issue
            Watchers:
            3 Start watching this issue

              Dates

              Created:
              Updated:

                Sync Status

                Connection: RTFACT Sync
                RTMID-23005 -
                SYNCHRONIZED
                • Last Sync Date: