Uploaded image for project: 'Artifactory Binary Repository'
  1. Artifactory Binary Repository
  2. RTFACT-23033

Licenses of a artifact not shown in build view

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Open
    • Priority: 4 - Normal
    • Resolution: Unresolved
    • Affects Version/s: 6.20.1
    • Fix Version/s: None
    • Component/s: Artifactory
    • Labels:
    • Environment:

      Artifactory Pro 6.20.1

    • Severity:
      Medium

      Description

      We publish our artifacts from Jenkins build process into a Generic repository. Artifacts are linked properly with the build (build-info) and are listed there.

      On some artifacts we attach license information by setting the property "artifact.licenses". Licenses are shown in the when browsing the artifacts but not in the build view.

      Steps to reproduce

      1. Publish a build with some artifacts
      2. Add some existing licenses to the property "artifacts.licenses" to the published artifact
      3. Check if the licenses are shown in the in the artfifacts "General" Tab under "Licenses"
      4. Browse to the Build linked with this artifact
      5. Open the Licenses tab and enable "Include Published Artifacts".
      6. Artifacts are not shown.

      We would expect in step 6 that the artifacts added on a artifact linked to the build would also show up in the builds License Tab.

        Attachments

          Activity

            People

            Assignee:
            Unassigned
            Reporter:
            samuel.bissig2 Samuel Bissig
            Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

              Dates

              Created:
              Updated:

                Sync Status

                Connection: RTFACT Sync
                RTMID-23033 -
                SYNCHRONIZED
                • Last Sync Date: