Uploaded image for project: 'Artifactory Binary Repository'
  1. Artifactory Binary Repository
  2. RTFACT-25602

NPM package metadata is outdated compared to the remote registry

    XMLWordPrintable

    Details

    • Severity:
      Medium

      Description

      Hello,

      When we try to install some NPM dependencies, it sometimes fails on a 404. I have found this article for a workaround: https://jfrog.com/knowledge-base/why-am-i-getting-404-for-some-npm-packages/

      It seems the "Zap cache" solves a part of the issue as we're now able to download the tarball. However, the package metadata is still out of date.

      Example:

      We had a failure on @babel/compat-data version 7.13.15

      The metadata still indicates 7.13.12 is the latest tag, and version 7.13.15 is not listed in there: https://lafourchette.jfrog.io/lafourchette/api/npm/npm/@babel/compat-data

      The remote version is listed on remote metadata: https://registry.npmjs.com/@babel/compat-data

      There is the same issue for @babel/plugin-proposal-async-generator-functions

        Attachments

          Activity

            People

            Assignee:
            Unassigned
            Reporter:
            sgeraud Stephane Geraud
            Votes:
            1 Vote for this issue
            Watchers:
            3 Start watching this issue

              Dates

              Created:
              Updated:

                Sync Status

                Connection: RTFACT Sync
                RTMID-25602 -
                SYNCHRONIZED
                • Last Sync Date: