Uploaded image for project: 'Artifactory Binary Repository'
  1. Artifactory Binary Repository
  2. RTFACT-26142

RPM repository becomes corrupt and requires re-creating

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Open
    • Priority: 4 - Normal
    • Resolution: Unresolved
    • Affects Version/s: 7.16.3
    • Fix Version/s: None
    • Component/s: Artifactory, RPM
    • Labels:
      None
    • Location:
      External

      Description

      On several occasions, we have had a local RPM repository become corrupted is such away that certain packages are not able to be installed via yum. 

      Errors include:

      Yum:
      [Errno -1] Package does not match intended download. Suggestion: run yum --enablerepo=xxxxx-xxxx clean metadata

      Tomcat/Artifactory:
      [http-nio-8081-exec-8] [WARN ] (o.a.r.r.Range :125) - Returning not satisfiable range status since none of the ranges in 'bytes=24011664-' is valid

      No combination of zap caches or index rebuilds seem to resolve the problem.

      While the condition can be resolved by dropping and re-creating the issue, this does not feel like a reasonable fix. 

      What would the recommended fix be for this condition?

       

      Vince

        Attachments

          Activity

            People

            Assignee:
            Unassigned
            Reporter:
            vince.allen Vince Allen
            Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

              Dates

              Created:
              Updated:

                Sync Status

                Connection: RTFACT Sync
                RTMID-26143 -
                SYNCHRONIZED
                • Last Sync Date: