Uploaded image for project: 'Artifactory Binary Repository'
  1. Artifactory Binary Repository
  2. RTFACT-26663

Go remote does not return packages

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Closed
    • Resolution: Done
    • Affects Version/s: None
    • Fix Version/s: None
    • Component/s: Artifactory Cloud
    • Labels:
      None
    • Location:
      External

      Description

      Hello JFrog.

       

      Builds suddenly started failing with 404 returned to the go client.

      After checking the configuration of the repo, I saw, as in the attached image, that the test to the remote url fails and i suspect that this might be the root cause.

       

      Step to reproduce:

      Setup a remote go repo.

      Configure the GOPROXY environment variable to resolve from the remote repo.

      Install any go package: go get github.com/gobwas/ws

      The response should look similar to:

      go get: module github.com/gobwas/ws: reading https://user:xxxxx@domain/artifactory/api/go/sternum-go/github.com/gobwas/ws/@v/list: 404 Not Found

      The package can be resolved when assigning a blank string "" to the GOPROXY (disabling the proxy basically).

       

      Thanks in advance.

        Attachments

          Activity

              People

              Assignee:
              Unassigned
              Reporter:
              5haharl Shahar
              Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved:

                  Sync Status

                  Connection: RTFACT Sync
                  RTMID-26673 -
                  SYNCHRONIZED
                  • Last Sync Date: