Uploaded image for project: 'Artifactory Binary Repository'
  1. Artifactory Binary Repository
  2. RTFACT-26893

Feature support adding version_limitations <=, >= for repository

    XMLWordPrintable

    Details

    • Type: New Feature
    • Status: Closed
    • Resolution: Deferred
    • Affects Version/s: 7.18.3, 7.17.11
    • Fix Version/s: None
    • Component/s: None
    • Location:
      External

      Description

      Hi.

      I have a remote repository which is a proxy of pypi.org. I am trying to control more about packages versions. I am only able to find to use the exclude patterns.

      However for use case like below, the exclude patterns will not be a good implementation.

      Example:

      For package markupsafe, I only wants to provide "version_limits": ">=0.18,<2.1.0", because newer versions will have break changes.

       

      It is very common for users to set packages versions by >-=, <= inside their requirements3.txt for pip install.

      I image it will also be very common for version control within a range, like >= or <=.

        Attachments

          Activity

            People

            Assignee:
            Unassigned
            Reporter:
            9PeCrMZtt2@3vdD Xiaoyan Li
            Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved:

                Sync Status

                Connection: RTFACT Sync
                RTMID-26903 -
                SYNCHRONIZED
                • Last Sync Date: