Uploaded image for project: 'Artifactory Binary Repository'
  1. Artifactory Binary Repository
  2. RTFACT-27083

Unable to change the repository environment from DEV -> PROD in project.

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Done
    • Resolution: Done
    • Affects Version/s: None
    • Fix Version/s: None
    • Component/s: Access
    • Labels:
      None
    • Severity:
      Medium
    • Location:
      External

      Description

      Problem description:  Unable to change repository environment from DEV -> PROD under the Artifactory Project

       

      Steps to reproduce: 

      1. Log into Artifactory, create two projects
      2. Share a test local repository between all the projects ( even not shared should work )
      3. Select a project admin view.
      4. Select the Repositories tab from the Project admin view.
      5. Select a repo that is shared with all repos (or a repo that is directory created for this project)
      6. Change the Environments from "Dev" to "Prod" and Save changes
      7. Select that exact same Repo, and you will see that it is back to "Dev"

      Environment details: 

       Tested in the Artifactory version 7.33.12 and also in latest version 7.37.15 issue persists.

      What is the expected behavior?

       When we click the PROD-button or Viceversa it should accept the changes and save .

        Attachments

          Activity

              People

              Assignee:
              Unassigned
              Reporter:
              ujwalp Ujwal Poovaiah
              Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

                Dates

                Created:
                Updated:
                Resolved:

                  Sync Status

                  Connection: RTFACT Sync
                  RTMID-27147 -
                  SYNCHRONIZED
                  • Last Sync Date: