Uploaded image for project: 'Artifactory Binary Repository'
  1. Artifactory Binary Repository
  2. RTFACT-2855

StringIndexOutOfBoundsException: String index out of range: -1 when navigating long paths in simple repo browser

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: Normal
    • Resolution: Duplicate
    • Affects Version/s: 2.1.3
    • Fix Version/s: None
    • Component/s: None
    • Labels:
      None
    • Environment:

      Tomcat 6, Java 1.6, MySQL

      Description

      Hello,

      When navigating long paths using the simple repo browser the interface throws a StringIndexOutOfBoundsException and shows a blank page. Some examples:
      http://scm.axway.corp.sopra/artifactory/repo/com/axway/composer/integrator/ works
      http://scm.axway.corp.sopra/artifactory/repo/com/axway/composer/integrator/enabler/ doesn't work

      http://scm.axway.corp.sopra/artifactory/repo/synchrony/eci/maven/workstation/ works
      http://scm.axway.corp.sopra/artifactory/repo/synchrony/eci/maven/workstation/maven_workstation_settings/

      The cutoff point seems around 85 character for the full URL - are you using a fixed size buffer somewhere around there?

      Steps to reproduce:
      1. Make a repo.
      2. Create a long path.
      3. Try to access it.
      4. Blank page.

      The exception:
      2010-02-23 09:48:40,301 [TP-Processor26] [ERROR] (o.a.w.RequestCycle :1502) - Can't instantiate page using constructor public org.artifactory.webapp.wicket.page.browse.simplebrowser.SimpleRepoBrowserPage()
      org.apache.wicket.WicketRuntimeException: Can't instantiate page using constructor public org.artifactory.webapp.wicket.page.browse.simplebrowser.SimpleRepoBrowserPage()
      at org.apache.wicket.session.DefaultPageFactory.createPage(DefaultPageFactory.java:206) [wicket-1.3.7.jar:1.3.7]
      at org.apache.wicket.session.DefaultPageFactory.newPage(DefaultPageFactory.java:57) [wicket-1.3.7.jar:1.3.7]
      at org.apache.wicket.request.target.component.BookmarkablePageRequestTarget.newPage(BookmarkablePageRequestTarget.java:272) [wicket-1.3.7.jar:1.3.7]
      at org.apache.wicket.request.target.component.BookmarkablePageRequestTarget.getPage(BookmarkablePageRequestTarget.java:293) [wicket-1.3.7.jar:1.3.7]
      at org.apache.wicket.request.target.component.BookmarkablePageRequestTarget.processEvents(BookmarkablePageRequestTarget.java:210) [wicket-1.3.7.jar:1.3.7]
      at org.apache.wicket.request.AbstractRequestCycleProcessor.processEvents(AbstractRequestCycleProcessor.java:91) [wicket-1.3.7.jar:1.3.7]
      at org.apache.wicket.RequestCycle.processEventsAndRespond(RequestCycle.java:1239) [wicket-1.3.7.jar:1.3.7]
      at org.apache.wicket.RequestCycle.step(RequestCycle.java:1316) [wicket-1.3.7.jar:1.3.7]
      at org.apache.wicket.RequestCycle.steps(RequestCycle.java:1418) [wicket-1.3.7.jar:1.3.7]
      at org.apache.wicket.RequestCycle.request(RequestCycle.java:532) [wicket-1.3.7.jar:1.3.7]
      at org.apache.wicket.protocol.http.WicketFilter.doGet(WicketFilter.java:356) [wicket-1.3.7.jar:1.3.7]
      at org.apache.wicket.protocol.http.WicketFilter.doFilter(WicketFilter.java:201) [wicket-1.3.7.jar:1.3.7]
      at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:235) [catalina.jar:na]
      at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:206) [catalina.jar:na]
      at org.artifactory.webapp.servlet.RepoFilter.execute(RepoFilter.java:165) [artifactory-web-application-2.1.3.jar:na]
      at org.artifactory.webapp.servlet.RepoFilter.doFilter(RepoFilter.java:76) [artifactory-web-application-2.1.3.jar:na]
      at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:235) [catalina.jar:na]
      at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:206) [catalina.jar:na]
      at org.artifactory.webapp.servlet.AccessFilter.useAuthentication(AccessFilter.java:191) [artifactory-web-application-2.1.3.jar:na]
      at org.artifactory.webapp.servlet.AccessFilter.doFilterInternal(AccessFilter.java:110) [artifactory-web-application-2.1.3.jar:na]
      at org.artifactory.webapp.servlet.AccessFilter.doFilter(AccessFilter.java:91) [artifactory-web-application-2.1.3.jar:na]
      at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:235) [catalina.jar:na]
      at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:206) [catalina.jar:na]
      at org.artifactory.webapp.servlet.RequestFilter.doFilter(RequestFilter.java:54) [artifactory-web-application-2.1.3.jar:na]
      at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:235) [catalina.jar:na]
      at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:206) [catalina.jar:na]
      at org.artifactory.webapp.servlet.ArtifactoryFilter.doFilter(ArtifactoryFilter.java:54) [artifactory-web-application-2.1.3.jar:na]
      at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:235) [catalina.jar:na]
      at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:206) [catalina.jar:na]
      at org.apache.catalina.core.ApplicationDispatcher.invoke(ApplicationDispatcher.java:630) [catalina.jar:na]
      at org.apache.catalina.core.ApplicationDispatcher.processRequest(ApplicationDispatcher.java:436) [catalina.jar:na]
      at org.apache.catalina.core.ApplicationDispatcher.doForward(ApplicationDispatcher.java:374) [catalina.jar:na]
      at org.apache.catalina.core.ApplicationDispatcher.forward(ApplicationDispatcher.java:302) [catalina.jar:na]
      at org.artifactory.webapp.servlet.RepoFilter.execute(RepoFilter.java:108) [artifactory-web-application-2.1.3.jar:na]
      at org.artifactory.webapp.servlet.RepoFilter.doFilter(RepoFilter.java:76) [artifactory-web-application-2.1.3.jar:na]
      at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:235) [catalina.jar:na]
      at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:206) [catalina.jar:na]
      at org.artifactory.webapp.servlet.AccessFilter.useAuthentication(AccessFilter.java:191) [artifactory-web-application-2.1.3.jar:na]
      at org.artifactory.webapp.servlet.AccessFilter.doFilterInternal(AccessFilter.java:110) [artifactory-web-application-2.1.3.jar:na]
      at org.artifactory.webapp.servlet.AccessFilter.doFilter(AccessFilter.java:91) [artifactory-web-application-2.1.3.jar:na]
      at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:235) [catalina.jar:na]
      at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:206) [catalina.jar:na]
      at org.artifactory.webapp.servlet.RequestFilter.doFilter(RequestFilter.java:54) [artifactory-web-application-2.1.3.jar:na]
      at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:235) [catalina.jar:na]
      at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:206) [catalina.jar:na]
      at org.artifactory.webapp.servlet.ArtifactoryFilter.doFilter(ArtifactoryFilter.java:54) [artifactory-web-application-2.1.3.jar:na]
      at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:235) [catalina.jar:na]
      at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:206) [catalina.jar:na]
      at org.apache.catalina.core.StandardWrapperValve.invoke(StandardWrapperValve.java:233) [catalina.jar:na]
      at org.apache.catalina.core.StandardContextValve.invoke(StandardContextValve.java:175) [catalina.jar:na]
      at org.apache.catalina.core.StandardHostValve.invoke(StandardHostValve.java:128) [catalina.jar:na]
      at org.apache.catalina.valves.ErrorReportValve.invoke(ErrorReportValve.java:102) [catalina.jar:na]
      at org.apache.catalina.core.StandardEngineValve.invoke(StandardEngineValve.java:109) [catalina.jar:na]
      at org.apache.catalina.connector.CoyoteAdapter.service(CoyoteAdapter.java:286) [catalina.jar:na]
      at org.apache.jk.server.JkCoyoteHandler.invoke(JkCoyoteHandler.java:190) [tomcat-coyote.jar:na]
      at org.apache.jk.common.HandlerRequest.invoke(HandlerRequest.java:283) [tomcat-coyote.jar:na]
      at org.apache.jk.common.ChannelSocket.invoke(ChannelSocket.java:767) [tomcat-coyote.jar:na]
      at org.apache.jk.common.ChannelSocket.processConnection(ChannelSocket.java:697) [tomcat-coyote.jar:na]
      at org.apache.jk.common.ChannelSocket$SocketConnection.runIt(ChannelSocket.java:889) [tomcat-coyote.jar:na]
      at org.apache.tomcat.util.threads.ThreadPool$ControlRunnable.run(ThreadPool.java:690) [tomcat-coyote.jar:na]
      at java.lang.Thread.run(Thread.java:619) [na:1.6.0_14-ea]
      Caused by: java.lang.reflect.InvocationTargetException: null
      at sun.reflect.NativeConstructorAccessorImpl.newInstance0(Native Method) [na:1.6.0_14-ea]
      at sun.reflect.NativeConstructorAccessorImpl.newInstance(NativeConstructorAccessorImpl.java:39) [na:1.6.0_14-ea]
      at sun.reflect.DelegatingConstructorAccessorImpl.newInstance(DelegatingConstructorAccessorImpl.java:27) [na:1.6.0_14-ea]
      at java.lang.reflect.Constructor.newInstance(Constructor.java:513) [na:1.6.0_14-ea]
      at org.apache.wicket.session.DefaultPageFactory.createPage(DefaultPageFactory.java:186) [wicket-1.3.7.jar:1.3.7]
      ... 60 common frames omitted
      Caused by: java.lang.StringIndexOutOfBoundsException: String index out of range: -1
      at java.lang.AbstractStringBuilder.setLength(AbstractStringBuilder.java:143) [na:1.6.0_14-ea]
      at java.lang.StringBuffer.setLength(StringBuffer.java:153) [na:1.6.0_14-ea]
      at org.apache.wicket.protocol.http.RequestUtils.toAbsolutePath(RequestUtils.java:206) [wicket-1.3.7.jar:1.3.7]
      at org.apache.wicket.protocol.http.RequestUtils.toAbsolutePath(RequestUtils.java:169) [wicket-1.3.7.jar:1.3.7]
      at org.artifactory.common.wicket.util.WicketUtils.getWicketAppPath(WicketUtils.java:86) [artifactory-web-common-2.1.3.jar:na]
      at org.artifactory.webapp.wicket.components.container.LogoLinkContainer.<init>(LogoLinkContainer.java:43) [artifactory-web-application-2.1.3.jar:na]
      at org.artifactory.addon.wicket.WicketAddonsImpl.getHomeLink(WicketAddonsImpl.java:260) [artifactory-web-application-2.1.3.jar:na]
      at sun.reflect.GeneratedMethodAccessor192.invoke(Unknown Source) [na:na]
      at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25) [na:1.6.0_14-ea]
      at java.lang.reflect.Method.invoke(Method.java:597) [na:1.6.0_14-ea]
      at org.springframework.aop.support.AopUtils.invokeJoinpointUsingReflection(AopUtils.java:307) [spring-aop-2.5.6.jar:2.5.6]
      at org.springframework.aop.framework.JdkDynamicAopProxy.invoke(JdkDynamicAopProxy.java:198) [spring-aop-2.5.6.jar:2.5.6]
      at $Proxy54.getHomeLink(Unknown Source) [na:na]
      at org.artifactory.webapp.wicket.page.base.BasePage.init(BasePage.java:96) [artifactory-web-application-2.1.3.jar:na]
      at org.artifactory.webapp.wicket.page.base.BasePage.<init>(BasePage.java:63) [artifactory-web-application-2.1.3.jar:na]
      at org.artifactory.webapp.wicket.page.base.AuthenticatedPage.<init>(AuthenticatedPage.java:41) [artifactory-web-application-2.1.3.jar:na]
      at org.artifactory.webapp.wicket.page.browse.simplebrowser.SimpleRepoBrowserPage.<init>(SimpleRepoBrowserPage.java:40) [artifactory-web-application-2.1.3.jar:na]
      ... 65 common frames omitted
      2010-02-23 09:48:40,309 [TP-Processor26] [ERROR] (o.a.w.RequestCycle :1372) - unexpected exception when handling another exception: Can't instantiate page using constructor public org.artifactory.webapp.wicket.page.error.InternalErrorPage()
      org.apache.wicket.WicketRuntimeException: Can't instantiate page using constructor public org.artifactory.webapp.wicket.page.error.InternalErrorPage()
      at org.apache.wicket.session.DefaultPageFactory.createPage(DefaultPageFactory.java:206) [wicket-1.3.7.jar:1.3.7]
      at org.apache.wicket.session.DefaultPageFactory.newPage(DefaultPageFactory.java:57) [wicket-1.3.7.jar:1.3.7]
      at org.apache.wicket.request.target.component.BookmarkablePageRequestTarget.newPage(BookmarkablePageRequestTarget.java:272) [wicket-1.3.7.jar:1.3.7]
      at org.apache.wicket.request.target.component.BookmarkablePageRequestTarget.getPage(BookmarkablePageRequestTarget.java:293) [wicket-1.3.7.jar:1.3.7]
      at org.apache.wicket.request.target.component.BookmarkablePageRequestTarget.respond(BookmarkablePageRequestTarget.java:240) [wicket-1.3.7.jar:1.3.7]
      at org.apache.wicket.request.AbstractRequestCycleProcessor.respond(AbstractRequestCycleProcessor.java:104) [wicket-1.3.7.jar:1.3.7]
      at org.apache.wicket.RequestCycle.respond(RequestCycle.java:1254) [wicket-1.3.7.jar:1.3.7]
      at org.apache.wicket.RequestCycle.step(RequestCycle.java:1321) [wicket-1.3.7.jar:1.3.7]
      at org.apache.wicket.RequestCycle.steps(RequestCycle.java:1418) [wicket-1.3.7.jar:1.3.7]
      at org.apache.wicket.RequestCycle.request(RequestCycle.java:532) [wicket-1.3.7.jar:1.3.7]
      at org.apache.wicket.protocol.http.WicketFilter.doGet(WicketFilter.java:356) [wicket-1.3.7.jar:1.3.7]
      at org.apache.wicket.protocol.http.WicketFilter.doFilter(WicketFilter.java:201) [wicket-1.3.7.jar:1.3.7]
      at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:235) [catalina.jar:na]
      at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:206) [catalina.jar:na]
      at org.artifactory.webapp.servlet.RepoFilter.execute(RepoFilter.java:165) [artifactory-web-application-2.1.3.jar:na]
      at org.artifactory.webapp.servlet.RepoFilter.doFilter(RepoFilter.java:76) [artifactory-web-application-2.1.3.jar:na]
      at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:235) [catalina.jar:na]
      at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:206) [catalina.jar:na]
      at org.artifactory.webapp.servlet.AccessFilter.useAuthentication(AccessFilter.java:191) [artifactory-web-application-2.1.3.jar:na]
      at org.artifactory.webapp.servlet.AccessFilter.doFilterInternal(AccessFilter.java:110) [artifactory-web-application-2.1.3.jar:na]
      at org.artifactory.webapp.servlet.AccessFilter.doFilter(AccessFilter.java:91) [artifactory-web-application-2.1.3.jar:na]
      at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:235) [catalina.jar:na]
      at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:206) [catalina.jar:na]
      at org.artifactory.webapp.servlet.RequestFilter.doFilter(RequestFilter.java:54) [artifactory-web-application-2.1.3.jar:na]
      at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:235) [catalina.jar:na]
      at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:206) [catalina.jar:na]
      at org.artifactory.webapp.servlet.ArtifactoryFilter.doFilter(ArtifactoryFilter.java:54) [artifactory-web-application-2.1.3.jar:na]
      at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:235) [catalina.jar:na]
      at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:206) [catalina.jar:na]
      at org.apache.catalina.core.ApplicationDispatcher.invoke(ApplicationDispatcher.java:630) [catalina.jar:na]
      at org.apache.catalina.core.ApplicationDispatcher.processRequest(ApplicationDispatcher.java:436) [catalina.jar:na]
      at org.apache.catalina.core.ApplicationDispatcher.doForward(ApplicationDispatcher.java:374) [catalina.jar:na]
      at org.apache.catalina.core.ApplicationDispatcher.forward(ApplicationDispatcher.java:302) [catalina.jar:na]
      at org.artifactory.webapp.servlet.RepoFilter.execute(RepoFilter.java:108) [artifactory-web-application-2.1.3.jar:na]
      at org.artifactory.webapp.servlet.RepoFilter.doFilter(RepoFilter.java:76) [artifactory-web-application-2.1.3.jar:na]
      at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:235) [catalina.jar:na]
      at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:206) [catalina.jar:na]
      at org.artifactory.webapp.servlet.AccessFilter.useAuthentication(AccessFilter.java:191) [artifactory-web-application-2.1.3.jar:na]
      at org.artifactory.webapp.servlet.AccessFilter.doFilterInternal(AccessFilter.java:110) [artifactory-web-application-2.1.3.jar:na]
      at org.artifactory.webapp.servlet.AccessFilter.doFilter(AccessFilter.java:91) [artifactory-web-application-2.1.3.jar:na]
      at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:235) [catalina.jar:na]
      at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:206) [catalina.jar:na]
      at org.artifactory.webapp.servlet.RequestFilter.doFilter(RequestFilter.java:54) [artifactory-web-application-2.1.3.jar:na]
      at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:235) [catalina.jar:na]
      at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:206) [catalina.jar:na]
      at org.artifactory.webapp.servlet.ArtifactoryFilter.doFilter(ArtifactoryFilter.java:54) [artifactory-web-application-2.1.3.jar:na]
      at org.apache.catalina.core.ApplicationFilterChain.internalDoFilter(ApplicationFilterChain.java:235) [catalina.jar:na]
      at org.apache.catalina.core.ApplicationFilterChain.doFilter(ApplicationFilterChain.java:206) [catalina.jar:na]
      at org.apache.catalina.core.StandardWrapperValve.invoke(StandardWrapperValve.java:233) [catalina.jar:na]
      at org.apache.catalina.core.StandardContextValve.invoke(StandardContextValve.java:175) [catalina.jar:na]
      at org.apache.catalina.core.StandardHostValve.invoke(StandardHostValve.java:128) [catalina.jar:na]
      at org.apache.catalina.valves.ErrorReportValve.invoke(ErrorReportValve.java:102) [catalina.jar:na]
      at org.apache.catalina.core.StandardEngineValve.invoke(StandardEngineValve.java:109) [catalina.jar:na]
      at org.apache.catalina.connector.CoyoteAdapter.service(CoyoteAdapter.java:286) [catalina.jar:na]
      at org.apache.jk.server.JkCoyoteHandler.invoke(JkCoyoteHandler.java:190) [tomcat-coyote.jar:na]
      at org.apache.jk.common.HandlerRequest.invoke(HandlerRequest.java:283) [tomcat-coyote.jar:na]
      at org.apache.jk.common.ChannelSocket.invoke(ChannelSocket.java:767) [tomcat-coyote.jar:na]
      at org.apache.jk.common.ChannelSocket.processConnection(ChannelSocket.java:697) [tomcat-coyote.jar:na]
      at org.apache.jk.common.ChannelSocket$SocketConnection.runIt(ChannelSocket.java:889) [tomcat-coyote.jar:na]
      at org.apache.tomcat.util.threads.ThreadPool$ControlRunnable.run(ThreadPool.java:690) [tomcat-coyote.jar:na]
      at java.lang.Thread.run(Thread.java:619) [na:1.6.0_14-ea]
      Caused by: java.lang.reflect.InvocationTargetException: null
      at sun.reflect.NativeConstructorAccessorImpl.newInstance0(Native Method) [na:1.6.0_14-ea]
      at sun.reflect.NativeConstructorAccessorImpl.newInstance(NativeConstructorAccessorImpl.java:39) [na:1.6.0_14-ea]
      at sun.reflect.DelegatingConstructorAccessorImpl.newInstance(DelegatingConstructorAccessorImpl.java:27) [na:1.6.0_14-ea]
      at java.lang.reflect.Constructor.newInstance(Constructor.java:513) [na:1.6.0_14-ea]
      at org.apache.wicket.session.DefaultPageFactory.createPage(DefaultPageFactory.java:186) [wicket-1.3.7.jar:1.3.7]
      ... 60 common frames omitted
      Caused by: java.lang.StringIndexOutOfBoundsException: String index out of range: -1
      at java.lang.AbstractStringBuilder.setLength(AbstractStringBuilder.java:143) [na:1.6.0_14-ea]
      at java.lang.StringBuffer.setLength(StringBuffer.java:153) [na:1.6.0_14-ea]
      at org.apache.wicket.protocol.http.RequestUtils.toAbsolutePath(RequestUtils.java:206) [wicket-1.3.7.jar:1.3.7]
      at org.apache.wicket.protocol.http.RequestUtils.toAbsolutePath(RequestUtils.java:169) [wicket-1.3.7.jar:1.3.7]
      at org.artifactory.common.wicket.util.WicketUtils.getWicketAppPath(WicketUtils.java:86) [artifactory-web-common-2.1.3.jar:na]
      at org.artifactory.webapp.wicket.components.container.LogoLinkContainer.<init>(LogoLinkContainer.java:43) [artifactory-web-application-2.1.3.jar:na]
      at org.artifactory.addon.wicket.WicketAddonsImpl.getHomeLink(WicketAddonsImpl.java:260) [artifactory-web-application-2.1.3.jar:na]
      at sun.reflect.GeneratedMethodAccessor192.invoke(Unknown Source) [na:na]
      at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25) [na:1.6.0_14-ea]
      at java.lang.reflect.Method.invoke(Method.java:597) [na:1.6.0_14-ea]
      at org.springframework.aop.support.AopUtils.invokeJoinpointUsingReflection(AopUtils.java:307) [spring-aop-2.5.6.jar:2.5.6]
      at org.springframework.aop.framework.JdkDynamicAopProxy.invoke(JdkDynamicAopProxy.java:198) [spring-aop-2.5.6.jar:2.5.6]
      at $Proxy54.getHomeLink(Unknown Source) [na:na]
      at org.artifactory.webapp.wicket.page.base.BasePage.init(BasePage.java:96) [artifactory-web-application-2.1.3.jar:na]
      at org.artifactory.webapp.wicket.page.base.BasePage.<init>(BasePage.java:63) [artifactory-web-application-2.1.3.jar:na]
      at org.artifactory.webapp.wicket.page.base.AuthenticatedPage.<init>(AuthenticatedPage.java:41) [artifactory-web-application-2.1.3.jar:na]
      at org.artifactory.webapp.wicket.page.home.HomePage.<init>(HomePage.java:34) [artifactory-web-application-2.1.3.jar:na]
      at org.artifactory.webapp.wicket.page.error.BaseMessagePage.<init>(BaseMessagePage.java:28) [artifactory-web-application-2.1.3.jar:na]
      at org.artifactory.webapp.wicket.page.error.InternalErrorPage.<init>(InternalErrorPage.java:23) [artifactory-web-application-2.1.3.jar:na]
      ... 65 common frames omitted

      PS: This is bad because the simple browser is much, much faster than the tree browser. You can also refresh the simple browser without losing state, i.e. current location

        Attachments

          Issue Links

            Activity

            elig Eli Givoni added a comment -

            Hello Costin,
            Thank you for your report.
            As you can see this issue was already fixed, so you can either remove your logo or upgrade your artifactory to 2.2.1 version.

            costin Costin Caraivan added a comment -

            Thanks for the tip, it worked.

            We can't upgrade right now, we'll try to upgrade as soon as possible though.
            However, in this version there's a problem with reset/save. I couldn't remove the logo from the interface - had to remove it by SSH. Is this a known issue? Even better, is this fixed in 2.2.1?

            Regards.

            elig Eli Givoni added a comment -

            Yes, this problem was also fixed in 2.2.0.

            costin Costin Caraivan added a comment -

            Ok. Thank you


              People

              • Assignee:
                yoavl Yoav Landman
                Reporter:
                costin Costin Caraivan
              • Votes:
                0 Vote for this issue
                Watchers:
                0 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: