Uploaded image for project: 'Artifactory Binary Repository'
  1. Artifactory Binary Repository
  2. RTFACT-400

EOF Exception while uploading a deployment from maven.

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: Blocker
    • Resolution: Incomplete
    • Affects Version/s: 1.2.5
    • Fix Version/s: None
    • Component/s: Deployer
    • Labels:
      None
    • Environment:

      MS Windows Server 2003 R2
      Java 1.6.0_01 b06

      Description

      Hi, I do a deployment using "mvn deploy -DrepositoryId=the-repo-id.". The project contains one super-pom and many sub-poms for the different sub-projects. All of them create jars, some of them end up with zips (through an assembly to have a deploy-able zip file). The ones only creating jars are uploaded to Artifactory without any problems. The first one with a zip (uploading the zip) will cause the following exception (excerpt from the "artifactory.log"):

      2008-05-28 17:23:59,703 [ERROR] (RepoFilter.java:151

      {10}) - Upload request failed
      org.mortbay.jetty.EofException
      at org.mortbay.jetty.HttpParser.parseNext(HttpParser.java:290)
      at org.mortbay.jetty.HttpParser$Input.blockForContent(HttpParser.java:1050)
      at org.mortbay.jetty.HttpParser$Input.read(HttpParser.java:999)
      at java.io.BufferedInputStream.read1(Unknown Source)
      at java.io.BufferedInputStream.read(Unknown Source)
      at java.io.BufferedInputStream.read1(Unknown Source)
      at java.io.BufferedInputStream.read(Unknown Source)
      at org.artifactory.checksum.ChecksumInputStream.read(ChecksumInputStream.java:53)
      at org.artifactory.checksum.ChecksumInputStream.read(ChecksumInputStream.java:44)
      at org.apache.jackrabbit.core.value.BLOBFileValue.<init>(BLOBFileValue.java:149)
      at org.apache.jackrabbit.core.value.BLOBFileValue.<init>(BLOBFileValue.java:121)
      at org.apache.jackrabbit.core.value.InternalValue.create(InternalValue.java:197)
      at org.apache.jackrabbit.core.PropertyImpl.setValue(PropertyImpl.java:753)
      at org.apache.jackrabbit.core.NodeImpl.setProperty(NodeImpl.java:2340)
      at org.artifactory.jcr.JcrHelper.importStream(JcrHelper.java:338)
      at org.artifactory.repo.JcrRepo$8.doInJcr(JcrRepo.java:406)
      at org.artifactory.repo.JcrRepo$8.doInJcr(JcrRepo.java:393)
      at org.artifactory.jcr.JcrHelper.doInSession(JcrHelper.java:210)
      at org.artifactory.repo.JcrRepo.saveResource(JcrRepo.java:391)
      at org.artifactory.engine.UploadEngine.process(UploadEngine.java:198)
      at org.artifactory.webapp.servlet.RepoFilter.doFilterInternal(RepoFilter.java:149)
      at org.artifactory.webapp.servlet.ArtifactoryFilter.doFilter(ArtifactoryFilter.java:95)
      at org.mortbay.jetty.servlet.ServletHandler$CachedChain.doFilter(ServletHandler.java:1084)
      at org.acegisecurity.ui.basicauth.BasicProcessingFilter.doFilter(BasicProcessingFilter.java:173)
      at org.artifactory.webapp.servlet.AccessFilter.doFilterInternal(AccessFilter.java:77)
      at org.artifactory.webapp.servlet.ArtifactoryFilter.doFilter(ArtifactoryFilter.java:95)
      at org.mortbay.jetty.servlet.ServletHandler$CachedChain.doFilter(ServletHandler.java:1084)
      at org.mortbay.jetty.servlet.ServletHandler.handle(ServletHandler.java:360)
      at org.mortbay.jetty.security.SecurityHandler.handle(SecurityHandler.java:216)
      at org.mortbay.jetty.servlet.SessionHandler.handle(SessionHandler.java:181)
      at org.mortbay.jetty.handler.ContextHandler.handle(ContextHandler.java:722)
      at org.mortbay.jetty.webapp.WebAppContext.handle(WebAppContext.java:404)
      at org.mortbay.jetty.handler.ContextHandlerCollection.handle(ContextHandlerCollection.java:206)
      at org.mortbay.jetty.handler.HandlerCollection.handle(HandlerCollection.java:114)
      at org.mortbay.jetty.handler.HandlerWrapper.handle(HandlerWrapper.java:139)
      at org.mortbay.jetty.Server.handle(Server.java:324)
      at org.mortbay.jetty.HttpConnection.handleRequest(HttpConnection.java:505)
      at org.mortbay.jetty.HttpConnection$RequestHandler.content(HttpConnection.java:842)
      at org.mortbay.jetty.HttpParser.parseNext(HttpParser.java:648)
      at org.mortbay.jetty.HttpParser.parseAvailable(HttpParser.java:205)
      at org.mortbay.jetty.HttpConnection.handle(HttpConnection.java:380)
      at org.mortbay.io.nio.SelectChannelEndPoint.run(SelectChannelEndPoint.java:395)
      at org.mortbay.thread.BoundedThreadPool$PoolThread.run(BoundedThreadPool.java:450)
      Caused by: java.io.IOException: Eine vorhandene Verbindung wurde vom Remotehost geschlossen
      at sun.nio.ch.SocketDispatcher.read0(Native Method)
      at sun.nio.ch.SocketDispatcher.read(Unknown Source)
      at sun.nio.ch.IOUtil.readIntoNativeBuffer(Unknown Source)
      at sun.nio.ch.IOUtil.read(Unknown Source)
      at sun.nio.ch.SocketChannelImpl.read(Unknown Source)
      at org.mortbay.io.nio.ChannelEndPoint.fill(ChannelEndPoint.java:128)
      at org.mortbay.jetty.HttpParser.parseNext(HttpParser.java:282)
      ... 42 more
      2008-05-28 17:24:22,421 [INFO ] (AbstractApplicationContext.java:672{10}

      ) - Closing org.artifactory.webapp.spring.ArtifactoryWebApplicationContext@1abcc03: display name [Root WebApplicationContext]; startup date [Wed May 28 13:38:30 CEST 2008]; root of context hierarchy
      2008-05-28 17:24:22,421 [INFO ] (SchedulerFactoryBean.java:977

      {10}) - Shutting down Quartz Scheduler
      2008-05-28 17:24:22,484 [WARN ] (DatabaseFileSystem.java:1068{10}

      ) - execute failed, about to reconnect...
      2008-05-28 17:25:02,765 [INFO ] (ArtifactoryContextConfigurer.java:41

      {10}) - Starting Artifactory...
      2008-05-28 17:25:02,781 [INFO ] (AbstractApplicationContext.java:378{10}

      ) - Refreshing org.artifactory.webapp.spring.ArtifactoryWebApplicationContext@c743eb: display name [Root WebApplicationContext]; startup date [Wed May 28 17:25:02 CEST 2008]; root of context hierarchy
      2008-05-28 17:25:03,000 [INFO ] (AbstractApplicationContext.java:393

      {10}) - Bean factory for application context [org.artifactory.webapp.spring.ArtifactoryWebApplicationContext@c743eb]: org.springframework.beans.factory.support.DefaultListableBeanFactory@1d439fe
      2008-05-28 17:25:03,093 [INFO ] (CentralConfigFactoryBean.java:55{10}

      ) - Loading configuration (using 'D:\artifactory-1.2.5\bin\../etc/artifactory.config.xml')...
      2008-05-28 17:25:03,093 [INFO ] (CentralConfigFactoryBean.java:57

      {10}) - Trying to load configuration from regular path file reosurce....
      2008-05-28 17:25:03,421 [INFO ] (CentralConfigFactoryBean.java:68{10}

      ) - Loaded configuration from 'D:\artifactory-1.2.5\bin\../etc/artifactory.config.xml'.
      2008-05-28 17:25:06,328 [WARN ] (CentralConfig.java:162

      {10}) - Could not determine server instance id from configuration. Using hostname instead.
      2008-05-28 17:25:06,843 [INFO ] (KeyVals.java :87{10}

      ) - Previous Artifactory revision is '1154'. Current revision is '1154'.
      2008-05-28 17:25:07,000 [INFO ] (SchedulerFactoryBean.java:879

      {10}) - Starting Quartz Scheduler now
      2008-05-28 17:25:07,203 [INFO ] (BackupHelper.java:88{10}

      ) - Backup activated with cron expression '0 0 /12 * * ?'.

      The Artifactory server does not break, but is not useable anymore and also block the complete system. After shuting it down and restarting it everythins is fine.

      I guess in the zip file contains some characters makes the server choke.

      It would be greate if this could be fixed very soon since it stop us from deploying stuff.

      Thanks a lot for your great work.

      Cheers, Rob.

        Attachments

          Activity

          yoavl Yoav Landman added a comment -

          Could you attach a sample zip that breaks deployment?

          robert.weissmann Robert Weissmann added a comment - - edited

          Hi Yoav,

          sorry but I cannot, because the data contained is confidential. To simple create one without the conf. data I have to prepare something. But I tried something else.

          I started artifact on my local machine (Windows 2000; Java 1.5.0_12-b04) and it works. Before I used a remote artifactory. The first thing you might think that it is not an atrifactory problem, but remember the jars get transfered without problems. Maybe this gives you a hint. If not, I will try to create a zip without conf. data which causes the same problem.

          yoavl Yoav Landman added a comment -

          Hi Rob,

          Of course if you could somehow provide a zip sanitized of any confidential info, that'd be the quickest step towards trying to reproduce this.
          If not, is there a way you with could try locally with the same vm as the remote one? (1.6.0_01 b06 ).
          Also, what is the size (roughly) of the zip and are you using a proxy to communicate with the remote Artifactory?

          yoavl Yoav Landman added a comment -

          Any updates on this Rob?
          Is it reproducible under the 1.3.0 betas?

          victorc Victor C added a comment -

          this file breaks the deployment. I get this message

          Unable to analyze uploaded file content. Cause: unexpected EOF

          andy_engel andreas engel added a comment -

          Hi,

          i have the same Problems described in this Issue.
          I deployed an jar to a artifactory repo with no warnings or errors in log.
          After downloading the deployed jar file i get the following error from WinZip by opening the jar:
          "Fehler [O:\...\...\...\*.jar]: In der Zip-Datei fehlen 16372 Bytes (es wird trotzdem versucht, die Datei zu bearbeiten)."

          I use Artifactory 2.2.0. Artifactory works an a solaris machine. My client-Computer works on a Win XP Profession SP2.

          Additional i get the following error when i try to deploy a war to artifactory:

          [INFO] Retrieving previous build number from Artifactory - Maven Repository Manager
          2010-10-29 10:14:41.828:INFO::Logging to StdErrLog::DEBUG=false via org.eclipse.jetty.util.log.StdErrLog
          [INFO] repository metadata for: 'snapshot emessage:emessage:2.4.0-SNAPSHOT' could not be found on repository: Artifactory - Maven Repository Manager, so will be created
          [DEBUG] Reading resolution-state from: D:\maven2_repos\emessage\emessage\2.4.0-SNAPSHOT\resolver-status.properties
          [DEBUG] Writing resolution-state to: D:\maven2_repos\emessage\emessage\2.4.0-SNAPSHOT\resolver-status.properties
          Uploading: http://maven-repository:8081/artifactory/VPS/emessage/emessage/2.4.0-SNAPSHOT/emessage-2.4.0-20101029.081441-1.war
          2010-10-29 10:15:13.609:WARN::EXCEPTION WagonExchange@17423413=PUT//maven-repository:8081/artifactory/VPS/emessage/emessage/2.4.0-SNAPSHOT/emessage-2.4.0-20101029.081441-1.war#9
          org.eclipse.jetty.io.EofException
          at org.eclipse.jetty.http.HttpGenerator.flushBuffer(HttpGenerator.java:857)
          at org.eclipse.jetty.client.HttpConnection.handle(HttpConnection.java:208)
          at org.eclipse.jetty.io.nio.SelectChannelEndPoint.run(SelectChannelEndPoint.java:437)
          at org.eclipse.jetty.util.thread.QueuedThreadPool$2.run(QueuedThreadPool.java:435)
          at java.lang.Thread.run(Thread.java:595)
          Caused by: java.io.IOException: Eine bestehende Verbindung wurde softwaregesteuert
          durch den Hostcomputer abgebrochen
          at sun.nio.ch.SocketDispatcher.write0(Native Method)
          at sun.nio.ch.SocketDispatcher.write(SocketDispatcher.java:33)
          at sun.nio.ch.IOUtil.writeFromNativeBuffer(IOUtil.java:104)
          at sun.nio.ch.IOUtil.write(IOUtil.java:60)
          at sun.nio.ch.SocketChannelImpl.write(SocketChannelImpl.java:302)
          at org.eclipse.jetty.io.nio.ChannelEndPoint.flush(ChannelEndPoint.java:166)
          at org.eclipse.jetty.io.nio.SelectChannelEndPoint.flush(SelectChannelEndPoint.java:223)
          at org.eclipse.jetty.http.HttpGenerator.flushBuffer(HttpGenerator.java:801)
          ... 4 more
          [INFO] ------------------------------------------------------------------------
          [INFO] BUILD FAILURE
          [INFO] ------------------------------------------------------------------------
          [INFO] Total time: 39.594s
          [INFO] Finished at: Fri Oct 29 10:15:13 CEST 2010
          [INFO] Final Memory: 15M/48M
          [INFO] ------------------------------------------------------------------------
          [ERROR] Failed to execute goal org.apache.maven.plugins:maven-deploy-plugin:2.4:deploy (default-deploy) on project emessage: Error deploying artifact: Transfer error: null: EofException: Eine bestehende Verbindung wurde softwaregesteuert
          durch den Hostcomputer abgebrochen
          -> [Help 1]
          org.apache.maven.lifecycle.LifecycleExecutionException: Failed to execute goal org.apache.maven.plugins:maven-deploy-plugin:2.4:deploy (default-deploy) on project emessage: Error deploying artifact: Transfer error: null
          at org.apache.maven.lifecycle.DefaultLifecycleExecutor.execute(DefaultLifecycleExecutor.java:585)
          at org.apache.maven.lifecycle.DefaultLifecycleExecutor.execute(DefaultLifecycleExecutor.java:324)
          at org.apache.maven.DefaultMaven.doExecute(DefaultMaven.java:247)
          at org.apache.maven.DefaultMaven.execute(DefaultMaven.java:104)
          at org.apache.maven.cli.MavenCli.execute(MavenCli.java:427)
          at org.apache.maven.cli.MavenCli.doMain(MavenCli.java:157)
          at org.apache.maven.cli.MavenCli.main(MavenCli.java:121)
          at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
          at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
          at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
          at java.lang.reflect.Method.invoke(Method.java:585)
          at org.codehaus.plexus.classworlds.launcher.Launcher.launchEnhanced(Launcher.java:290)
          at org.codehaus.plexus.classworlds.launcher.Launcher.launch(Launcher.java:230)
          at org.codehaus.plexus.classworlds.launcher.Launcher.mainWithExitCode(Launcher.java:409)
          at org.codehaus.plexus.classworlds.launcher.Launcher.main(Launcher.java:352)
          Caused by: org.apache.maven.plugin.MojoExecutionException: Error deploying artifact: Transfer error: null
          at org.apache.maven.plugin.deploy.DeployMojo.execute(DeployMojo.java:195)
          at org.apache.maven.plugin.DefaultBuildPluginManager.executeMojo(DefaultBuildPluginManager.java:105)
          at org.apache.maven.lifecycle.DefaultLifecycleExecutor.execute(DefaultLifecycleExecutor.java:577)
          ... 14 more
          Caused by: org.apache.maven.artifact.deployer.ArtifactDeploymentException: Error deploying artifact: Transfer error: null
          at org.apache.maven.artifact.deployer.DefaultArtifactDeployer.deploy(DefaultArtifactDeployer.java:92)
          at org.apache.maven.plugin.deploy.DeployMojo.execute(DeployMojo.java:173)
          ... 16 more
          Caused by: org.apache.maven.wagon.TransferFailedException: Transfer error: null
          at org.apache.maven.wagon.providers.http.JettyClientHttpWagon.handleException(JettyClientHttpWagon.java:280)
          at org.apache.maven.wagon.providers.http.JettyClientHttpWagon.put(JettyClientHttpWagon.java:533)
          at org.apache.maven.wagon.providers.http.JettyClientHttpWagon.put(JettyClientHttpWagon.java:481)
          at org.apache.maven.repository.legacy.DefaultWagonManager.putRemoteFile(DefaultWagonManager.java:498)
          at org.apache.maven.repository.legacy.DefaultWagonManager.putArtifact(DefaultWagonManager.java:450)
          at org.apache.maven.artifact.deployer.DefaultArtifactDeployer.deploy(DefaultArtifactDeployer.java:82)
          ... 17 more
          Caused by: org.eclipse.jetty.io.EofException
          at org.eclipse.jetty.http.HttpGenerator.flushBuffer(HttpGenerator.java:857)
          at org.eclipse.jetty.client.HttpConnection.handle(HttpConnection.java:208)
          at org.eclipse.jetty.io.nio.SelectChannelEndPoint.run(SelectChannelEndPoint.java:437)
          at org.eclipse.jetty.util.thread.QueuedThreadPool$2.run(QueuedThreadPool.java:435)
          at java.lang.Thread.run(Thread.java:595)
          Caused by: java.io.IOException: Eine bestehende Verbindung wurde softwaregesteuert
          durch den Hostcomputer abgebrochen
          at sun.nio.ch.SocketDispatcher.write0(Native Method)
          at sun.nio.ch.SocketDispatcher.write(SocketDispatcher.java:33)
          at sun.nio.ch.IOUtil.writeFromNativeBuffer(IOUtil.java:104)
          at sun.nio.ch.IOUtil.write(IOUtil.java:60)
          at sun.nio.ch.SocketChannelImpl.write(SocketChannelImpl.java:302)
          at org.eclipse.jetty.io.nio.ChannelEndPoint.flush(ChannelEndPoint.java:166)
          at org.eclipse.jetty.io.nio.SelectChannelEndPoint.flush(SelectChannelEndPoint.java:223)
          at org.eclipse.jetty.http.HttpGenerator.flushBuffer(HttpGenerator.java:801)
          ... 4 more
          [ERROR]
          [ERROR]
          [ERROR] For more information about the errors and possible solutions, please read the following articles:
          [ERROR] [Help 1] http://cwiki.apache.org/confluence/display/MAVEN/MojoExecutionException

          Can anyone help me to solve my problems?


            People

            • Assignee:
              yoavl Yoav Landman
              Reporter:
              robert.weissmann Robert Weissmann
            • Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: