Uploaded image for project: 'Artifactory Binary Repository'
  1. Artifactory Binary Repository
  2. RTFACT-6613

Newer version of postgres needed than necessary

    Details

    • Type: Bug
    • Status: Resolved
    • Priority: Normal
    • Resolution: Fixed
    • Affects Version/s: 3.2.0, 3.2.1, 3.2.1.1, 3.2.2
    • Fix Version/s: 3.3.0
    • Component/s: Database
    • Labels:
      None

      Description

      Recent versions of artifactory are requiring the use of postgres 9.2 or better. Since both RHEL 6 and vmware's vpostgres are based on 9.1 you cannot use the packages shipped by the distributors with artifactory.

      As far as I can tell the only incompatibility is the database creation scripts have one call to the LEFT() function. Other than that artifactory works fine on the older database releases.

      Since the change is trivial (change LEFT(var, len) to substr(var, 1, len)) and supporting the vendor's package release is useful, the change should be made.

        Attachments

          Activity

            People

            • Assignee:
              denebeim Jay Denebeim (Inactive)
              Reporter:
              denebeim Jay Denebeim (Inactive)
            • Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: