Uploaded image for project: 'Artifactory Binary Repository'
  1. Artifactory Binary Repository
  2. RTFACT-8040

docker pull of nonexistant repository causes confusing error message

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Open
    • Priority: 4 - Normal
    • Resolution: Unresolved
    • Affects Version/s: 4.0.2, 4.15.0
    • Fix Version/s: None
    • Component/s: Docker
    • Labels:
      None
    • Severity:
      Medium

      Description

      We've been very pleased with the Docker repository feature so far, thanks! One unfortunate bug is that the error message when you typo your repository name is very confusing:

      [steven@host]% docker pull docker.mycompany.com/invalid:wat
      Pulling repository docker.mycompany.com/invalid
      Error: Status 400 trying to pull repository invalid: "{\n  \"errors\" : [ {\n    \"status\" : 400,\n    \"message\" : \"Unsupported docker v1 repository request for 'docker-v2'\"\n  } ]\n}"
      

        Attachments

          Activity

              People

              Assignee:
              Unassigned
              Reporter:
              stevenschlansker Steven Schlansker (Inactive)
              Votes:
              6 Vote for this issue
              Watchers:
              6 Start watching this issue

                Dates

                Created:
                Updated:

                  Sync Status

                  Connection: RTFACT Sync
                  RTMID-8040 -
                  SYNCHRONIZED
                  • Last Sync Date: