Uploaded image for project: 'Artifactory Binary Repository'
  1. Artifactory Binary Repository
  2. RTFACT-8253

When both folder and files have the same name, the folder in the UI is behaved as a file


    • Type: Bug
    • Status: Resolved
    • Priority: Normal
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 5.0.0
    • Component/s: None
    • Labels:


      When you create a folder with with the same name as the file (for example: test.war, HelloWorldApp.ear, multi.jar) then you can not expend the folder to retrieve the file. You can only retrieve the file by going to the Simple Browser.

      Steps to reproduce:

      1. Create a repository (I've created a gradle-local with Gradle layout)
      2. Deploy file with one of the names above. For example: HelloWorldApp.ear. When deploying the files, deploy in the next format: HelloWorldApp.ear/HelloWorldApp.ear (HelloWorldApp.ear the first is name of the folder, the second is the file itself)
      3. Browse to the gradle-local repository and try to expend the HelloWorldApp.ear folder. It can not be expended.
      4. Browse using the Simple Browser --> It works, the folder can be expended.
      5. I've notice that this happens only with compressed files (Tried with jar, ear, war and tar. This did not happened when tried with jpg file).


          Issue Links



              • Assignee:
                nadavy Nadav Yogev
                alexeiv Alexei Vainshtein
              • Votes:
                2 Vote for this issue
                4 Start watching this issue


                • Created: