Uploaded image for project: 'TeamCity Artifactory Plug-in'
  1. TeamCity Artifactory Plug-in
  2. TCAP-322

Build number changed with Team City service messages is not used

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Resolved
    • Resolution: Done
    • Affects Version/s: 2.7.1
    • Fix Version/s: 2.8.0
    • Labels:
      None
    • Environment:

      Teamcity 2018.2.2

      Artifactory 6.3.3

      Description

      As already filed on [GitHub|http://example.com]:

       

      I have a build with three builds steps. In build step two I change the build number using TeamCity service messages:

      https://confluence.jetbrains.com/display/TCD7/Build+Script+Interaction+with+TeamCity#BuildScriptInteractionwithTeamCity-ReportingBuildNumber

      In step three I use a file spec to upload some artifacts and build information to Artifactory. In the Artifactory builds tab the build gets listed with its build counter as build id and not with the build number I set with the service message. The plugin should use the changed build number.

      The original build number before the second build step was equal to the build counter. Maybe the plugin does not recognize the update.

        Attachments

          Activity

            People

            Assignee:
            eyalb Eyal Ben Moshe [X] (Inactive)
            Reporter:
            julius.blank Julius Blank (Inactive)
            Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved: