[BAP-91] Bamboo 3.2 fails to start using Bamboo Artifactory Plug-in Created: 28/Jul/11  Updated: 18/Sep/11  Resolved: 18/Sep/11

Status: Resolved
Project: Bamboo Artifactory Plug-in
Component/s: None
Affects Version/s: 1.4.0
Fix Version/s: 1.4.2

Type: Bug Priority: Normal
Reporter: Joerg Stephan Assignee: Noam Y. Tenne (Inactive)
Resolution: Fixed Votes: 1
Labels: None

Attachments: Text File bamboo.log    

 Description   

After upgrading to the latest bamboo version (3.2), bamboo fails to start if one is using your plugin.
Following exceptions do occur:

2011-07-28 12:06:24,902 ERROR [main] [OsgiPlugin] Detected an error (BundleException) enabling the plugin 'com.atlassian.upm.atlassian-universal-plugin-manager-plugin' : Constraint violation for package 'org.codehaus.jackson.map.annotate' when resolving module 38.0 between existing import 38.0.org.codehaus.jackson.map.annotate BLAMED ON [[38.0] package; (&(package=org.codehaus.jackson.map.annotate)(version>=1.4.4))] and uses constraint 0.org.codehaus.jackson.map.annotate BLAMED ON [[38.0] package; (&(package=org.codehaus.jackson.xc)(version>=1.4.4)), [31.0] package; (&(package=org.codehaus.jackson.map.annotate)(version>=1.4.0))]. This error usually occurs when your plugin imports a package from another bundle with a specific version constraint and either the bundle providing that package doesn't meet those version constraints, or there is no bundle available that provides the specified package. For more details on how to fix this, see http://confluence.atlassian.com/x/1xy6D
2011-07-28 12:06:24,903 WARN [main] [OsgiPlugin] Unable to enable plugin 'com.atlassian.upm.atlassian-universal-plugin-manager-plugin'
com.atlassian.plugin.osgi.container.OsgiContainerException: Cannot start plugin: com.atlassian.upm.atlassian-universal-plugin-manager-plugin
at com.atlassian.plugin.osgi.factory.OsgiPlugin.enableInternal(OsgiPlugin.java:430)
at com.atlassian.plugin.impl.AbstractPlugin.enable(AbstractPlugin.java:237)
at com.atlassian.plugin.manager.PluginEnabler.actualEnable(PluginEnabler.java:114)
at com.atlassian.plugin.manager.PluginEnabler.enable(PluginEnabler.java:99)
at com.atlassian.plugin.manager.DefaultPluginManager.addPlugins(DefaultPluginManager.java:682)
at com.atlassian.plugin.manager.DefaultPluginManager.init(DefaultPluginManager.java:156)
at com.atlassian.bamboo.container.BambooContainer.init(BambooContainer.java:173)
at com.atlassian.bamboo.container.BambooContainer.initialise(BambooContainer.java:137)
at com.atlassian.bamboo.upgrade.UpgradeLauncher.initialiseBambooContainer(UpgradeLauncher.java:176)
at com.atlassian.bamboo.upgrade.UpgradeLauncher.upgradeAndStartBamboo(UpgradeLauncher.java:92)
at com.atlassian.bamboo.upgrade.UpgradeLauncher.contextInitialized(UpgradeLauncher.java:39)
at org.eclipse.jetty.server.handler.ContextHandler.startContext(ContextHandler.java:633)
at org.eclipse.jetty.servlet.ServletContextHandler.startContext(ServletContextHandler.java:228)
at org.eclipse.jetty.webapp.WebAppContext.startContext(WebAppContext.java:1160)
at org.eclipse.jetty.server.handler.ContextHandler.doStart(ContextHandler.java:576)
at org.eclipse.jetty.webapp.WebAppContext.doStart(WebAppContext.java:492)
at org.eclipse.jetty.util.component.AbstractLifeCycle.start(AbstractLifeCycle.java:55)
at org.eclipse.jetty.server.handler.HandlerWrapper.doStart(HandlerWrapper.java:93)
at org.eclipse.jetty.server.Server.doStart(Server.java:243)
at org.eclipse.jetty.util.component.AbstractLifeCycle.start(AbstractLifeCycle.java:55)
at com.atlassian.bamboo.server.Server.main(Server.java:77)
Caused by: org.osgi.framework.BundleException: Constraint violation for package 'org.codehaus.jackson.map.annotate' when resolving module 38.0 between existing import 38.0.org.codehaus.jackson.map.annotate BLAMED ON [[38.0] package; (&(package=org.codehaus.jackson.map.annotate)(version>=1.4.4))] and uses constraint 0.org.codehaus.jackson.map.annotate BLAMED ON [[38.0] package; (&(package=org.codehaus.jackson.xc)(version>=1.4.4)), [31.0] package; (&(package=org.codehaus.jackson.map.annotate)(version>=1.4.0))]
at org.apache.felix.framework.Felix.resolveBundle(Felix.java:3415)
at org.apache.felix.framework.Felix.startBundle(Felix.java:1709)
at org.apache.felix.framework.BundleImpl.start(BundleImpl.java:905)
at org.apache.felix.framework.BundleImpl.start(BundleImpl.java:892)
at com.atlassian.plugin.osgi.factory.OsgiPlugin.enableInternal(OsgiPlugin.java:402)
... 20 more
2011-07-28 12:06:24,903 ERROR [main] [PluginEnabler] Unable to enable plugin com.atlassian.upm.atlassian-universal-plugin-manager-plugin
com.atlassian.plugin.osgi.container.OsgiContainerException: Cannot start plugin: com.atlassian.upm.atlassian-universal-plugin-manager-plugin
at com.atlassian.plugin.osgi.factory.OsgiPlugin.enableInternal(OsgiPlugin.java:430)
at com.atlassian.plugin.impl.AbstractPlugin.enable(AbstractPlugin.java:237)
at com.atlassian.plugin.manager.PluginEnabler.actualEnable(PluginEnabler.java:114)
at com.atlassian.plugin.manager.PluginEnabler.enable(PluginEnabler.java:99)
at com.atlassian.plugin.manager.DefaultPluginManager.addPlugins(DefaultPluginManager.java:682)
at com.atlassian.plugin.manager.DefaultPluginManager.init(DefaultPluginManager.java:156)
at com.atlassian.bamboo.container.BambooContainer.init(BambooContainer.java:173)
at com.atlassian.bamboo.container.BambooContainer.initialise(BambooContainer.java:137)
at com.atlassian.bamboo.upgrade.UpgradeLauncher.initialiseBambooContainer(UpgradeLauncher.java:176)
at com.atlassian.bamboo.upgrade.UpgradeLauncher.upgradeAndStartBamboo(UpgradeLauncher.java:92)
at com.atlassian.bamboo.upgrade.UpgradeLauncher.contextInitialized(UpgradeLauncher.java:39)
at org.eclipse.jetty.server.handler.ContextHandler.startContext(ContextHandler.java:633)
at org.eclipse.jetty.servlet.ServletContextHandler.startContext(ServletContextHandler.java:228)
at org.eclipse.jetty.webapp.WebAppContext.startContext(WebAppContext.java:1160)
at org.eclipse.jetty.server.handler.ContextHandler.doStart(ContextHandler.java:576)
at org.eclipse.jetty.webapp.WebAppContext.doStart(WebAppContext.java:492)
at org.eclipse.jetty.util.component.AbstractLifeCycle.start(AbstractLifeCycle.java:55)
at org.eclipse.jetty.server.handler.HandlerWrapper.doStart(HandlerWrapper.java:93)
at org.eclipse.jetty.server.Server.doStart(Server.java:243)
at org.eclipse.jetty.util.component.AbstractLifeCycle.start(AbstractLifeCycle.java:55)
at com.atlassian.bamboo.server.Server.main(Server.java:77)
Caused by: org.osgi.framework.BundleException: Constraint violation for package 'org.codehaus.jackson.map.annotate' when resolving module 38.0 between existing import 38.0.org.codehaus.jackson.map.annotate BLAMED ON [[38.0] package; (&(package=org.codehaus.jackson.map.annotate)(version>=1.4.4))] and uses constraint 0.org.codehaus.jackson.map.annotate BLAMED ON [[38.0] package; (&(package=org.codehaus.jackson.xc)(version>=1.4.4)), [31.0] package; (&(package=org.codehaus.jackson.map.annotate)(version>=1.4.0))]
at org.apache.felix.framework.Felix.resolveBundle(Felix.java:3415)
at org.apache.felix.framework.Felix.startBundle(Felix.java:1709)
at org.apache.felix.framework.BundleImpl.start(BundleImpl.java:905)
at org.apache.felix.framework.BundleImpl.start(BundleImpl.java:892)
at com.atlassian.plugin.osgi.factory.OsgiPlugin.enableInternal(OsgiPlugin.java:402)
... 20 more



 Comments   
Comment by Christoph Feddersen [ 12/Aug/11 ]

Hi, we're running Bamboo 3.2 with version 1.4.1 now, but are still getting the exception during startup. The Atlassian universal plugin manager won't start if the artifactory plugin is installed, so that it's not possible to manage plugins in the Bamboo administration area. Bamboo starts fine without the Artifactory plugin, so we're pretty sure that the combination of the universal plugin manager 1.5 (latest version) and the Artifactory plugin are causing the conflict.

Exception:

2011-08-12 16:23:34,425 INFO [main] [UnrecognizedModuleDescriptorServiceTrackerCustomizer] Turned unrecognized plugin module com.atlassian.support.stp:webResourceManagerContextItem into module com.atlassian.support.stp:webResourceManagerContextItem (null)
2011-08-12 16:23:34,561 ERROR [main] [OsgiPlugin] Detected an error (BundleException) enabling the plugin 'com.atlassian.upm.atlassian-universal-plugin-manager-plugin' : Constraint violation for package 'org.codehaus.jackson.map.annotate' when resolving module 38.0 between existing import 38.0.org.codehaus.jackson.map.annotate BLAMED ON [[38.0] package; (&(package=org.codehaus.jackson.map.annotate)(version>=1.4.4))] and uses constraint 0.org.codehaus.jackson.map.annotate BLAMED ON [[38.0] package; (&(package=org.codehaus.jackson.xc)(version>=1.4.4)), [31.0] package; (&(package=org.codehaus.jackson.map.annotate)(version>=1.4.0))]. This error usually occurs when your plugin imports a package from another bundle with a specific version constraint and either the bundle providing that package doesn't meet those version constraints, or there is no bundle available that provides the specified package. For more details on how to fix this, see http://confluence.atlassian.com/x/1xy6D
2011-08-12 16:23:34,561 WARN [main] [OsgiPlugin] Unable to enable plugin 'com.atlassian.upm.atlassian-universal-plugin-manager-plugin'
com.atlassian.plugin.osgi.container.OsgiContainerException: Cannot start plugin: com.atlassian.upm.atlassian-universal-plugin-manager-plugin
at com.atlassian.plugin.osgi.factory.OsgiPlugin.enableInternal(OsgiPlugin.java:430)
at com.atlassian.plugin.impl.AbstractPlugin.enable(AbstractPlugin.java:237)
at com.atlassian.plugin.manager.PluginEnabler.actualEnable(PluginEnabler.java:114)
at com.atlassian.plugin.manager.PluginEnabler.enable(PluginEnabler.java:99)
at com.atlassian.plugin.manager.DefaultPluginManager.addPlugins(DefaultPluginManager.java:682)
at com.atlassian.plugin.manager.DefaultPluginManager.init(DefaultPluginManager.java:156)
at com.atlassian.bamboo.container.BambooContainer.init(BambooContainer.java:173)
at com.atlassian.bamboo.container.BambooContainer.initialise(BambooContainer.java:137)
at com.atlassian.bamboo.upgrade.UpgradeLauncher.initialiseBambooContainer(UpgradeLauncher.java:176)
at com.atlassian.bamboo.upgrade.UpgradeLauncher.upgradeAndStartBamboo(UpgradeLauncher.java:92)
at com.atlassian.bamboo.upgrade.UpgradeLauncher.contextInitialized(UpgradeLauncher.java:39)
at org.eclipse.jetty.server.handler.ContextHandler.startContext(ContextHandler.java:633)
at org.eclipse.jetty.servlet.ServletContextHandler.startContext(ServletContextHandler.java:228)
at org.eclipse.jetty.webapp.WebAppContext.startContext(WebAppContext.java:1160)
at org.eclipse.jetty.server.handler.ContextHandler.doStart(ContextHandler.java:576)
at org.eclipse.jetty.webapp.WebAppContext.doStart(WebAppContext.java:492)
at org.eclipse.jetty.util.component.AbstractLifeCycle.start(AbstractLifeCycle.java:55)
at org.eclipse.jetty.server.handler.HandlerWrapper.doStart(HandlerWrapper.java:93)
at org.eclipse.jetty.server.Server.doStart(Server.java:243)
at org.eclipse.jetty.util.component.AbstractLifeCycle.start(AbstractLifeCycle.java:55)
at com.atlassian.bamboo.server.Server.main(Server.java:77)
Caused by: org.osgi.framework.BundleException: Constraint violation for package 'org.codehaus.jackson.map.annotate' when resolving module 38.0 between existing import 38.0.org.codehaus.jackson.map.annotate BLAMED ON [[38.0] package; (&(package=org.codehaus.jackson.map.annotate)(version>=1.4.4))] and uses constraint 0.org.codehaus.jackson.map.annotate BLAMED ON [[38.0] package; (&(package=org.codehaus.jackson.xc)(version>=1.4.4)), [31.0] package; (&(package=org.codehaus.jackson.map.annotate)(version>=1.4.0))]
at org.apache.felix.framework.Felix.resolveBundle(Felix.java:3415)
at org.apache.felix.framework.Felix.startBundle(Felix.java:1709)
at org.apache.felix.framework.BundleImpl.start(BundleImpl.java:905)
at org.apache.felix.framework.BundleImpl.start(BundleImpl.java:892)
at com.atlassian.plugin.osgi.factory.OsgiPlugin.enableInternal(OsgiPlugin.java:402)
... 20 more
2011-08-12 16:23:34,562 ERROR [main] [PluginEnabler] Unable to enable plugin com.atlassian.upm.atlassian-universal-plugin-manager-plugin
com.atlassian.plugin.osgi.container.OsgiContainerException: Cannot start plugin: com.atlassian.upm.atlassian-universal-plugin-manager-plugin
at com.atlassian.plugin.osgi.factory.OsgiPlugin.enableInternal(OsgiPlugin.java:430)
at com.atlassian.plugin.impl.AbstractPlugin.enable(AbstractPlugin.java:237)
at com.atlassian.plugin.manager.PluginEnabler.actualEnable(PluginEnabler.java:114)
at com.atlassian.plugin.manager.PluginEnabler.enable(PluginEnabler.java:99)
at com.atlassian.plugin.manager.DefaultPluginManager.addPlugins(DefaultPluginManager.java:682)
at com.atlassian.plugin.manager.DefaultPluginManager.init(DefaultPluginManager.java:156)
at com.atlassian.bamboo.container.BambooContainer.init(BambooContainer.java:173)
at com.atlassian.bamboo.container.BambooContainer.initialise(BambooContainer.java:137)
at com.atlassian.bamboo.upgrade.UpgradeLauncher.initialiseBambooContainer(UpgradeLauncher.java:176)
at com.atlassian.bamboo.upgrade.UpgradeLauncher.upgradeAndStartBamboo(UpgradeLauncher.java:92)
at com.atlassian.bamboo.upgrade.UpgradeLauncher.contextInitialized(UpgradeLauncher.java:39)
at org.eclipse.jetty.server.handler.ContextHandler.startContext(ContextHandler.java:633)
at org.eclipse.jetty.servlet.ServletContextHandler.startContext(ServletContextHandler.java:228)
at org.eclipse.jetty.webapp.WebAppContext.startContext(WebAppContext.java:1160)
at org.eclipse.jetty.server.handler.ContextHandler.doStart(ContextHandler.java:576)
at org.eclipse.jetty.webapp.WebAppContext.doStart(WebAppContext.java:492)
at org.eclipse.jetty.util.component.AbstractLifeCycle.start(AbstractLifeCycle.java:55)
at org.eclipse.jetty.server.handler.HandlerWrapper.doStart(HandlerWrapper.java:93)
at org.eclipse.jetty.server.Server.doStart(Server.java:243)
at org.eclipse.jetty.util.component.AbstractLifeCycle.start(AbstractLifeCycle.java:55)
at com.atlassian.bamboo.server.Server.main(Server.java:77)
Caused by: org.osgi.framework.BundleException: Constraint violation for package 'org.codehaus.jackson.map.annotate' when resolving module 38.0 between existing import 38.0.org.codehaus.jackson.map.annotate BLAMED ON [[38.0] package; (&(package=org.codehaus.jackson.map.annotate)(version>=1.4.4))] and uses constraint 0.org.codehaus.jackson.map.annotate BLAMED ON [[38.0] package; (&(package=org.codehaus.jackson.xc)(version>=1.4.4)), [31.0] package; (&(package=org.codehaus.jackson.map.annotate)(version>=1.4.0))]
at org.apache.felix.framework.Felix.resolveBundle(Felix.java:3415)
at org.apache.felix.framework.Felix.startBundle(Felix.java:1709)
at org.apache.felix.framework.BundleImpl.start(BundleImpl.java:905)
at org.apache.felix.framework.BundleImpl.start(BundleImpl.java:892)
at com.atlassian.plugin.osgi.factory.OsgiPlugin.enableInternal(OsgiPlugin.java:402)
... 20 more

Comment by Joerg Stephan [ 16/Aug/11 ]

We are still experiencing the problem with the current version.

Comment by Noam Y. Tenne (Inactive) [ 16/Aug/11 ]

Hi Joerg, Christoph

Can you please describe the steps you took to upgrade the plugin?

Comment by Joerg Stephan [ 16/Aug/11 ]

In "/bamboo/bambooapp/webapp/WEB-INF/lib" we deleted the old jar and copied the the new jar (bamboo-artifactory-plugin-1.4.1.jar) to this location.

Comment by Christoph Feddersen [ 26/Aug/11 ]

Hi Noam,

any news regarding this issue? Can we provide more information that might help to identify the problem?
We can't use the plugin and the moment, which is a real pity.

Comment by Christoph Feddersen [ 26/Aug/11 ]

Logfile of Bamboo startup with DEBUG output for all OSGI related calls

Comment by Noam Y. Tenne (Inactive) [ 26/Aug/11 ]

We're still investigating since we're unable to reproduce this with the latest version of the plugin, but we'll keep you posted with any progress.

Comment by Christoph Feddersen [ 26/Aug/11 ]

I just uploaded our logfile with DEBUG ouput for all OSGI related calls. Looks like a conflict with the org.codehaus.jackson.map.annotate classes.

Comment by Noam Y. Tenne (Inactive) [ 28/Aug/11 ]

Hi Christoph,

We were able to reproduce the issue and we'll release a fix ASAP.

Comment by Christoph Feddersen [ 30/Aug/11 ]

Great! We'll try it as soon as it's available

Comment by Noam Y. Tenne (Inactive) [ 05/Sep/11 ]

Christoph,

We suspect that it's a bug in Bamboo; can you try to rename the plugin jar file by omitting the version number?
For example, if the plugin's named bamboo-artifactory-plugin-1.4.1.jar, change it to bamboo-artifactory-plugin.jar.
Does this solve the issue?

Comment by Christoph Feddersen [ 05/Sep/11 ]

Hi Noam,

it's indeed working with the renamed jar file. Will you report this bug to Atlassian or should we handle that?

Comment by Noam Y. Tenne (Inactive) [ 05/Sep/11 ]

I'll do it.

Comment by Eli Givoni [ 18/Sep/11 ]
1    |      at org.eclipse.jetty.server.handler.HandlerWrapper.doStart(HandlerWrapper.java:93)
1    |      at org.eclipse.jetty.server.Server.doStart(Server.java:243)
1    |      at org.eclipse.jetty.util.component.AbstractLifeCycle.start(AbstractLifeCycle.java:55)
1    |      at com.atlassian.bamboo.server.Server.main(Server.java:77)
1    |      at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
1    |      at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
1    |      at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
1    |      at java.lang.reflect.Method.invoke(Unknown Source)
1    |      at org.tanukisoftware.wrapper.WrapperSimpleApp.run(WrapperSimpleApp.java:240)
1    |      at java.lang.Thread.run(Unknown Source)
1    | Caused by: org.osgi.framework.BundleException: Unresolved constraint in bundle com.atlassian.oauth.atlassian-oauth-consumer-sal-plugin [28]: Unable to resolve 28.0: missing requirement [28.0] package;
package=org.slf4j)(version>=1.5.0))
1    |      at org.apache.felix.framework.Felix.resolveBundle(Felix.java:3409)
1    |      at org.apache.felix.framework.Felix.startBundle(Felix.java:1709)
1    |      at org.apache.felix.framework.BundleImpl.start(BundleImpl.java:905)
1    |      at org.apache.felix.framework.BundleImpl.start(BundleImpl.java:892)
1    |      at com.atlassian.plugin.osgi.factory.OsgiPlugin.enableInternal(OsgiPlugin.java:402)
1    |      ... 27 more
1    | 2011-09-18 10:17:21,046 ERROR [WrapperSimpleAppMain] [PluginEnabler] Unable to enable plugin com.atlassian.oauth.consumer.sal
1    | com.atlassian.plugin.osgi.container.OsgiContainerException: Cannot start plugin: com.atlassian.oauth.consumer.sal
1    |      at com.atlassian.plugin.osgi.factory.OsgiPlugin.enableInternal(OsgiPlugin.java:430)
1    |      at com.atlassian.plugin.impl.AbstractPlugin.enable(AbstractPlugin.java:237)
1    |      at com.atlassian.plugin.impl.AbstractDelegatingPlugin.enable(AbstractDelegatingPlugin.java:213)
1    |      at com.atlassian.plugin.manager.PluginEnabler.actualEnable(PluginEnabler.java:114)
1    |      at com.atlassian.plugin.manager.PluginEnabler.enable(PluginEnabler.java:99)
1    |      at com.atlassian.plugin.manager.DefaultPluginManager.addPlugins(DefaultPluginManager.java:682)
1    |      at com.atlassian.plugin.manager.DefaultPluginManager.init(DefaultPluginManager.java:156)
1    |      at com.atlassian.bamboo.container.BambooContainer.init(BambooContainer.java:173)
1    |      at com.atlassian.bamboo.container.BambooContainer.initialise(BambooContainer.java:137)
1    |      at com.atlassian.bamboo.upgrade.UpgradeLauncher.initialiseBambooContainer(UpgradeLauncher.java:176)
1    |      at com.atlassian.bamboo.upgrade.UpgradeLauncher.upgradeAndStartBamboo(UpgradeLauncher.java:92)
1    |      at com.atlassian.bamboo.upgrade.UpgradeLauncher.contextInitialized(UpgradeLauncher.java:39)
1    |      at org.eclipse.jetty.server.handler.ContextHandler.startContext(ContextHandler.java:633)
1    |      at org.eclipse.jetty.servlet.ServletContextHandler.startContext(ServletContextHandler.java:228)
1    |      at org.eclipse.jetty.webapp.WebAppContext.startContext(WebAppContext.java:1160)
1    |      at org.eclipse.jetty.server.handler.ContextHandler.doStart(ContextHandler.java:576)
1    |      at org.eclipse.jetty.webapp.WebAppContext.doStart(WebAppContext.java:492)
1    |      at org.eclipse.jetty.util.component.AbstractLifeCycle.start(AbstractLifeCycle.java:55)
1    |      at org.eclipse.jetty.server.handler.HandlerWrapper.doStart(HandlerWrapper.java:93)
1    |      at org.eclipse.jetty.server.Server.doStart(Server.java:243)
1    |      at org.eclipse.jetty.util.component.AbstractLifeCycle.start(AbstractLifeCycle.java:55)
1    |      at com.atlassian.bamboo.server.Server.main(Server.java:77)
1    |      at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
1    |      at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
1    |      at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
1    |      at java.lang.reflect.Method.invoke(Unknown Source)
1    |      at org.tanukisoftware.wrapper.WrapperSimpleApp.run(WrapperSimpleApp.java:240)
1    |      at java.lang.Thread.run(Unknown Source)
1    | Caused by: org.osgi.framework.BundleException: Unresolved constraint in bundle com.atlassian.oauth.atlassian-oauth-consumer-sal-plugin [28]: Unable to resolve 28.0: missing requirement [28.0] package;
package=org.slf4j)(version>=1.5.0))
1    |      at org.apache.felix.framework.Felix.resolveBundle(Felix.java:3409)
1    |      at org.apache.felix.framework.Felix.startBundle(Felix.java:1709)
1    |      at org.apache.felix.framework.BundleImpl.start(BundleImpl.java:905)
1    |      at org.apache.felix.framework.BundleImpl.start(BundleImpl.java:892)
1    |      at com.atlassian.plugin.osgi.factory.OsgiPlugin.enableInternal(OsgiPlugin.java:402)
1    |      ... 27 more
1    | 2011-09-18 10:17:21,440 ERROR [WrapperSimpleAppMain] [OsgiPlugin] Detected an error (BundleException) enabling the plugin 'com.atlassian.sal.bamboo' : Unresolved constraint in bundle com.atlassian.sal
boo [32]: Unable to resolve 32.0: missing requirement [32.0] package; (&(package=org.slf4j)(version>=1.5.0)).  This error usually occurs when your plugin imports a package from another bundle with a specific
sion constraint and either the bundle providing that package doesn't meet those version constraints, or there is no bundle available that provides the specified package. For more details on how to fix this,
http://confluence.atlassian.com/x/1xy6D
1    | 2011-09-18 10:17:21,441 WARN [WrapperSimpleAppMain] [OsgiPlugin] Unable to enable plugin 'com.atlassian.sal.bamboo'
1    | com.atlassian.plugin.osgi.container.OsgiContainerException: Cannot start plugin: com.atlassian.sal.bamboo
1    |      at com.atlassian.plugin.osgi.factory.OsgiPlugin.enableInternal(OsgiPlugin.java:430)
1    |      at com.atlassian.plugin.impl.AbstractPlugin.enable(AbstractPlugin.java:237)
1    |      at com.atlassian.plugin.impl.AbstractDelegatingPlugin.enable(AbstractDelegatingPlugin.java:213)
1    |      at com.atlassian.plugin.manager.PluginEnabler.actualEnable(PluginEnabler.java:114)
1    |      at com.atlassian.plugin.manager.PluginEnabler.enable(PluginEnabler.java:99)
1    |      at com.atlassian.plugin.manager.DefaultPluginManager.addPlugins(DefaultPluginManager.java:682)
1    |      at com.atlassian.plugin.manager.DefaultPluginManager.init(DefaultPluginManager.java:156)
1    |      at com.atlassian.bamboo.container.BambooContainer.init(BambooContainer.java:173)
1    |      at com.atlassian.bamboo.container.BambooContainer.initialise(BambooContainer.java:137)
1    |      at com.atlassian.bamboo.upgrade.UpgradeLauncher.initialiseBambooContainer(UpgradeLauncher.java:176)
1    |      at com.atlassian.bamboo.upgrade.UpgradeLauncher.upgradeAndStartBamboo(UpgradeLauncher.java:92)
1    |      at com.atlassian.bamboo.upgrade.UpgradeLauncher.contextInitialized(UpgradeLauncher.java:39)
1    |      at org.eclipse.jetty.server.handler.ContextHandler.startContext(ContextHandler.java:633)
1    |      at org.eclipse.jetty.servlet.ServletContextHandler.startContext(ServletContextHandler.java:228)
1    |      at org.eclipse.jetty.webapp.WebAppContext.startContext(WebAppContext.java:1160)
1    |      at org.eclipse.jetty.server.handler.ContextHandler.doStart(ContextHandler.java:576)
1    |      at org.eclipse.jetty.webapp.WebAppContext.doStart(WebAppContext.java:492)
1    |      at org.eclipse.jetty.util.component.AbstractLifeCycle.start(AbstractLifeCycle.java:55)
1    |      at org.eclipse.jetty.server.handler.HandlerWrapper.doStart(HandlerWrapper.java:93)
1    |      at org.eclipse.jetty.server.Server.doStart(Server.java:243)
1    |      at org.eclipse.jetty.util.component.AbstractLifeCycle.start(AbstractLifeCycle.java:55)
1    |      at com.atlassian.bamboo.server.Server.main(Server.java:77)
1    |      at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
1    |      at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
1    |      at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
1    |      at java.lang.reflect.Method.invoke(Unknown Source)
1    |      at org.tanukisoftware.wrapper.WrapperSimpleApp.run(WrapperSimpleApp.java:240)
1    |      at java.lang.Thread.run(Unknown Source)
1    | Caused by: org.osgi.framework.BundleException: Unresolved constraint in bundle com.atlassian.sal.bamboo [32]: Unable to resolve 32.0: missing requirement [32.0] package; (&(package=org.slf4j)(version>
.0))
1    |      at org.apache.felix.framework.Felix.resolveBundle(Felix.java:3409)
1    |      at org.apache.felix.framework.Felix.startBundle(Felix.java:1709)
1    |      at org.apache.felix.framework.BundleImpl.start(BundleImpl.java:905)
1    |      at org.apache.felix.framework.BundleImpl.start(BundleImpl.java:892)
1    |      at com.atlassian.plugin.osgi.factory.OsgiPlugin.enableInternal(OsgiPlugin.java:402)
1    |      ... 27 more
1    | 2011-09-18 10:17:21,442 ERROR [WrapperSimpleAppMain] [PluginEnabler] Unable to enable plugin com.atlassian.sal.bamboo
1    | com.atlassian.plugin.osgi.container.OsgiContainerException: Cannot start plugin: com.atlassian.sal.bamboo
1    |      at com.atlassian.plugin.osgi.factory.OsgiPlugin.enableInternal(OsgiPlugin.java:430)
1    |      at com.atlassian.plugin.impl.AbstractPlugin.enable(AbstractPlugin.java:237)
1    |      at com.atlassian.plugin.impl.AbstractDelegatingPlugin.enable(AbstractDelegatingPlugin.java:213)
1    |      at com.atlassian.plugin.manager.PluginEnabler.actualEnable(PluginEnabler.java:114)
1    |      at com.atlassian.plugin.manager.PluginEnabler.enable(PluginEnabler.java:99)
1    |      at com.atlassian.plugin.manager.DefaultPluginManager.addPlugins(DefaultPluginManager.java:682)
1    |      at com.atlassian.plugin.manager.DefaultPluginManager.init(DefaultPluginManager.java:156)
1    |      at com.atlassian.bamboo.container.BambooContainer.init(BambooContainer.java:173)
1    |      at com.atlassian.bamboo.container.BambooContainer.initialise(BambooContainer.java:137)
1    |      at com.atlassian.bamboo.upgrade.UpgradeLauncher.initialiseBambooContainer(UpgradeLauncher.java:176)
1    |      at com.atlassian.bamboo.upgrade.UpgradeLauncher.upgradeAndStartBamboo(UpgradeLauncher.java:92)
1    |      at com.atlassian.bamboo.upgrade.UpgradeLauncher.contextInitialized(UpgradeLauncher.java:39)
1    |      at org.eclipse.jetty.server.handler.ContextHandler.startContext(ContextHandler.java:633)
1    |      at org.eclipse.jetty.servlet.ServletContextHandler.startContext(ServletContextHandler.java:228)
1    |      at org.eclipse.jetty.webapp.WebAppContext.startContext(WebAppContext.java:1160)
1    |      at org.eclipse.jetty.server.handler.ContextHandler.doStart(ContextHandler.java:576)
1    |      at org.eclipse.jetty.webapp.WebAppContext.doStart(WebAppContext.java:492)
1    |      at org.eclipse.jetty.util.component.AbstractLifeCycle.start(AbstractLifeCycle.java:55)
1    |      at org.eclipse.jetty.server.handler.HandlerWrapper.doStart(HandlerWrapper.java:93)
1    |      at org.eclipse.jetty.server.Server.doStart(Server.java:243)
1    |      at org.eclipse.jetty.util.component.AbstractLifeCycle.start(AbstractLifeCycle.java:55)
1    |      at com.atlassian.bamboo.server.Server.main(Server.java:77)
1    |      at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
1    |      at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
1    |      at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
1    |      at java.lang.reflect.Method.invoke(Unknown Source)
1    |      at org.tanukisoftware.wrapper.WrapperSimpleApp.run(WrapperSimpleApp.java:240)
1    |      at java.lang.Thread.run(Unknown Source)
1    | Caused by: org.osgi.framework.BundleException: Unresolved constraint in bundle com.atlassian.sal.bamboo [32]: Unable to resolve 32.0: missing requirement [32.0] package; (&(package=org.slf4j)(version>
.0))
1    |      at org.apache.felix.framework.Felix.resolveBundle(Felix.java:3409)
1    |      at org.apache.felix.framework.Felix.startBundle(Felix.java:1709)
1    |      at org.apache.felix.framework.BundleImpl.start(BundleImpl.java:905)
1    |      at org.apache.felix.framework.BundleImpl.start(BundleImpl.java:892)
1    |      at com.atlassian.plugin.osgi.factory.OsgiPlugin.enableInternal(OsgiPlugin.java:402)
1    |      ... 27 more
1    | 2011-09-18 10:17:21,738 ERROR [WrapperSimpleAppMain] [OsgiPlugin] Detected an error (BundleException) enabling the plugin 'com.atlassian.upm.atlassian-universal-plugin-manager-plugin' : Unresolved con
int in bundle com.atlassian.upm.atlassian-universal-plugin-manager-plugin [36]: Unable to resolve 36.0: missing requirement [36.0] package; (&(package=org.slf4j)(version>=1.5.0)).  This error usually occurs
 your plugin imports a package from another bundle with a specific version constraint and either the bundle providing that package doesn't meet those version constraints, or there is no bundle available that
vides the specified package. For more details on how to fix this, see http://confluence.atlassian.com/x/1xy6D
1    | 2011-09-18 10:17:21,738 WARN [WrapperSimpleAppMain] [OsgiPlugin] Unable to enable plugin 'com.atlassian.upm.atlassian-universal-plugin-manager-plugin'
1    | com.atlassian.plugin.osgi.container.OsgiContainerException: Cannot start plugin: com.atlassian.upm.atlassian-universal-plugin-manager-plugin
1    |      at com.atlassian.plugin.osgi.factory.OsgiPlugin.enableInternal(OsgiPlugin.java:430)
1    |      at com.atlassian.plugin.impl.AbstractPlugin.enable(AbstractPlugin.java:237)
1    |      at com.atlassian.plugin.impl.AbstractDelegatingPlugin.enable(AbstractDelegatingPlugin.java:213)
1    |      at com.atlassian.plugin.manager.PluginEnabler.actualEnable(PluginEnabler.java:114)
1    |      at com.atlassian.plugin.manager.PluginEnabler.enable(PluginEnabler.java:99)
1    |      at com.atlassian.plugin.manager.DefaultPluginManager.addPlugins(DefaultPluginManager.java:682)
1    |      at com.atlassian.plugin.manager.DefaultPluginManager.init(DefaultPluginManager.java:156)
1    |      at com.atlassian.bamboo.container.BambooContainer.init(BambooContainer.java:173)
1    |      at com.atlassian.bamboo.container.BambooContainer.initialise(BambooContainer.java:137)
1    |      at com.atlassian.bamboo.upgrade.UpgradeLauncher.initialiseBambooContainer(UpgradeLauncher.java:176)
1    |      at com.atlassian.bamboo.upgrade.UpgradeLauncher.upgradeAndStartBamboo(UpgradeLauncher.java:92)
1    |      at com.atlassian.bamboo.upgrade.UpgradeLauncher.contextInitialized(UpgradeLauncher.java:39)
1    |      at org.eclipse.jetty.server.handler.ContextHandler.startContext(ContextHandler.java:633)
1    |      at org.eclipse.jetty.servlet.ServletContextHandler.startContext(ServletContextHandler.java:228)
1    |      at org.eclipse.jetty.webapp.WebAppContext.startContext(WebAppContext.java:1160)
1    |      at org.eclipse.jetty.server.handler.ContextHandler.doStart(ContextHandler.java:576)
1    |      at org.eclipse.jetty.webapp.WebAppContext.doStart(WebAppContext.java:492)
1    |      at org.eclipse.jetty.util.component.AbstractLifeCycle.start(AbstractLifeCycle.java:55)
1    |      at org.eclipse.jetty.server.handler.HandlerWrapper.doStart(HandlerWrapper.java:93)
1    |      at org.eclipse.jetty.server.Server.doStart(Server.java:243)
1    |      at org.eclipse.jetty.util.component.AbstractLifeCycle.start(AbstractLifeCycle.java:55)
1    |      at com.atlassian.bamboo.server.Server.main(Server.java:77)
1    |      at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
1    |      at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
1    |      at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
1    |      at java.lang.reflect.Method.invoke(Unknown Source)
1    |      at org.tanukisoftware.wrapper.WrapperSimpleApp.run(WrapperSimpleApp.java:240)
1    |      at java.lang.Thread.run(Unknown Source)
1    | Caused by: org.osgi.framework.BundleException: Unresolved constraint in bundle com.atlassian.upm.atlassian-universal-plugin-manager-plugin [36]: Unable to resolve 36.0: missing requirement [36.0] pack
 (&(package=org.slf4j)(version>=1.5.0))
1    |      at org.apache.felix.framework.Felix.resolveBundle(Felix.java:3409)
1    |      at org.apache.felix.framework.Felix.startBundle(Felix.java:1709)
1    |      at org.apache.felix.framework.BundleImpl.start(BundleImpl.java:905)
1    |      at org.apache.felix.framework.BundleImpl.start(BundleImpl.java:892)
1    |      at com.atlassian.plugin.osgi.factory.OsgiPlugin.enableInternal(OsgiPlugin.java:402)
1    |      ... 27 more
1    | 2011-09-18 10:17:21,814 ERROR [WrapperSimpleAppMain] [PluginEnabler] Unable to enable plugin com.atlassian.upm.atlassian-universal-plugin-manager-plugin
1    | com.atlassian.plugin.osgi.container.OsgiContainerException: Cannot start plugin: com.atlassian.upm.atlassian-universal-plugin-manager-plugin
1    |      at com.atlassian.plugin.osgi.factory.OsgiPlugin.enableInternal(OsgiPlugin.java:430)
1    |      at com.atlassian.plugin.impl.AbstractPlugin.enable(AbstractPlugin.java:237)
1    |      at com.atlassian.plugin.impl.AbstractDelegatingPlugin.enable(AbstractDelegatingPlugin.java:213)
1    |      at com.atlassian.plugin.manager.PluginEnabler.actualEnable(PluginEnabler.java:114)
1    |      at com.atlassian.plugin.manager.PluginEnabler.enable(PluginEnabler.java:99)
1    |      at com.atlassian.plugin.manager.DefaultPluginManager.addPlugins(DefaultPluginManager.java:682)
1    |      at com.atlassian.plugin.manager.DefaultPluginManager.init(DefaultPluginManager.java:156)
1    |      at com.atlassian.bamboo.container.BambooContainer.init(BambooContainer.java:173)
1    |      at com.atlassian.bamboo.container.BambooContainer.initialise(BambooContainer.java:137)
1    |      at com.atlassian.bamboo.upgrade.UpgradeLauncher.initialiseBambooContainer(UpgradeLauncher.java:176)
1    |      at com.atlassian.bamboo.upgrade.UpgradeLauncher.upgradeAndStartBamboo(UpgradeLauncher.java:92)
1    |      at com.atlassian.bamboo.upgrade.UpgradeLauncher.contextInitialized(UpgradeLauncher.java:39)
1    |      at org.eclipse.jetty.server.handler.ContextHandler.startContext(ContextHandler.java:633)
1    |      at org.eclipse.jetty.servlet.ServletContextHandler.startContext(ServletContextHandler.java:228)
1    |      at org.eclipse.jetty.webapp.WebAppContext.startContext(WebAppContext.java:1160)
1    |      at org.eclipse.jetty.server.handler.ContextHandler.doStart(ContextHandler.java:576)
1    |      at org.eclipse.jetty.webapp.WebAppContext.doStart(WebAppContext.java:492)
1    |      at org.eclipse.jetty.util.component.AbstractLifeCycle.start(AbstractLifeCycle.java:55)
1    |      at org.eclipse.jetty.server.handler.HandlerWrapper.doStart(HandlerWrapper.java:93)
1    |      at org.eclipse.jetty.server.Server.doStart(Server.java:243)
1    |      at org.eclipse.jetty.util.component.AbstractLifeCycle.start(AbstractLifeCycle.java:55)
1    |      at com.atlassian.bamboo.server.Server.main(Server.java:77)
1    |      at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
1    |      at sun.reflect.NativeMethodAccessorImpl.invoke(Unknown Source)
1    |      at sun.reflect.DelegatingMethodAccessorImpl.invoke(Unknown Source)
1    |      at java.lang.reflect.Method.invoke(Unknown Source)
1    |      at org.tanukisoftware.wrapper.WrapperSimpleApp.run(WrapperSimpleApp.java:240)
1    |      at java.lang.Thread.run(Unknown Source)
1    | Caused by: org.osgi.framework.BundleException: Unresolved constraint in bundle com.atlassian.upm.atlassian-universal-plugin-manager-plugin [36]: Unable to resolve 36.0: missing requirement [36.0] pack
 (&(package=org.slf4j)(version>=1.5.0))
1    |      at org.apache.felix.framework.Felix.resolveBundle(Felix.java:3409)
1    |      at org.apache.felix.framework.Felix.startBundle(Felix.java:1709)
1    |      at org.apache.felix.framework.BundleImpl.start(BundleImpl.java:905)
1    |      at org.apache.felix.framework.BundleImpl.start(BundleImpl.java:892)
1    |      at com.atlassian.plugin.osgi.factory.OsgiPlugin.enableInternal(OsgiPlugin.java:402)
1    |      ... 27 more
1    | 2011-09-18 10:17:22,014 INFO [WrapperSimpleAppMain] [WaitUntil] Plugins that have yet to be enabled: [com.atlassian.plugins.rest.atlassian-rest-module, com.atlassian.templaterenderer.api, com.atlassia
mplaterenderer.atlassian-template-renderer-velocity1.6-plugin, com.atlassian.auiplugin, com.atlassian.bamboo.plugins.rest, com.atlassian.oauth.consumer, com.atlassian.bamboo.plugins.feedback, com.atlassian.b
Comment by Eli Givoni [ 18/Sep/11 ]
1    | 2011-09-18 10:16:33,338 INFO [WrapperSimpleAppMain] [BambooContainer] Initing PluginManager...
1    | 2011-09-18 10:16:33,339 INFO [WrapperSimpleAppMain] [DefaultPluginManager] Initialising the plugin system
1    | 2011-09-18 10:16:33,968 INFO [WrapperSimpleAppMain] [ExportsBuilder] Package scan completed. Found 3364 packages to export.
1    | 2011-09-18 10:16:34,084 INFO [WrapperSimpleAppMain] [DefaultOsgiPersistentCache] Application upgrade detected, clearing OSGi cache directories
1    | 2011-09-18 10:16:34,515 WARN [Felix:Startup] [DefaultComponentRegistrar] Host component buildDefinitionConverter of instance com.atlassian.bamboo.fieldvalue.BuildDefinitionConverter@36019a has no inte
es
1    | 2011-09-18 10:16:35,647 ERROR [FelixStartLevel] [FelixOsgiContainerManager] Error starting file:/C:/Users/eli/bamboo-home/caches/plugins/framework-bundles/jcl-over-slf4j-1.5.8.jar
1    | org.osgi.framework.BundleException: Unresolved constraint in bundle jcl.over.slf4j [3]: Unable to resolve 3.0: missing requirement [3.0] package; (&(package=org.slf4j)(version>=1.5.8))
1    |      at org.apache.felix.framework.Felix.resolveBundle(Felix.java:3409)
1    |      at org.apache.felix.framework.Felix.startBundle(Felix.java:1709)
1    |      at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1143)
1    |      at org.apache.felix.framework.StartLevelImpl.run(StartLevelImpl.java:264)
1    |      at java.lang.Thread.run(Unknown Source)
1    | 2011-09-18 10:16:35,647 ERROR [FelixDispatchQueue] [FelixOsgiContainerManager] Framework error in bundle jcl.over.slf4j
1    | org.osgi.framework.BundleException: Unresolved constraint in bundle jcl.over.slf4j [3]: Unable to resolve 3.0: missing requirement [3.0] package; (&(package=org.slf4j)(version>=1.5.8))
1    |      at org.apache.felix.framework.Felix.resolveBundle(Felix.java:3409)
1    |      at org.apache.felix.framework.Felix.startBundle(Felix.java:1709)
1    |      at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1143)
1    |      at org.apache.felix.framework.StartLevelImpl.run(StartLevelImpl.java:264)
1    |      at java.lang.Thread.run(Unknown Source)
1    | 2011-09-18 10:16:36,079 ERROR [FelixStartLevel] [ContextLoaderListener] Unable to process extender configuration
1    | org.springframework.beans.factory.BeanCreationException: Error creating bean with name 'applicationContextCreator' defined in OSGi resource[bundle://2.0:0/META-INF/spring/extender/spring-event-bridge.
bnd.id=7|bnd.sym=org.springframework.osgi.extender]: Instantiation of bean failed; nested exception is java.lang.NoClassDefFoundError: org/slf4j/LoggerFactory
1    |      at org.springframework.beans.factory.support.ConstructorResolver.autowireConstructor(ConstructorResolver.java:254)
1    |      at org.springframework.beans.factory.support.AbstractAutowireCapableBeanFactory.autowireConstructor(AbstractAutowireCapableBeanFactory.java:925)
1    |      at org.springframework.beans.factory.support.AbstractAutowireCapableBeanFactory.createBeanInstance(AbstractAutowireCapableBeanFactory.java:835)
1    |      at org.springframework.beans.factory.support.AbstractAutowireCapableBeanFactory.doCreateBean(AbstractAutowireCapableBeanFactory.java:440)
1    |      at org.springframework.beans.factory.support.AbstractAutowireCapableBeanFactory$1.run(AbstractAutowireCapableBeanFactory.java:409)
1    |      at java.security.AccessController.doPrivileged(Native Method)
1    |      at org.springframework.beans.factory.support.AbstractAutowireCapableBeanFactory.createBean(AbstractAutowireCapableBeanFactory.java:380)
1    |      at org.springframework.beans.factory.support.AbstractBeanFactory$1.getObject(AbstractBeanFactory.java:264)
1    |      at org.springframework.beans.factory.support.DefaultSingletonBeanRegistry.getSingleton(DefaultSingletonBeanRegistry.java:222)
1    |      at org.springframework.beans.factory.support.AbstractBeanFactory.doGetBean(AbstractBeanFactory.java:261)
1    |      at org.springframework.beans.factory.support.AbstractBeanFactory.getBean(AbstractBeanFactory.java:185)
1    |      at org.springframework.beans.factory.support.AbstractBeanFactory.getBean(AbstractBeanFactory.java:164)
1    |      at org.springframework.beans.factory.support.DefaultListableBeanFactory.preInstantiateSingletons(DefaultListableBeanFactory.java:429)
1    |      at org.springframework.context.support.AbstractApplicationContext.finishBeanFactoryInitialization(AbstractApplicationContext.java:728)
1    |      at org.springframework.context.support.AbstractApplicationContext.refresh(AbstractApplicationContext.java:380)
1    |      at org.springframework.osgi.context.support.AbstractDelegatedExecutionApplicationContext.access$301(AbstractDelegatedExecutionApplicationContext.java:69)
1    |      at org.springframework.osgi.context.support.AbstractDelegatedExecutionApplicationContext$1.run(AbstractDelegatedExecutionApplicationContext.java:186)
1    |      at org.springframework.osgi.util.internal.PrivilegedUtils.executeWithCustomTCCL(PrivilegedUtils.java:85)
1    |      at org.springframework.osgi.context.support.AbstractDelegatedExecutionApplicationContext.normalRefresh(AbstractDelegatedExecutionApplicationContext.java:182)
1    |      at org.springframework.osgi.context.support.AbstractDelegatedExecutionApplicationContext$NoDependenciesWaitRefreshExecutor.refresh(AbstractDelegatedExecutionApplicationContext.java:89)
1    |      at org.springframework.osgi.context.support.AbstractDelegatedExecutionApplicationContext.refresh(AbstractDelegatedExecutionApplicationContext.java:175)
1    |      at org.springframework.osgi.extender.internal.support.ExtenderConfiguration.<init>(ExtenderConfiguration.java:169)
1    |      at org.springframework.osgi.extender.internal.activator.ContextLoaderListener.start(ContextLoaderListener.java:378)
1    |      at org.apache.felix.framework.util.SecureAction.startActivator(SecureAction.java:633)
1    |      at org.apache.felix.framework.Felix.activateBundle(Felix.java:1817)
1    |      at org.apache.felix.framework.Felix.startBundle(Felix.java:1734)
1    |      at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1143)
1    |      at org.apache.felix.framework.StartLevelImpl.run(StartLevelImpl.java:264)
1    |      at java.lang.Thread.run(Unknown Source)
1    | Caused by: java.lang.NoClassDefFoundError: org/slf4j/LoggerFactory
1    |      at com.atlassian.plugin.osgi.spring.NonValidatingOsgiApplicationContextCreator.<clinit>(NonValidatingOsgiApplicationContextCreator.java:27)
1    |      at sun.reflect.NativeConstructorAccessorImpl.newInstance0(Native Method)
1    |      at sun.reflect.NativeConstructorAccessorImpl.newInstance(Unknown Source)
1    |      at sun.reflect.DelegatingConstructorAccessorImpl.newInstance(Unknown Source)
1    |      at java.lang.reflect.Constructor.newInstance(Unknown Source)
1    |      at org.springframework.beans.BeanUtils.instantiateClass(BeanUtils.java:100)
1    |      at org.springframework.beans.factory.support.SimpleInstantiationStrategy.instantiate(SimpleInstantiationStrategy.java:87)
1    |      at org.springframework.beans.factory.support.ConstructorResolver.autowireConstructor(ConstructorResolver.java:248)
1    |      ... 28 more
1    | Caused by: java.lang.ClassNotFoundException: org.slf4j.LoggerFactory
1    |      at org.apache.felix.framework.ModuleImpl.findClassOrResourceByDelegation(ModuleImpl.java:772)
1    |      at org.apache.felix.framework.ModuleImpl.access$200(ModuleImpl.java:73)
1    |      at org.apache.felix.framework.ModuleImpl$ModuleClassLoader.loadClass(ModuleImpl.java:1690)
1    |      at java.lang.ClassLoader.loadClass(Unknown Source)
1    |      ... 36 more
1    | 2011-09-18 10:16:36,184 ERROR [FelixStartLevel] [FelixOsgiContainerManager] Error starting file:/C:/Users/eli/bamboo-home/caches/plugins/framework-bundles/spring-osgi-extender-1.2.1.jar
1    | org.springframework.beans.factory.BeanCreationException: Error creating bean with name 'applicationContextCreator' defined in OSGi resource[bundle://2.0:0/META-INF/spring/extender/spring-event-bridge.
bnd.id=7|bnd.sym=org.springframework.osgi.extender]: Instantiation of bean failed; nested exception is java.lang.NoClassDefFoundError: org/slf4j/LoggerFactory
1    |      at org.springframework.beans.factory.support.ConstructorResolver.autowireConstructor(ConstructorResolver.java:254)
1    |      at org.springframework.beans.factory.support.AbstractAutowireCapableBeanFactory.autowireConstructor(AbstractAutowireCapableBeanFactory.java:925)
1    |      at org.springframework.beans.factory.support.AbstractAutowireCapableBeanFactory.createBeanInstance(AbstractAutowireCapableBeanFactory.java:835)
1    |      at org.springframework.beans.factory.support.AbstractAutowireCapableBeanFactory.doCreateBean(AbstractAutowireCapableBeanFactory.java:440)
1    |      at org.springframework.beans.factory.support.AbstractAutowireCapableBeanFactory$1.run(AbstractAutowireCapableBeanFactory.java:409)
1    |      at java.security.AccessController.doPrivileged(Native Method)
1    |      at org.springframework.beans.factory.support.AbstractAutowireCapableBeanFactory.createBean(AbstractAutowireCapableBeanFactory.java:380)
1    |      at org.springframework.beans.factory.support.AbstractBeanFactory$1.getObject(AbstractBeanFactory.java:264)
1    |      at org.springframework.beans.factory.support.DefaultSingletonBeanRegistry.getSingleton(DefaultSingletonBeanRegistry.java:222)
1    |      at org.springframework.beans.factory.support.AbstractBeanFactory.doGetBean(AbstractBeanFactory.java:261)
1    |      at org.springframework.beans.factory.support.AbstractBeanFactory.getBean(AbstractBeanFactory.java:185)
1    |      at org.springframework.beans.factory.support.AbstractBeanFactory.getBean(AbstractBeanFactory.java:164)
1    |      at org.springframework.beans.factory.support.DefaultListableBeanFactory.preInstantiateSingletons(DefaultListableBeanFactory.java:429)
1    |      at org.springframework.context.support.AbstractApplicationContext.finishBeanFactoryInitialization(AbstractApplicationContext.java:728)
1    |      at org.springframework.context.support.AbstractApplicationContext.refresh(AbstractApplicationContext.java:380)
1    |      at org.springframework.osgi.context.support.AbstractDelegatedExecutionApplicationContext.access$301(AbstractDelegatedExecutionApplicationContext.java:69)
1    |      at org.springframework.osgi.context.support.AbstractDelegatedExecutionApplicationContext$1.run(AbstractDelegatedExecutionApplicationContext.java:186)
1    |      at org.springframework.osgi.util.internal.PrivilegedUtils.executeWithCustomTCCL(PrivilegedUtils.java:85)
1    |      at org.springframework.osgi.context.support.AbstractDelegatedExecutionApplicationContext.normalRefresh(AbstractDelegatedExecutionApplicationContext.java:182)
1    |      at org.springframework.osgi.context.support.AbstractDelegatedExecutionApplicationContext$NoDependenciesWaitRefreshExecutor.refresh(AbstractDelegatedExecutionApplicationContext.java:89)
1    |      at org.springframework.osgi.context.support.AbstractDelegatedExecutionApplicationContext.refresh(AbstractDelegatedExecutionApplicationContext.java:175)
1    |      at org.springframework.osgi.extender.internal.support.ExtenderConfiguration.<init>(ExtenderConfiguration.java:169)
1    |      at org.springframework.osgi.extender.internal.activator.ContextLoaderListener.start(ContextLoaderListener.java:378)
1    |      at org.apache.felix.framework.util.SecureAction.startActivator(SecureAction.java:633)
1    |      at org.apache.felix.framework.Felix.activateBundle(Felix.java:1817)
1    |      at org.apache.felix.framework.Felix.startBundle(Felix.java:1734)
1    |      at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1143)
1    |      at org.apache.felix.framework.StartLevelImpl.run(StartLevelImpl.java:264)
1    |      at java.lang.Thread.run(Unknown Source)
1    | Caused by: java.lang.NoClassDefFoundError: org/slf4j/LoggerFactory
1    |      at com.atlassian.plugin.osgi.spring.NonValidatingOsgiApplicationContextCreator.<clinit>(NonValidatingOsgiApplicationContextCreator.java:27)
1    |      at sun.reflect.NativeConstructorAccessorImpl.newInstance0(Native Method)
1    |      at sun.reflect.NativeConstructorAccessorImpl.newInstance(Unknown Source)
1    |      at sun.reflect.DelegatingConstructorAccessorImpl.newInstance(Unknown Source)
1    |      at java.lang.reflect.Constructor.newInstance(Unknown Source)
1    |      at org.springframework.beans.BeanUtils.instantiateClass(BeanUtils.java:100)
1    |      at org.springframework.beans.factory.support.SimpleInstantiationStrategy.instantiate(SimpleInstantiationStrategy.java:87)
1    |      at org.springframework.beans.factory.support.ConstructorResolver.autowireConstructor(ConstructorResolver.java:248)
1    |      ... 28 more
1    | Caused by: java.lang.ClassNotFoundException: org.slf4j.LoggerFactory
1    |      at org.apache.felix.framework.ModuleImpl.findClassOrResourceByDelegation(ModuleImpl.java:772)
1    |      at org.apache.felix.framework.ModuleImpl.access$200(ModuleImpl.java:73)
1    |      at org.apache.felix.framework.ModuleImpl$ModuleClassLoader.loadClass(ModuleImpl.java:1690)
1    |      at java.lang.ClassLoader.loadClass(Unknown Source)
1    |      ... 36 more
1    | 2011-09-18 10:16:36,185 ERROR [FelixDispatchQueue] [FelixOsgiContainerManager] Framework error in bundle org.springframework.osgi.extender
1    | org.osgi.framework.BundleException: Activator start error in bundle org.springframework.osgi.extender [7].
1    |      at org.apache.felix.framework.Felix.activateBundle(Felix.java:1864)
1    |      at org.apache.felix.framework.Felix.startBundle(Felix.java:1734)
1    |      at org.apache.felix.framework.Felix.setActiveStartLevel(Felix.java:1143)
1    |      at org.apache.felix.framework.StartLevelImpl.run(StartLevelImpl.java:264)
1    |      at java.lang.Thread.run(Unknown Source)
1    | Caused by: org.springframework.beans.factory.BeanCreationException: Error creating bean with name 'applicationContextCreator' defined in OSGi resource[bundle://2.0:0/META-INF/spring/extender/spring-ev
bridge.xml|bnd.id=7|bnd.sym=org.springframework.osgi.extender]: Instantiation of bean failed; nested exception is java.lang.NoClassDefFoundError: org/slf4j/LoggerFactory
1    |      at org.springframework.beans.factory.support.ConstructorResolver.autowireConstructor(ConstructorResolver.java:254)
1    |      at org.springframework.beans.factory.support.AbstractAutowireCapableBeanFactory.autowireConstructor(AbstractAutowireCapableBeanFactory.java:925)
1    |      at org.springframework.beans.factory.support.AbstractAutowireCapableBeanFactory.createBeanInstance(AbstractAutowireCapableBeanFactory.java:835)
1    |      at org.springframework.beans.factory.support.AbstractAutowireCapableBeanFactory.doCreateBean(AbstractAutowireCapableBeanFactory.java:440)
1    |      at org.springframework.beans.factory.support.AbstractAutowireCapableBeanFactory$1.run(AbstractAutowireCapableBeanFactory.java:409)
1    |      at java.security.AccessController.doPrivileged(Native Method)
1    |      at org.springframework.beans.factory.support.AbstractAutowireCapableBeanFactory.createBean(AbstractAutowireCapableBeanFactory.java:380)
1    |      at org.springframework.beans.factory.support.AbstractBeanFactory$1.getObject(AbstractBeanFactory.java:264)
1    |      at org.springframework.beans.factory.support.DefaultSingletonBeanRegistry.getSingleton(DefaultSingletonBeanRegistry.java:222)
1    |      at org.springframework.beans.factory.support.AbstractBeanFactory.doGetBean(AbstractBeanFactory.java:261)
1    |      at org.springframework.beans.factory.support.AbstractBeanFactory.getBean(AbstractBeanFactory.java:185)
1    |      at org.springframework.beans.factory.support.AbstractBeanFactory.getBean(AbstractBeanFactory.java:164)
1    |      at org.springframework.beans.factory.support.DefaultListableBeanFactory.preInstantiateSingletons(DefaultListableBeanFactory.java:429)
1    |      at org.springframework.context.support.AbstractApplicationContext.finishBeanFactoryInitialization(AbstractApplicationContext.java:728)
1    |      at org.springframework.context.support.AbstractApplicationContext.refresh(AbstractApplicationContext.java:380)
1    |      at org.springframework.osgi.context.support.AbstractDelegatedExecutionApplicationContext.access$301(AbstractDelegatedExecutionApplicationContext.java:69)
1    |      at org.springframework.osgi.context.support.AbstractDelegatedExecutionApplicationContext$1.run(AbstractDelegatedExecutionApplicationContext.java:186)
1    |      at org.springframework.osgi.util.internal.PrivilegedUtils.executeWithCustomTCCL(PrivilegedUtils.java:85)
1    |      at org.springframework.osgi.context.support.AbstractDelegatedExecutionApplicationContext.normalRefresh(AbstractDelegatedExecutionApplicationContext.java:182)
1    |      at org.springframework.osgi.context.support.AbstractDelegatedExecutionApplicationContext$NoDependenciesWaitRefreshExecutor.refresh(AbstractDelegatedExecutionApplicationContext.java:89)
1    |      at org.springframework.osgi.context.support.AbstractDelegatedExecutionApplicationContext.refresh(AbstractDelegatedExecutionApplicationContext.java:175)
1    |      at org.springframework.osgi.extender.internal.support.ExtenderConfiguration.<init>(ExtenderConfiguration.java:169)
1    |      at org.springframework.osgi.extender.internal.activator.ContextLoaderListener.start(ContextLoaderListener.java:378)
1    |      at org.apache.felix.framework.util.SecureAction.startActivator(SecureAction.java:633)
1    |      at org.apache.felix.framework.Felix.activateBundle(Felix.java:1817)
1    |      ... 4 more
1    | Caused by: java.lang.NoClassDefFoundError: org/slf4j/LoggerFactory
1    |      at com.atlassian.plugin.osgi.spring.NonValidatingOsgiApplicationContextCreator.<clinit>(NonValidatingOsgiApplicationContextCreator.java:27)
1    |      at sun.reflect.NativeConstructorAccessorImpl.newInstance0(Native Method)
1    |      at sun.reflect.NativeConstructorAccessorImpl.newInstance(Unknown Source)
1    |      at sun.reflect.DelegatingConstructorAccessorImpl.newInstance(Unknown Source)
1    |      at java.lang.reflect.Constructor.newInstance(Unknown Source)
1    |      at org.springframework.beans.BeanUtils.instantiateClass(BeanUtils.java:100)
1    |      at org.springframework.beans.factory.support.SimpleInstantiationStrategy.instantiate(SimpleInstantiationStrategy.java:87)
1    |      at org.springframework.beans.factory.support.ConstructorResolver.autowireConstructor(ConstructorResolver.java:248)
1    |      ... 28 more
1    | Caused by: java.lang.ClassNotFoundException: org.slf4j.LoggerFactory
1    |      at org.apache.felix.framework.ModuleImpl.findClassOrResourceByDelegation(ModuleImpl.java:772)
1    |      at org.apache.felix.framework.ModuleImpl.access$200(ModuleImpl.java:73)
1    |      at org.apache.felix.framework.ModuleImpl$ModuleClassLoader.loadClass(ModuleImpl.java:1690)
1    |      at java.lang.ClassLoader.loadClass(Unknown Source)
1    |      ... 36 more
1    | 2011-09-18 10:16:38,314 INFO [WrapperSimpleAppMain] [BambooPluginManager] Adding resource bundle: com.atlassian.bamboo.maven.sharing.i18n
1    | 2011-09-18 10:16:38,544 INFO [WrapperSimpleAppMain] [BambooPluginManager] Adding resource bundle: com.atlassian.bamboo.builder.clover.i18n
1    | 2011-09-18 10:16:38,791 INFO [WrapperSimpleAppMain] [BambooPluginManager] Adding resource bundle: com.atlassian.bamboo.plugin.dotnet.il8n
Generated at Tue May 21 12:34:10 UTC 2019 using JIRA 7.6.3#76005-sha1:8a4e38d34af948780dbf52044e7aafb13a7cae58.