[HAP-356] Build don't appear in Artifactory Created: 02/Nov/12  Updated: 05/Nov/12

Status: Open
Project: Jenkins Artifactory Plug-in
Component/s: None
Affects Version/s: None
Fix Version/s: None

Type: Bug Priority: Critical
Reporter: Pavel Assignee: Yossi Shaul
Resolution: Unresolved Votes: 0
Labels: None

Attachments: PNG File 1s.png     PNG File 2s.png     PNG File 3s.png     JPEG File screenshot-1.jpg     JPEG File screenshot-3.jpg     JPEG File screenshot-4.jpg     JPEG File screenshot-5.jpg    
Issue Links:
Relationship
is related to HAP-343 Wrong build retention date is sent in... Resolved

 Description   

Hi,

In our development environment we use Jenkins and Artifactory. Projects builds in Jenkins after that move to Artifactory. Unfortunately one of the projects after builds in Jenkins and moving to Artifactory, don't appear in artifacts.
Can you help with that?



 Comments   
Comment by Pavel [ 02/Nov/12 ]

Screenshots with this case:



Comment by Pavel [ 02/Nov/12 ]

.

Comment by Eli Givoni [ 02/Nov/12 ]

Hi Pavel,
1.What version of Artifactory and Jenkins Artifactory plugin are you using?
2.Can you see it in the UI, not coming from the Jenkins link?
3.Can you see it using the REST API http://wiki.jfrog.org/confluence/display/RTF/Artifactory%27s+REST+API#ArtifactorysRESTAPI-BuildRuns

Thanks,

Eli

Comment by Pavel [ 05/Nov/12 ]

Hi,

>1.What version of Artifactory and Jenkins Artifactory plugin are you using?
We are using Artifactory Pro Power Pack 2.6.4 (rev. 13153), Jenkins ver. 1.474, Jenkins Artifactory Plugin 2.1.2

>2.Can you see it in the UI, not coming from the Jenkins link?

>3. 3.Can you see it using the REST API http://wiki.jfrog.org/confluence/display/RTF/Artifactory%27s+REST+API#ArtifactorysRESTAPI-BuildRuns
It doesn't clear for me how use this API. Please add more details.

Comment by Yossi Shaul [ 05/Nov/12 ]

Pavel, you comment is not fully visible.
Anyway, it looks like you are suffering from a bug in the retention policy that was fixed in the latest version of the plugin - https://issues.jfrog.org/jira/browse/HAP-343.
Please upgrade and let us know if it works.

Generated at Wed Sep 18 01:14:06 UTC 2019 using JIRA 7.6.3#76005-sha1:8a4e38d34af948780dbf52044e7aafb13a7cae58.