[RTFACT-13631] Scheduled pull replication logs "http:" URLs although source server only supports "https:" Created: 06/Feb/17  Updated: 06/Feb/17

Status: Open
Project: Artifactory Binary Repository
Component/s: Replication
Affects Version/s: 4.7.7
Fix Version/s: None

Type: Bug Priority: Minor
Reporter: Hugh Greene Assignee: Unassigned
Resolution: Unresolved Votes: 0
Labels: None


 Description   

[You may well wish to downgrade this to "Issue Type: Cosmetic" and/or "Priority: Trivial".]

We have two Artifactory Pro 4.7.7 instances at different sites, one doing scheduled replication from the other. The source server is behind Apache which only allows HTTPS connections (though Artifactory's embedded tomcat allows HTTP from 127.0.0.1).

The destination server Artifactory logs show lines like this

2017-01-31 21:12:10,414 [replication-consumer-1485864660001-0] [INFO ] (o.a.r.HttpRepo :405) - [redacted-remote-repo] downloading http://[redacted source server]/artifactory/[redacted virtual repo]/[group]/[name]/[version]/[artifact].zip 8.38 KB

while the source Apache SSL logs (from a timezone 9h earlier) show this

[31/Jan/2017:12:12:06 +0000] [redacted destination server IP] TLSv1 DHE-RSA-AES256-SHA "HEAD /artifactory/[redacted virtual repo]/[group]/[name]/[version]/[artifact].zip HTTP/1.1" -
[31/Jan/2017:12:12:07 +0000] [redacted destination server IP] TLSv1 DHE-RSA-AES256-SHA "GET /artifactory/[redacted virtual repo]/[group]/[name]/[version]/[artifact].zip HTTP/1.1" 8577

So, the request is definitely going over HTTPS, but being logged as "http:".


Generated at Tue Feb 18 08:07:13 UTC 2020 using JIRA 7.6.16#76018-sha1:9ed376192612a49536ac834c64177a0fed6290f5.