[RTFACT-17459] Event-based pull replication does not sync recently added properties Created: 05/Sep/18  Updated: 26/Nov/18  Resolved: 31/Oct/18

Status: Resolved
Project: Artifactory Binary Repository
Component/s: None
Affects Version/s: 6.1.0
Fix Version/s: 6.6.0

Type: Bug Priority: Critical
Reporter: Nimer Bsoul Assignee: Yoaz Menda (Inactive)
Resolution: Cannot Reproduce Votes: 1
Labels: None

Issue Links:
Relationship
is related to RTFACT-15132 When pull replication set up, target ... Resolved

 Description   

When you setup Event-based pull with Enable Event Replication option enabled replication between a local repository on one server and a remote repository pointing to the local repository on another server, the replication of the artifact occurs accordingly but when adding a new property to the artifact on the local repository side*,* there is no event triggered to update the artifact on the remote repository side.

Steps to reproduce:

1 - Create a generic local repository on server1

2 -  Create a remote repository on server2 which points to the local repository on server1

3 - Enable replication on server2 remote repository with Enable Event Replication,  Sync Deleted Artifacts and  Sync Artifact Properties enabled in the replication configuration.

4 - Add a new property to the artifact on the local repository, and notice that the properties were not synced on the remote repository's side.
 
 


Generated at Tue Jul 23 02:03:39 UTC 2019 using JIRA 7.6.3#76005-sha1:8a4e38d34af948780dbf52044e7aafb13a7cae58.