[RTFACT-8253] When both folder and files have the same name, the folder in the UI is behaved as a file Created: 25/Sep/15  Updated: 14/Nov/17  Resolved: 31/Jan/17

Status: Resolved
Project: Artifactory Binary Repository
Component/s: None
Affects Version/s: None
Fix Version/s: 5.0.0

Type: Bug Priority: Normal
Reporter: Alexei Vainshtein Assignee: Nadav Yogev
Resolution: Fixed Votes: 2
Labels: None

Attachments: JPEG File GUI_Bug.jpg     JPEG File simple_browser.jpg    
Issue Links:
Duplicate
duplicates RTFACT-12672 When folder name has an extension in ... Resolved

 Description   

When you create a folder with with the same name as the file (for example: test.war, HelloWorldApp.ear, multi.jar) then you can not expend the folder to retrieve the file. You can only retrieve the file by going to the Simple Browser.

Steps to reproduce:

1. Create a repository (I've created a gradle-local with Gradle layout)
2. Deploy file with one of the names above. For example: HelloWorldApp.ear. When deploying the files, deploy in the next format: HelloWorldApp.ear/HelloWorldApp.ear (HelloWorldApp.ear the first is name of the folder, the second is the file itself)
3. Browse to the gradle-local repository and try to expend the HelloWorldApp.ear folder. It can not be expended.
4. Browse using the Simple Browser --> It works, the folder can be expended.
5. I've notice that this happens only with compressed files (Tried with jar, ear, war and tar. This did not happened when tried with jpg file).


Generated at Tue Apr 07 06:35:04 UTC 2020 using Jira 8.5.3#805003-sha1:b4933e02eaff29a49114274fe59e1f99d9d963d7.