[TCAP-318] Teamcity 2018 build info changed separator in full project name from double colon '::' to slash '/' Created: 14/Jul/18  Updated: 19/Nov/18  Resolved: 20/Aug/18

Status: Resolved
Project: TeamCity Artifactory Plug-in
Component/s: None
Affects Version/s: None
Fix Version/s: 2.7.1

Type: Bug Priority: Normal
Reporter: Matthew Wang Assignee: Eyal Ben Moshe
Resolution: Fixed Votes: 2
Labels: None

Issue Links:
Duplicate
is duplicated by TCAP-321 No Build Info with TeamCity 2018.1.1 Will Not Implement

 Description   

With TeamCity updated to 2018.1 the build name will contain a "/" by default. The build info will not be published correct. 

TeamCity used to separate the project and build configuration name with " :: ". Now they use " / " as a separator. This leads to a broken build information in latest Artifactory 6.0.2. Thus the link from TeamCity result page doesn't work and shows empty build page, same happens when you go from Builds page.

Sample log from artifactory "2018-06-22 11:01:46,940 [ajp-nio-8019-exec-8] [INFO ] (o.a.r.r.c.BuildResource:308) - Adding build 'test-projects / TestGradle / initial #12"

Sample log from teamcity build: "[:artifactoryDeploy] Build successfully deployed. Browse it in Artifactory under https://arturl/artifactory/webapp/builds/test-projects%20/%20TestGradle%20/%20initial/12"



 Comments   
Comment by Eyal Ben Moshe [ 01/Aug/18 ]

The following github issue discusses the same issue:

https://github.com/jfrog/teamcity-artifactory-plugin/issues/43

Generated at Thu Aug 22 05:02:11 UTC 2019 using JIRA 7.6.3#76005-sha1:8a4e38d34af948780dbf52044e7aafb13a7cae58.