Blank page when accessing Artifactory using Internet Explorer

When using Internet Explorer browser on version 4.0, some users may encounter a blank page when trying to access Artifactory's home page. 

 

CASE 1: This issue may occur due to some host resolved incorrectly by windows from your intranet DNS. 

 

To resolve this issue, go to Internet Options ? Security tab ? choose 'Local intranet' and click 'Sites' ? Enable 'automatically detect intranet network'. 

 

 

 

 

Now close the settings tabs and refresh the page.  

 

CASE 2: It maybe seen if Compatibility mode is enabled.

please ensure that Artifactory URL is not included in the Internet Explorer's Compatibility Mode (uncheck Intranet option). You can see the option by using the steps below or by visiting this documentation from Microsoft:

  1. Open the desktop, and then tap or click the Internet Explorer icon on the taskbar.

  2. Tap or click the Tools button Tools, and then tap or click Compatibility View settings.

CASE 3: Compatibility is forced on the browser by Group Policy:

  1. Open the webpage in Internet Explorer, press F12, or click  then click F12 developer tools.

     

  2. Click Browser Mode and see if Compatibility View is checked

     

     

  3. If Browser Mode is in Compatibility mode, although it is not enabled in Case 2 above, it may mean that your IT administrator has forced the compatibility mode on Group Policy  (see this link). Please consult your IT for assistance to see if Artifactory URL can be removed from the Compatibility list.